Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox is not displaying pages correctly.

  • 10 bhfreagra
  • 4 leis an bhfadhb seo
  • 1383 views
  • Freagra is déanaí ó Howieg

more options

Images are not showing. It works if I start in safe mode, but I don't know what extensions or plug ins are causing the problem. Tried to uninstall and reinstall, but all of the same plugins and extensions are still there. I cant seem to delete any of the extensions or plugins.

Réiteach roghnaithe

Did you try to disable hardware acceleration?

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Read this answer in context 👍 0

All Replies (10)

more options

Sorry, but looking at this again, it is actually some of the text that is missing.

more options

If images are missing then check that you do not block images from some domains.

  • Tap the Alt key or press F10 to show the Menu Bar

Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

more options

Browser is working if I go back to version 32. Anything newer does not work unless it is in safe mode. See pics attached for problem. I think it is a plugin that is causing this, but it seems to be extremely difficult to remove plugins and extensions. Help! I am about to dump firefox and switch to Chrome or back to IE.

more options

Do you have any content blocking extensions?

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

more options

Hi,

It works in safe mode, but normal mode only works in version 32, not in anything newer. Version 33 and 34 do not work in normal mode, even with all extensions disabled. I do not have any content blocking extensions.

more options

You can try to disable OMTC and leave hardware acceleration in Firefox enabled.

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Tried it, but it did not change anything. Still no good in normal mode.

more options

There is still no resolution to this problem. It works fine if I revert back to version 32.0 but anything after that is not working correctly. The program is also updating itself to the new version even though I have auto update turned off. Very very frustrating. Deleting Firefox and not returning. I will go to Chrome or Explorer.

more options

Réiteach Roghnaithe

Did you try to disable hardware acceleration?

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

This looks like it corrected the problem! Thank you for the support. Keeping firefox around for a while longer. :-)