X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox 32.0.3 no longer allows view page source. How can I replace this valuable tool?

Postáilte

One of the many valuable features of Firefox has been the ability to easily view the page or frame source of a website. I am a Perl developer and use this to detect bugs in my programs. However with the latest release of Firefox (32.0.3) I'm no longer able to display the source code generated by my Perl scripts. Is there any way to restore this functionality?

I tried prepending 'view-source:' to the URL but that doesn't work. It appears to send a new request to the server instead of showing me the source for the currently displayed page. Since I embed various debugging comments into the code I want to see the code for the currently displayed page.

Thank you for any help or guidance.

One of the many valuable features of Firefox has been the ability to easily view the page or frame source of a website. I am a Perl developer and use this to detect bugs in my programs. However with the latest release of Firefox (32.0.3) I'm no longer able to display the source code generated by my Perl scripts. Is there any way to restore this functionality? I tried prepending 'view-source:' to the URL but that doesn't work. It appears to send a new request to the server instead of showing me the source for the currently displayed page. Since I embed various debugging comments into the code I want to see the code for the currently displayed page. Thank you for any help or guidance.

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 15.0 r0
  • 1.5.0.5
  • Google Update
  • LogMeIn, Inc. Remote Access Components
  • ActiveTouch General Plugin Container Version 105
  • 5.1.30514.0
  • iTunes Detector Plug-in
  • McAfee MSC FF plugin DLL
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPWLPG

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0

Tuilleadh Eolais

skeeveatklah 0 réiteach 1 freagra

Freagra Cabhrach

I think control-u will do what you want. It does on mine.

I think control-u will do what you want. It does on mine.

Úinéir na ceiste

Unfortunately, this does not present the source code. Instead, I get the following message:

Document Expired

This document is no longer available.

The requested document is not available in Firefox's cache.

   As a security precaution, Firefox does not automatically re-request sensitive documents.
   Click Try Again to re-request the document from the website.
Unfortunately, this does not present the source code. Instead, I get the following message: Document Expired This document is no longer available. The requested document is not available in Firefox's cache. As a security precaution, Firefox does not automatically re-request sensitive documents. Click Try Again to re-request the document from the website.
cor-el
  • Top 10 Contributor
  • Moderator
17530 réiteach 158511 freagra

Are you running Firefox in Private Browsing mode?

Is the cache (memory and disk) enabled and working if you check that on the about:cache page?

Is there any POST data or AJAX request send to get those pages?


You can try to disable automatic cache management and set a fixed size.

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content
Are you running Firefox in Private Browsing mode? Is the cache (memory and disk) enabled and working if you check that on the <b>about:cache</b> page? Is there any POST data or AJAX request send to get those pages? ---- You can try to disable automatic cache management and set a fixed size. *Firefox/Tools > Options > Advanced > Network > Cached Web Content
jscher2000
  • Top 10 Contributor
8762 réiteach 71700 freagra

Freagra Cabhrach

For generated source including modifications made during and after loading by scripts in the page, there are a couple of tricks you can try:

(1) For the built-in source viewer: select the entire page (Ctrl+a) and then right-click > View Selection Source. You can click to clear the selection in the source viewer once it loads, as it can be annoying reading text that way.

(2) If you have a good syntax highlighting editor you want to use instead of the built-in source viewer: Ctrl+Shift+i to open the Inspector, right-click the html tag > Copy Outer HTML, then paste into a document in your editor.

For ''generated source'' including modifications made during and after loading by scripts in the page, there are a couple of tricks you can try: (1) For the built-in source viewer: select the entire page (Ctrl+a) and then right-click > View Selection Source. You can click to clear the selection in the source viewer once it loads, as it can be annoying reading text that way. (2) If you have a good syntax highlighting editor you want to use instead of the built-in source viewer: Ctrl+Shift+i to open the Inspector, right-click the html tag > Copy Outer HTML, then paste into a document in your editor.
errorprone 0 réiteach 8 freagra

Hi. Control-shift-i does nothing for me. Is there a different key combo for MacOSX? (I also tried Cntrl-Shift-i, Option-Shift-i, Cntrl-Option-I, Cmd-Shift-i -- no luck)

Hi. Control-shift-i does nothing for me. Is there a different key combo for MacOSX? (I also tried Cntrl-Shift-i, Option-Shift-i, Cntrl-Option-I, Cmd-Shift-i -- no luck)
jscher2000
  • Top 10 Contributor
8762 réiteach 71700 freagra

Hi errorprone, as you can see, the original poster was using Windows, so we focused on that OS.

You can look up keyboard shortcuts for Mac here:

https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#firefox:mac

(I got to that page using the Help menu > Keyboard Shortcuts)

Also, they usually are listed on the menu so in this case, you should be able to find them on either:

  • "3-bar" menu button > Developer
  • (menu bar) Tools > Web Developer
Hi errorprone, as you can see, the original poster was using Windows, so we focused on that OS. You can look up keyboard shortcuts for Mac here: https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#firefox:mac (I got to that page using the Help menu > Keyboard Shortcuts) Also, they usually are listed on the menu so in this case, you should be able to find them on either: * "3-bar" menu button > Developer * (menu bar) Tools > Web Developer
bigjim391 0 réiteach 2 freagra

Testing above in my 35.0, I have found highlighting the desired section or whole page(Cntrl-A), right click to View Selection Source .. . . an unreadable white page results with hidden text highlighted. Copy and paste that into Notepad and voila! There is source of page to the extent the author has allowed.

Testing above in my 35.0, I have found highlighting the desired section or whole page(Cntrl-A), right click to View Selection Source .. . . an unreadable white page results with hidden text highlighted. Copy and paste that into Notepad and voila! There is source of page to the extent the author has allowed.
bigjim391 0 réiteach 2 freagra

I would like to add that I think this to be a detriment. One of those "Let's fix what ain't broke" moves . . . my FF(35.0) still crashes all to often and they gotta mess with the View Source option . . . .

And to add salt to that wound wound, the dreaded IE (8.0.6.blah blah) displays when selecting View Page Source . .. . . tadaaaaa . . the page source code plain as day.

Perhaps an option in Settings to turn this useless feature on/off might be appropriate. If there is one, please tell me where. And default it to OFF.

I would like to add that I think this to be a detriment. One of those "Let's fix what ain't broke" moves . . . my FF(35.0) still crashes all to often and they gotta mess with the View Source option . . . . And to add salt to that wound wound, the dreaded IE (8.0.6.blah blah) displays when selecting View Page Source . .. . . tadaaaaa . . the page source code plain as day. Perhaps an option in Settings to turn this useless feature on/off might be appropriate. If there is one, please tell me where. And default it to OFF.