Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox crash when visiting Google+

  • 9 bhfreagra
  • 13 leis an bhfadhb seo
  • 2552 views
  • Freagra is déanaí ó bvaleriani

more options

Hello

Every time I open Firefox and then when I visit Google+, Firefox crashes. Then I see Error Report window where I click "restart firefox" and then everything is ok.

I submited crash report several times and I have this problem since version 30 and it persists now in version 31.

I'm using Ubuntu 14.04 32-bit so I opened firefox with terminal to see what's wrong and this is what I get:

(process:8059): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:8059): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(firefox:8059): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(firefox:8059): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(firefox:8059): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised

    • (firefox:8059): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed
    • (firefox:8059): CRITICAL **: gst_app_src_set_size: assertion 'GST_IS_APP_SRC (appsrc)' failed


Best regards

Réiteach roghnaithe

That looks like a problem with GStreamer.

Try to set the media.gstreamer.enabled pref to false on the about:config page.

Read this answer in context 👍 5

All Replies (9)

more options

Hi, Can you please copy the crash reports and paste them into a response? We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste that into the "Post a Reply" box. (Please don't take a screenshot of your crashes, just copy and paste the ID's. The below image is just an example of what your Firefox screen should look like)

aboutcrashesFx29

Thank you for your help!

More information and further troubleshooting steps can be found in the Troubleshoot Firefox crashes (closing or quitting unexpectedly) article.

more options

Hello

These are my crash ids:

bp-222af172-db84-4c2d-a614-4d0ba2140808 bp-f954ef6b-2af8-4767-bb88-4c3ee2140727 bp-fda8cb4f-59fc-426b-a580-79c4d2140726 bp-7d495ad9-6540-4b5e-b459-2732b2140726 bp-18e5db6a-15b1-449f-aaf7-89d152140724

more options

Réiteach Roghnaithe

That looks like a problem with GStreamer.

Try to set the media.gstreamer.enabled pref to false on the about:config page.

more options

I have the same problem - but there is no "media.gstreamer.enabled" preference in my config!

more options

If you are using windows then you won't see that preference, this is only for Linux.

Athraithe ag alenn ar

more options

Ah, ok - that makes sense... but I'm having the exact same issue as described.... crashes 100% of the time when going to any Google+ page.

Windows 7-64, latest FF, minimal plug-ins

more options

Report ID Date Submitted bp-67e7e395-413d-49f6-8f07-e9d372140821 21-Aug-2014 4:35 PM bp-da94bb50-34a7-4ac7-9ad5-031fa2140623 23-Jun-2014 12:28 PM bp-f293b777-9b3d-4aa6-852e-98b892140620 20-Jun-2014 11:17 AM bp-e43f19d7-7b9c-47d8-a3a9-2d5972140425 25-Apr-2014 6:47 PM bp-65fdd044-a2d4-454e-8c9e-de81a2140425 25-Apr-2014 6:46 PM

more options

Hi bvaleriani

That are out-of-memory crashes where all available memory is used up causing Firefox to crash.

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Did all that - made no difference. Something about Google+ that Firefox doesn't like at all!