Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

One word search in address bar not working.

  • 71 freagra
  • 128 leis an bhfadhb seo
  • Freagra is déanaí ó Lurker

more options

I've been away from my desktop for a week and now the searches in the address bar are not working. For example, I used to just type 'test' into the search bar and the tab would show a list of Google searches. Two words work though. Any and all help would be deeply appreciated. I've tried Search Reset, changing the keyword and fixup in about:config.

Réiteach roghnaithe

Thanks for the paste. Looks like this service based in Malaysia: ( Does it seem plausible that your ISP is using this service?? Even if it is, it should not be able to override the new way that address bar search works in Firefox 33.

I think the question of a bad extension was raised before. Have you tested in Firefox's Safe Mode to rule that out? It's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using either

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

Note: Flash and other plugins still run

After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (not Reset)

Any difference?

Read this answer in context 👍 0

All Replies (20)

more options

More bumps.

more options

I honestly don't think there's a way to fix this until an update (or possibly an extension) can figure it out. It looks like when you type 1 word, it tries to find it as a website first, and then goes to a search engine. I've noticed the delay, but it still eventually goes to the search results.

I found an extension called Smart Address Bar that might help. It changes the way searching in the address bar works, but allows you to use your search engine and bypasses the DNS lookup. Give it a shot and see if it helps:

more options

When you say there's no way to fix this, do you mean that the problem was introduced in a previous update ? Personally, it never went to the search engine for me.

However, since the update 32 earlier, it's gone crazy. Whenever I search for a phrase in the address bar, it gives me a server not found error. But, if I were to search the term on a tab and then switch to another tab, results will appear on both tabs although with significant delay.

more options

please try it with firefox 33 beta. as mentioned before it will no longer interpret a one word entry into the address bar as a domain, that it tries to resolve first, but sends it as a search term to your chosen engine right away:

more options

Unfortunately, the problem still exists for me even with beta. As far as I know, I wasnt using a beta version when it was working. So I dont understand why Firefox cant just roll back the update that screwed things up ?

more options

If you must know, Firefox 33 (beta) uses the search engine for 1 word searches, so it should work fine.

more options

Like I said, I've tried it and it did'nt work unfortunately.

more options

Firefox beta is now at version 33 with the problem resolved. Mozilla is not going to roll back to a previous version just because 1 user has a problem. I am no longer monitoring this thread.

more options

Firstly, I'm well aware that Firefox Beta V33 apparently has the problem resolved. However as I've said, it wasnt resolved for me. Second, I have never asked for anything even remotely connected to a roll back in order to fix my problem. I merely stated that everything was working fine a week before and I do not even know if there has been any update. Now I might be wrong but the information below the title of this topic seems to tell me that there are 43 others with this problem ? Regardless, this topic was made to search for a solution to the problem that I have. If you cant help me, fine. All I can do is to just bump this topic every few days until I get lucky.

more options

Try a new Profile to see if it works. - as a troubleshooting exercise

more options

Just tried that. Nothing, I'm afraid.

  1. 1
  2. 2
  3. 3
  4. 4