Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

v.31: using NoScript, initial homepage displayed properly, but subsequent tabs do not display properly

  • 2 fhreagra
  • 2 leis an bhfadhb seo
  • 7 views
  • Freagra is déanaí ó baroque-quest

more options

I am running FF with NoScript, "Never Remember History," "Tell sites I do not want to be tracked," an un-selected "Remember passwords for sites," and no Flash. My search engine is Duckduckgo. I use FF for private surfing. If I want to watch video, I use IE11.

With v.30 and before, I never could see how to configure FF to display my home page of duckduckgo.com when I created a new tab. But that's only a minor annoyance because I just click on the Home button.

Now with v.31, when I create a new tab I see nine rectangles where my history would be represented, if I had not turned it off. At the top is a search box with Duckduckgo. However, when I try to use the search box, I see a message "This page requires JavaScript. Get the non-JS version here."

What is the point of allowing my home page of Duckduckgo to display properly when FF is first displayed, but subsequent tabs require going to the bottom right of the screen and selecting NoScript's "Temporarily allow all this page" or clicking on the Home button? From my point of view, this is not an improvement, just something different to look at.

I set my home page to https://duckduckgo.com/html/, in other words, the version which FF suggested, but that changed nothing.

Réiteach roghnaithe

I don't need JavaScript enabled for the built-in new tab page, but it could be because I've turned off search suggestions.

Here's how to set your new tab page to DuckDuckGo:

(0) As the first step, copy the full URL from the address bar for the search page. You will paste this in step 3.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page -- paste here

Press Ctrl+t to open a new tab and verify that it worked. Success?

Read this answer in context 👍 0

All Replies (2)

more options

Réiteach Roghnaithe

I don't need JavaScript enabled for the built-in new tab page, but it could be because I've turned off search suggestions.

Here's how to set your new tab page to DuckDuckGo:

(0) As the first step, copy the full URL from the address bar for the search page. You will paste this in step 3.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page -- paste here

Press Ctrl+t to open a new tab and verify that it worked. Success?

more options

Thanks for the answer, jscher2000.

When I asked the question, I was slightly worried someone would say something like, "It's trivial, just check the oosy-blah box!" But the solution was definitely not intuitive.