Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

what version of firefox do I need to have my roboform work properly

  • 7 bhfreagra
  • 2 leis an bhfadhb seo
  • 4 views
  • Freagra is déanaí ó user633449

more options

I use Firefox for several web sites, but I NEED my roboform. It appears that there is a version of firefox that works well with Roboform and that is the version I need. where can I download it please? Of the 2, roboform is way more important to me than what browser I use, despite the fact that I like FF. If I can't have my roboform, then I will have to go back to using IE.

Réiteach roghnaithe

Or just transfer your passwords out of Roboform and use Firefox's default password manager. Password Manager - Remember, delete and edit logins and passwords in Firefox

Read this answer in context 👍 0

All Replies (7)

more options

Roboform Version 7.9.8 is compatible with Firefox 30. http://www.roboform.com/platforms/windows/firefox

Note: When Firefox is updated, Roboform also needs to be updated.

more options

Now I ask again - what version of FIREFOX do I need to work with my current version of Roboform? I have absolutely NO INTENTION of paying for another roboform program in order to update to their latest version, and this is what they tell me I need to do. So I either get an older version of Firefox that is compatible or I stop using it altogether

Carolyn

more options

If you've payed for roboform already you shouldn't need to pay again, you just update Roboform and update Firefox at the same time, it's free

more options

that is NOT what they are telling me. Apparently I paid for version 6.9 and the new version that works with Firefox is version 7.9. According to them I need to buy a new license, which I have no intention of doing.

more options

Roboform 6.9 was (IIRC) last compatible with Firefox 3.6. At the time Firefox 4 came out there was a big ruckus over Silber Systems (who make Roboform) "redefining" their interpretation of their "lifetime license"; users had to pay for the version 7 upgrade.

Mozilla doesn't want people to use old versions, so if you insist on sticking with that old version of Roboform please stick with the browser you have been using it with. Your security on the internet is more important to Mozilla than you not being able to use Firefox.

more options

ok thank you. I guess I will do that then.

Thanks for the help and information.

more options

Réiteach Roghnaithe

Or just transfer your passwords out of Roboform and use Firefox's default password manager. Password Manager - Remember, delete and edit logins and passwords in Firefox