Search Support

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox ask me to make it the default browser every time I start it.

  • 5 fhreagra
  • 5 leis an bhfadhb seo
  • 29147 views
  • Freagra is déanaí ó cor-el

more options

It does it everytime, I say yes. Then a window opens telling me to restart computer to update to lastest version. I am running ver 30 already, when I check this is says I'm up to date.

Réiteach roghnaithe

Open Tools->Options->Advanced settings page. 1. On the General tab switch off "Always check to see if Firefox...". 2. On the Update tab select "Never check for updates...". 3. "OK" and manually restart FF.

If the issue does not occur more try enable update checking on Tools->Options->Advanced->Update tab.

Read this answer in context 👍 2

All Replies (5)

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings, disables most add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".
Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Does the same thing in safe mode.

more options

Réiteach Roghnaithe

Open Tools->Options->Advanced settings page. 1. On the General tab switch off "Always check to see if Firefox...". 2. On the Update tab select "Never check for updates...". 3. "OK" and manually restart FF.

If the issue does not occur more try enable update checking on Tools->Options->Advanced->Update tab.

more options

That stopped it from asking to make default browser & does not want me to restart for latest update.

more options

Do a clean reinstall and delete the Firefox program before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.