Search Support

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox crashes

  • 18 freagra
  • 3 leis an bhfadhb seo
  • 486 views
  • Freagra is déanaí ó johnhwatson71

more options

Crash ID: bp-e4c09508-0bad-4105-8bf9-752282140618

I don't know how to fix this.

Things I have tried with no success:

- resetting Firefox - start up in safe mode -start up with add-ons disabled -start up with no add ons at all -disabled hardware acceleration

none of these things worked.

I am a running a brand new 2014 imac with OS X 10.9.3

These crashes happen AT LEAST 3 times a day. Once on every startup, and then completely randomly throughout usage.

Réiteach roghnaithe

Note Safe Mode disables hardware acceleration.

As a workaround it seems you may be able to avoid crashes by leaving Hardware Acceleration disabled.

If I understand you correctly it does crash if all of 11 plugins are enabled but not if all plugins are disabled.

Testing and bisecting the range of plugins will narrow that down. If it is a single plugin in takes about 4 steps to identify.

  1. enable first 6,
  2. if it crashes enable first 3 (ELSE test other 5 of 11)
  3. if it still crashes test first 2 (ELSE test number 3 that should be the cause)
  4. Test first 1 if it crashes that is the cause (ELSE test number 2 it should be the cause)
Read this answer in context 👍 0

All Replies (18)

more options

Not sure the reason and you seem to be trying the correct things, but can you post two or three very recent crash IDs from using Firefox in Safe Mode and with all plugins disabled.

more options

Well it seems to be working in safe mode (everything disabled now), So I tried it again, and...

Crash ID: bp-3d97eb41-2782-4e41-8c4d-971fd2140618

here is another one that just happened.

it has to be an add on or a plug in i have. I just don't know how to tell which one =/

more options

Try then to see if you crash

  • In safemode but with all addons plugins.
    (If so hardware acceleration or a plugin may be the issue)
  • In ordinary mode but with all plugins and all addons disabled
    (If so one of the extensions or plugins may be the problem)

Which of the above prevents crashes? Then maybe try with half of your adons at a time to try to narrow down if a particular one is causing the crashes.

Athraithe ag John99 ar

more options

How do I do safe mode with add-ons? It doesn't let me have them enabled in safe mode.

more options

Okay so as of right now:

Normal mode | all add ons disabled | HW acceleration enabled| -working just fine. (however crashes are always random, so i have no idea how reliable my current session is)

I don't know how to enable addons in safe mode to try that method.

more options

Okay. So I'm about 95% certain it was the DivX Web Player that was causing my issues. I removed anything DivX from my computer. So we'll see if that was the source or not.

When I was testing out each add on, the DivX one is the only one that gave me a problem on its own. So hopefully that was it. Guess we'll see.

as of right now. normal mode, add ons (minus divx) and hw accelration enabled, seems to be working fine. time will tell.

more options

Sorry, I see what I originally wrote was nonsense and have corrected it.

You seem to have worked out DivX is the culprit. I have not noticed recent posts about that , but there were some old threads mentioning crashes or memory issues.

It may also be worth checking that the DivX software is up to date.

Also check your video drivers are up to date (Or conversely try rolling them back if they updated recently)

more options

Alright, so it turns out that DivX was not the culprit as I experienced another crash.

So i have disabled HW acceleration and no crashes yet. Here is the issue. I have a brand new iMac 2014. With all the latest software and OS updates installed. This includes drivers for my graphics, which is using a NVIDIA GeForce GT 750M.

So I have no new drivers to update to, to my knowledge.

So I'm kind of at a loss. Do I just not use hardware acceleration at all?

I didn't have this issue with chrome. But i don't want to go back to chrome.

more options

When does it NOT crash ?

  • In Firefox Safe Mode with all plugins disabled ?
    Or if it does crash like that paste in the Crash IDs please.

What minimal changes need to be made then to see the crashes occurring.


For forum cross referencing

  • Reports for your Crash IDs :
    1. bp-e4c09508-0bad-4105-8bf9-752282140618
    2. bp-3d97eb41-2782-4e41-8c4d-971fd2140618
  • Crash Signatures
    1. Signature: js::GCThingTraceKind(void*)
    2. Signature: js::ShapeTable::search(jsid, bool)
      • Related bug
        1020805 NEW --- crash in js::ShapeTable::search(jsid, bool)

(Not crash reports that give me any clues I find useful unfortunately )

more options

It doesn't crash when: - normal mode - add ons disabled - HW acceleration enabled

or -normal mode - add ons enabled - HW acceleration disabled

or - safe mode - add ons/plugins disabled - HW acceleration enabled or disabled

these are the three instances where I experience no crashing.

When I do crash: -normal mode -add ons/plug in enabled -HW accelerations enabled (there are no new drivers for my OS at this time, I have the most up to date drivers)

more options

I also removed another add on called "flash video downloader", and am running: -normal mode -add ons enabled -HW acceleration enabled

for about an hour now with no crashes as of yet.

more options

well so much for that theory:

here is the most recent crash report Crash ID: bp-ca0615d1-0bbe-41a1-91c7-884962140618

more options

I would go for Add-ons enabled and hardware acceleration disabled unless you can identify extensions that contribute to this problem.

Aren't you able to identify an extension or theme that causes this issue? I can hardly believe that any extension is causing Firefox to crash.

You can also try a new profile.

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

more options

I have no themes, just the default one. and no...I have not been able to pinpoint any specific add on or plugin that can be causing this.

I don't know if it the hardware acceleration because it works in normal mode when the add ons are disabled

Also, I already tried with resetting firefox and making a new profile. Should I try it again?

more options

Réiteach Roghnaithe

Note Safe Mode disables hardware acceleration.

As a workaround it seems you may be able to avoid crashes by leaving Hardware Acceleration disabled.

If I understand you correctly it does crash if all of 11 plugins are enabled but not if all plugins are disabled.

Testing and bisecting the range of plugins will narrow that down. If it is a single plugin in takes about 4 steps to identify.

  1. enable first 6,
  2. if it crashes enable first 3 (ELSE test other 5 of 11)
  3. if it still crashes test first 2 (ELSE test number 3 that should be the cause)
  4. Test first 1 if it crashes that is the cause (ELSE test number 2 it should be the cause)
more options

My safe mode doesn't disable hardware acceleration. Should it?

I tried what the above person said and made a new profile and deleted the old one. no problems thus far.

going to slowly add the addons. and if i get problems again, i will try your method.

more options

Hardware acceleration does seem to be the culprit here, but seemingly still only when add ons are enabled. Crash ID: bp-9c50b383-9d23-4abe-ba8a-d72d32140619

is this an issue with my hardware or something else? I got this computer less than a month ago. I guess something could be defective?

what is: EXC_BAD_ACCESS / KERN_INVALID_ADDRESS ?

that seems to be the crash reason every time.

Athraithe ag johnhwatson71 ar

more options

just wanted to give an update.

have since disabled HW acceleration for good, and tried to reproduce the crash and have not been able to thus far. And I have all my add ons and plug ins enabled. So I'm pretty sure that was the issue.

Also, just to be safe, I did an Apple Diagnostic on my hardware and no problems were found with my graphics card.

Also, creating a new profile I think helped somewhat. So hopefully, no more crashes. hopefully the acceleration bug is fixed eventually.

thank you for all the assistance!