Search Support

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

firefox 30 spell check not working

  • 16 freagra
  • 50 leis an bhfadhb seo
  • 14586 views
  • Freagra is déanaí ó cor-el

more options

Since updating Firefox to version 30 when i am entering email info etc--spell check is not underling in red spelling mistakes

Réiteach roghnaithe

Yes, that is quite likely. Note that is is generally not recommended to edit files used by Firefox while Firefox is running.

Read this answer in context 👍 0

All Replies (16)

more options

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

more options

There is an obvious disconnect in your post on this subject since there is no such option under Tools in Version 30. There is a "Check my spelling as I type" option in Preferences -> Advanced.

Is there even anybody looking at this problem that I have experienced since at least Version 24? I used to be able to enable spell checking for posts to a heavily used morningstar.com forum that has many very educated users, and it is indeed embarrassing to post statements with spelling errors. Where did it go???

I have installed the dictionary over and over with absolutely NO effect. Is it possible that there is a conflict with installed Add-Ons? At about the time my spell checking failed, I installed the Add-On Ghostery.

more options

Cor-el was responding to a Windows user as it is indeed Tools > Options while on Mac OSX it is Firefox > Preferences and on Linux it is Edit > Preferences.

Note that only en-US and one or two other locales of Firefox comes with a dictionary due to licensing reasons ever sine inline spell check existed starting Firefox 2.0

Also need to make sure the dictionary extension is enabled in Addons Manager and you have it selected in the Languages in right-click.

more options

Thank you for clarifying since I am indeed running a Mac.

I went into Add-Ons as recommended and there is one for English United States (en-US) Spellchecker 7.0 and it appears to be active since it asks if I want to remove it.

I went back into the morningstar.com forum, checked that spell checking is on and purposely misspelled several words. It detected nothing as it has since about Version 24. It is interesting that it seems to be doing a nice job on this reply since I am pretty good at fat-finger typing!!!

Maybe it's time for me to address this problem to Morningstar????

Thank you for your suggestions.

more options

Does that forum have its own spellchecker feature? If so, that website can override the Firefox built-in spellchecker.

Also, if you are using the en-US version of Firefox which contains a spellcheck dictionary already, you don't need to install a spellcheck add-on for English United States (en-US).

more options

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Firefox > Preferences > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

more options

Although spell check IS working, I know it is accepting one word that is misspelled. Is there any way I can correct this? Thank you.

The word is preforming.

more options

It is an existing word:

You would have to edit the dictionary file in the dictionaries folder in the Firefox program folder and remove that entry if you do not want it to be recognized as a valid word if you swap the two letters too often.

Athraithe ag cor-el ar

more options

Okay. I meant to use the other word, so I simply have to be more careful.

But what if it wasn't a real word?

more options

See my above reply. I had edited it afterward and added steps to remove this word from the dictionary file.

more options

Easy enough. Thank you. It looks like I have to restart Firefox for the change to take effect. Right?

more options

Réiteach Roghnaithe

Yes, that is quite likely. Note that is is generally not recommended to edit files used by Firefox while Firefox is running.

more options

In Firefox 33 for windows you have no spell checking at all 'out of the box' because there is no dictionary installed. Previous versions of the browser downloads & installs with the English dictionary already there. This one does not.

To install a dictionary in WIN7 PRO (so that spell checking will work) you must FIRST find a web page that has a text box with more than one "line of text". I am not joking. You honesty have to scratch your head and think about the wen sites you use so that you can have the needed text box, and install a dictionary (there is no way to do this from "Tools->Options") .

One you see a text region that has more than one line in it, you right-click inside the text box, and use the popup menu; go to "Language" and then select "Add Dictionary". Add the dictionary of your choice. This is all very odd; a seriously very strange way to ship a product that in the past ALWAYS had an English dictionary included.

Somebody dropped the ball.

Athraithe ag BarleySinger ar

more options

The en-US Firefox 33.0 should have a en-US dictionary.

You do need a dictionary for en-GB.

Athraithe ag James ar

more options

Maybe I am dense, but with over 40 years IT experience, I doubt it. I have upgraded to FF 33 and in morningstar.com tried a re-test to see if spell checki8ng has returned. NOT!!!! I repeat:

Is there even anybody looking at this problem that I have experienced since at least Version 24? I used to be able to enable spell checking for posts to a heavily used morningstar.com forum that has many very educated users, and it is indeed embarrassing to post statements with spelling errors. Where did it go???"'

more options

Are you using the en-US locale or another locale?

Only a few locales apart from the en-US locale come with a dictionary because of licensing reasons, so if yours doesn't come with one then you will have to install one. You can check the dictionaries folder in the Firefox program folder to see if there is still a dictionary installed.

You can look here for dictionaries:

Athraithe ag cor-el ar