Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

What can you do to access Password options in the Security window if your Firefox browser won't display the options?

  • 3 fhreagra
  • 2 leis an bhfadhb seo
  • 25 views
  • Freagra is déanaí ó jay95404

more options

I want to stop and prevent my Firefox browser from saving website passwords, which I understand can be done using the Security window.

https://support.mozilla.org/en-US/kb/security-and-passwords-settings?esab=a&s=passwords&r=1&as=s

Unfortunately, once opened, the Security window doesn't display the password options check boxes for me even though that's what the support site says the browser should do it. Neither can I get the Security window to extend to display the other potential options, which leads to me think there aren't any other options.

Any ideas what I can do about this problem? I'm running Mac OS 10.8.5 and Firefox 30.0. Thanks for any advice!

Réiteach roghnaithe

To rule out extensions as a possible culprit in the dialog's dysfunction, could you try opening it in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • 3-bar menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help > Restart with Add-ons Disabled

Firefox should close and then display a small dialog: click "Start in Safe Mode" (not Reset)

Any difference?

Read this answer in context 👍 1

All Replies (3)

more options

Réiteach Roghnaithe

To rule out extensions as a possible culprit in the dialog's dysfunction, could you try opening it in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • 3-bar menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help > Restart with Add-ons Disabled

Firefox should close and then display a small dialog: click "Start in Safe Mode" (not Reset)

Any difference?

more options

(The following definitely relevant to Windows, but I'm not sure about Mac)

Another thing Safe Mode does is ignore the localstore.rdf file, which contains toolbar/window/dialog layout information and sometimes can become corrupted. To eliminate localstore.rdf as a factor, you can rename the file and customize from scratch.

Open your current Firefox settings (AKA Firefox profile) folder using either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (classic menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show in Finder" button.

Leaving that window open, switch back over to Firefox and Exit/Quit

Pause while Firefox finishes its cleanup, then rename localstore.rdf to something like localstore.old

Start Firefox up again. Any improvement?

more options

Starting Firefox in Safe Mode seemed to do the trick! I was able to access the check boxes after I restarted with my add-ons disabled. Thanks for the suggestion!