Search Support

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Can't watch videos on Netflix using Firefox 30.0, previous versions ok and IE still works

  • 14 freagra
  • 24 leis an bhfadhb seo
  • 21634 views
  • Freagra is déanaí ó FredMcD

more options

Starting this week (and I'm not sure what happened except perhaps my updating to the latest version of Firefox), I can no longer watch videos on Netflix using Firefox on my Windows 7 PC.

I am using Firefox 30.0 and Silverlight 5.1.30214.0 and under Add-ons I have Silverlight set at Always Activate. I also deleted cache and cookies since I saw that as a troubleshooting option.

The most unusual thing is, I am not getting any error message, just a WHITE blank screen. When I click on a movie on Netflix.com to watch it, it brings up a blank white screen with a teeny little gray square centered at the top of the screen, and the most bizarre part is that the AUDIO of the movie works...so I HEAR everything, but see nothing. I have tried several different tv shows and movies and this happens for all.

Meanwhile, on the same PC, at the same time, I am still able to watch movies on Netflix using Internet Explorer (I have version 10-something). But I prefer Firefox. Hoping someone can help solve this mystery!

Réiteach roghnaithe

Hmmm . . . . I don't see anything.

Okay, do this; go to your add-ons manager, and disable several of them. Restart Firefox, and test it on Netflix. If there is still a problem, disable some more. When FF runs without problem, you have narrowed it down. Re-enable the last group one by one until the problem comes back.

Read this answer in context 👍 2

All Replies (14)

more options

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

more options

Your System Details shows;

Installed Plug-ins

Garmin Communicator Plug-In 4.1.0.0 Garmin Communicator Plug-In 4.0.1.0

(are these the same program?) Version 5.4.2.18903 5.1.30214.0

Having two versions of the same program may cause issues.

more options

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart.

more options

Thank you for the suggestion. This was the most helpful suggestion so far because I learned a valuable clue: when I open Firefox in safe mode, the Netflix movies will play! I do not yet know why they only play in safe mode, but at the very least, I will be able to watch movies in safe mode. Thank you for that important step forward. Upon applying the rest of your suggestion to turn off use hardware acceleration, the problem did not go away, so something else must still be wrong. Any further thoughts you have would be greatly appreciated. Thanks again for the very prompt and helpful thoughts!

more options

Thank you for the suggestion. I cleaned up that plugin issue by uninstalling the program and reinstalling it with the latest version. There is no longer a plugin duplication, but unfortunately, that didn't resolve my issue with playing video on Netflix.com. The mystery continues.

more options

Thank you for the suggestion about updating plugins. There were no "yellow" plugins but there were two that were red so I updated them both. Unfortunately, that didn't resolve my issue with playing video on Netflix.com. The mystery continues.

more options

when I open Firefox in safe mode, the Netflix movies will play

Good ! Now we know where the problem is. One of your add-ons is the problem. What I need you to do is to give me a list of your add-ons. Follow these instructions;

Open a new window or tab. In the address box, enter about:support After the page opens, you will see the page banner on the left. Under it are two buttons. One is labeled Copy Text To Clipboard. Press it. Now return to this page, right click in the reply box below, and select Paste. Then post it.

more options

Fred, you rock. Sorry, this week got busy. Here's my copy/paste. Thanks for giving me hope of a solution. I am going to post in 2 parts due to size limit on the post.

Application Basics


Name: Firefox Version: 30.0 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Add to Amazon Wish List Button Version: 1.10 Enabled: true ID: amznUWL2@amazon.com

Name: Garmin Communicator Version: 4.2.0.0 Enabled: true ID: {195A3098-0BD5-4e90-AE22-BA1C540AFD1E}

Name: Microsoft .NET Framework Assistant Version: 1.3.1 Enabled: true ID: {20a82645-c095-46ed-80e3-08825760534b}

Name: ShopAtHome.com Toolbar Version: 7.1.1.2 Enabled: true ID: toolbar@shopathome.com

Name: Symantec Vulnerability Protection Version: 12.3.0.3 - 1 Enabled: true ID: {BBDA0591-3099-440a-AA10-41764D9DB4DB}

Name: TRUSTe Privacy Plugin Version: 2.0 Enabled: true ID: trackermanager@truste.com

Name: Adobe Acrobat - Create PDF Version: 1.2 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom

Name: DigitalPersona Extension Version: 5.0.0.4997 Enabled: false ID: otis@digitalpersona.com

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.newtab.url: about:blank browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243 browser.startup.homepage: about:home browser.startup.homepage_override.buildID: 20140605174243 browser.startup.homepage_override.mstone: 30.0 dom.mozApps.used: true dom.w3c_touch_events.expose: false extensions.lastAppVersion: 30.0 general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0E) gfx.direct3d.last_used_feature_level_idx: 0 gfx.direct3d.prefer_10_1: true network.cookie.prefsMigrated: true places.database.lastMaintenance: 1403363164 places.history.expiration.transient_current_max_pages: 51678 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true plugin.state.npctrl: 2 plugin.state.npgarmin: 2 print.printer_\\jenort\Brother_HL-2140_series.print_bgcolor: false print.printer_\\jenort\Brother_HL-2140_series.print_bgimages: false print.printer_\\jenort\Brother_HL-2140_series.print_colorspace: print.printer_\\jenort\Brother_HL-2140_series.print_command: print.printer_\\jenort\Brother_HL-2140_series.print_downloadfonts: false print.printer_\\jenort\Brother_HL-2140_series.print_duplex: 152 print.printer_\\jenort\Brother_HL-2140_series.print_edge_bottom: 0 print.printer_\\jenort\Brother_HL-2140_series.print_edge_left: 0 print.printer_\\jenort\Brother_HL-2140_series.print_edge_right: 0 print.printer_\\jenort\Brother_HL-2140_series.print_edge_top: 0 print.printer_\\jenort\Brother_HL-2140_series.print_evenpages: true print.printer_\\jenort\Brother_HL-2140_series.print_footercenter: print.printer_\\jenort\Brother_HL-2140_series.print_footerleft: &PT print.printer_\\jenort\Brother_HL-2140_series.print_footerright: &D print.printer_\\jenort\Brother_HL-2140_series.print_headercenter: print.printer_\\jenort\Brother_HL-2140_series.print_headerleft: &T print.printer_\\jenort\Brother_HL-2140_series.print_headerright: &U print.printer_\\jenort\Brother_HL-2140_series.print_in_color: true print.printer_\\jenort\Brother_HL-2140_series.print_margin_bottom: 0.5 print.printer_\\jenort\Brother_HL-2140_series.print_margin_left: 0.5 print.printer_\\jenort\Brother_HL-2140_series.print_margin_right: 0.5 print.printer_\\jenort\Brother_HL-2140_series.print_margin_top: 0.5 print.printer_\\jenort\Brother_HL-2140_series.print_oddpages: true print.printer_\\jenort\Brother_HL-2140_series.print_orientation: 0 print.printer_\\jenort\Brother_HL-2140_series.print_page_delay: 50 print.printer_\\jenort\Brother_HL-2140_series.print_paper_data: 1 print.printer_\\jenort\Brother_HL-2140_series.print_paper_height: 11.00 print.printer_\\jenort\Brother_HL-2140_series.print_paper_name: print.printer_\\jenort\Brother_HL-2140_series.print_paper_size_type: 0 print.printer_\\jenort\Brother_HL-2140_series.print_paper_size_unit: 0 print.printer_\\jenort\Brother_HL-2140_series.print_paper_width: 8.50 print.printer_\\jenort\Brother_HL-2140_series.print_plex_name: print.printer_\\jenort\Brother_HL-2140_series.print_resolution: 0 print.printer_\\jenort\Brother_HL-2140_series.print_resolution_name: print.printer_\\jenort\Brother_HL-2140_series.print_reversed: false print.printer_\\jenort\Brother_HL-2140_series.print_scaling: 1.00 print.printer_\\jenort\Brother_HL-2140_series.print_shrink_to_fit: false print.printer_\\jenort\Brother_HL-2140_series.print_to_file: false print.printer_\\jenort\Brother_HL-2140_series.print_unwriteable_margin_bottom: 0 print.printer_\\jenort\Brother_HL-2140_series.print_unwriteable_margin_left: 0 print.printer_\\jenort\Brother_HL-2140_series.print_unwriteable_margin_right: 0 print.printer_\\jenort\Brother_HL-2140_series.print_unwriteable_margin_top: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_bgcolor: false print.printer_\\JPDCSVR\Northside_Konica_C452.print_bgimages: false print.printer_\\JPDCSVR\Northside_Konica_C452.print_colorspace: print.printer_\\JPDCSVR\Northside_Konica_C452.print_command: print.printer_\\JPDCSVR\Northside_Konica_C452.print_downloadfonts: false print.printer_\\JPDCSVR\Northside_Konica_C452.print_duplex: 152 print.printer_\\JPDCSVR\Northside_Konica_C452.print_edge_bottom: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_edge_left: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_edge_right: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_edge_top: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_evenpages: true print.printer_\\JPDCSVR\Northside_Konica_C452.print_footercenter: print.printer_\\JPDCSVR\Northside_Konica_C452.print_footerleft: &PT print.printer_\\JPDCSVR\Northside_Konica_C452.print_footerright: &D print.printer_\\JPDCSVR\Northside_Konica_C452.print_headercenter: print.printer_\\JPDCSVR\Northside_Konica_C452.print_headerleft: &T print.printer_\\JPDCSVR\Northside_Konica_C452.print_headerright: &U print.printer_\\JPDCSVR\Northside_Konica_C452.print_in_color: true print.printer_\\JPDCSVR\Northside_Konica_C452.print_margin_bottom: 0.5 print.printer_\\JPDCSVR\Northside_Konica_C452.print_margin_left: 0.5 print.printer_\\JPDCSVR\Northside_Konica_C452.print_margin_right: 0.5 print.printer_\\JPDCSVR\Northside_Konica_C452.print_margin_top: 0.5 print.printer_\\JPDCSVR\Northside_Konica_C452.print_oddpages: true print.printer_\\JPDCSVR\Northside_Konica_C452.print_orientation: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_page_delay: 50 print.printer_\\JPDCSVR\Northside_Konica_C452.print_paper_data: 1 print.printer_\\JPDCSVR\Northside_Konica_C452.print_paper_height: 11.00 print.printer_\\JPDCSVR\Northside_Konica_C452.print_paper_name: print.printer_\\JPDCSVR\Northside_Konica_C452.print_paper_size_type: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_paper_size_unit: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_paper_width: 8.50 print.printer_\\JPDCSVR\Northside_Konica_C452.print_plex_name: print.printer_\\JPDCSVR\Northside_Konica_C452.print_resolution: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_resolution_name: print.printer_\\JPDCSVR\Northside_Konica_C452.print_reversed: false print.printer_\\JPDCSVR\Northside_Konica_C452.print_scaling: 1.00 print.printer_\\JPDCSVR\Northside_Konica_C452.print_shrink_to_fit: true print.printer_\\JPDCSVR\Northside_Konica_C452.print_to_file: false print.printer_\\JPDCSVR

more options

\Northside_Konica_C452.print_unwriteable_margin_bottom: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_unwriteable_margin_left: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_unwriteable_margin_right: 0 print.printer_\\JPDCSVR\Northside_Konica_C452.print_unwriteable_margin_top: 0 print.printer_Adobe_PDF.print_bgcolor: false print.printer_Adobe_PDF.print_bgimages: false print.printer_Adobe_PDF.print_colorspace: print.printer_Adobe_PDF.print_command: print.printer_Adobe_PDF.print_downloadfonts: false print.printer_Adobe_PDF.print_duplex: 152 print.printer_Adobe_PDF.print_edge_bottom: 0 print.printer_Adobe_PDF.print_edge_left: 0 print.printer_Adobe_PDF.print_edge_right: 0 print.printer_Adobe_PDF.print_edge_top: 0 print.printer_Adobe_PDF.print_evenpages: true print.printer_Adobe_PDF.print_footercenter: print.printer_Adobe_PDF.print_footerleft: &PT print.printer_Adobe_PDF.print_footerright: &D print.printer_Adobe_PDF.print_headercenter: print.printer_Adobe_PDF.print_headerleft: &T print.printer_Adobe_PDF.print_headerright: &U print.printer_Adobe_PDF.print_in_color: true print.printer_Adobe_PDF.print_margin_bottom: 0.5 print.printer_Adobe_PDF.print_margin_left: 0.5 print.printer_Adobe_PDF.print_margin_right: 0.5 print.printer_Adobe_PDF.print_margin_top: 0.5 print.printer_Adobe_PDF.print_oddpages: true print.printer_Adobe_PDF.print_orientation: 0 print.printer_Adobe_PDF.print_page_delay: 50 print.printer_Adobe_PDF.print_paper_data: 1 print.printer_Adobe_PDF.print_paper_height: 11.00 print.printer_Adobe_PDF.print_paper_name: print.printer_Adobe_PDF.print_paper_size_type: 0 print.printer_Adobe_PDF.print_paper_size_unit: 0 print.printer_Adobe_PDF.print_paper_width: 8.50 print.printer_Adobe_PDF.print_plex_name: print.printer_Adobe_PDF.print_resolution: 0 print.printer_Adobe_PDF.print_resolution_name: print.printer_Adobe_PDF.print_reversed: false print.printer_Adobe_PDF.print_scaling: 1.00 print.printer_Adobe_PDF.print_shrink_to_fit: true print.printer_Adobe_PDF.print_to_file: false print.printer_Adobe_PDF.print_unwriteable_margin_bottom: 0 print.printer_Adobe_PDF.print_unwriteable_margin_left: 0 print.printer_Adobe_PDF.print_unwriteable_margin_right: 0 print.printer_Adobe_PDF.print_unwriteable_margin_top: 0 privacy.cpd.downloads: false privacy.cpd.history: false privacy.cpd.sessions: false privacy.sanitize.migrateFx3Prefs: true privacy.sanitize.timeSpan: 0 security.warn_viewing_mixed: false storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1401818683

Graphics


Adapter Description: Intel(R) HD Graphics 3000 Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32 Adapter RAM: Unknown Device ID: 0x0126 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16571) Driver Date: 1-16-2013 Driver Version: 9.17.10.2963 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 10 Vendor ID: 0x8086 WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.6 Version in use: 4.10.6

NSS Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSMIME Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSSL Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSUTIL Expected minimum version: 3.16 Version in use: 3.16

more options

Réiteach Roghnaithe

Hmmm . . . . I don't see anything.

Okay, do this; go to your add-ons manager, and disable several of them. Restart Firefox, and test it on Netflix. If there is still a problem, disable some more. When FF runs without problem, you have narrowed it down. Re-enable the last group one by one until the problem comes back.

more options

I fixed the problem by activating the Silverlight plugin. Open the menu button in Firefox. Click on Add-ons. This will open the Mozzilla page. Click Plugins. The Ad- ons Manager will open. It will list your ad-ons. Find Silverlight, then on the far right, choose how you want it to operate. I chose Always Activate. I had this problem on my Win7 laptop. When i tried to stream on my Win7 desktop, I got a pop-up asking me to activate Silverlight. I cllcked it and Netflix started streaming right away. Why the two Win7 machines are different, I have no idea.

more options

Hello,

I am glad to hear that your problem has been resolved.

If you have not already, please mark this thread as solved by marking the solution.
This will help other users experiencing similar problems find help faster and more efficiently.

I hope you continue using our products and thank you for contacting Mozilla Support.

more options

Fred, you are amazing! Thank you for your help. I learned a few things in the process. It was a bad browser extension. As soon as I disabled it, everything worked again. Thank you so much!

more options

I just passed on information I learned from this forum. Pass it on.