Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

SmartSheet causes Firefox 29 to crash

  • 4 fhreagra
  • 2 leis an bhfadhb seo
  • 170 views
  • Freagra is déanaí ó yelnut

more options

I use SmartSheet extensively at work, but since I upgraded to Firefox 29, my browser will crash periodically when working on a SmartSheet. This usually happens when saving a sheet, or while scrolling down a sheet. Does anyone out there have the same problem and can suggest a fix?

Réiteach roghnaithe

Thank you, i have installed V30 and it seems to have solved the problem.

Read this answer in context 👍 0

All Replies (4)

more options

Hmm, I've never used SmartSheet.com. Since this is a paid service, perhaps their support will be able to provide specific advice. Or maybe they'll suggest trying a different browser...

When Firefox crashes, it usually records information about what was happening at that moment. You can submit that data to Mozilla when the Crash Reporter pops up, and share it with forum volunteers to see whether it points to the solution. Please check the support article "Troubleshoot Firefox crashes (closing or quitting unexpectedly)" (especially the last section) for steps to get those crash IDs, and then post some of the recent ones here.

If Firefox isn't really crashing but freezes and becomes nonresponsive, unfortunately there's usually no data captured for that.


Meanwhile, some general things:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


In case one of your extensions is involved, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

more options

Hi yelnut,

There is a bug in Firefox v29 which causes Smartsheet to crash the browser. Firefox is aware of this bug and they have fixed it, but they will not release the fix until Firefox v30. In the meantime, we would recommend using Chrome. Thanks! Travis - Technical Support at Smartsheet.

more options

FYI, Firefox 30 is scheduled for release tomorrow morning.

more options

Réiteach Roghnaithe

Thank you, i have installed V30 and it seems to have solved the problem.