Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dúnadh an snáithe seo agus cuireadh sa chartlann é. Cuir ceist nua má tá cabhair uait.

How Do I Rollback to Firefox 28?

  • 3 fhreagra
  • 6 leis an bhfadhb seo
  • 579 views
  • Freagra is déanaí ó Moses

more options

I've seen the thread on rolling back where the guy asks to roll back to Firefox 28 from 29 and you give him advice to DO SOMETHING ELSE. Thanks so much for that but I've already tried that, and that solution sucks. Classic Theme Restorer doesn't do what I want. It doesn't restore the spinner, and it doesn't fix any of the three Qute themes, for pretty much the exact same reason, it appears:

gigaherz: "Due to the heavy UI changes in Firefox 29 I cannot maintain this theme any longer" Murphy: "Due to the heavy UI changes in Firefox 29 I cannot maintain this theme any longer" Ryan Power: "Sorry folks, but Firefox is getting too unwieldy to keep trying to restore the classic look..."

I've despaired of getting Firefox 29 to look the way I want it to look. In the interim I would like to run Firefox 28.

Oh, and one more thing: I tried to create this question using my actual install of Firefox 29, but apparently that doesn't work any more! I am unable to create a question on how to rollback from Firefox 29 by using Firefox 29. Instead I have to use my work computer (which I assure you, will never update to 29).

If that's an accident, then it's HILARIOUS.

All Replies (3)

more options

Old versions of Firefox contain security vulnerabilities. You shouldn't use them.

Throbber Restored provides an activity indicator in Firefox 29+.

Classic Theme Restorer does what it says on the tin: it makes Firefox 29 look like Firefox 28. It's intended to be used with the default theme; results may be unpredictable when used alongside third-party themes.

There are other complete themes that are compatible with the current version of Firefox.

If despite the above you still want to sabotage your system, see Install an older version of Firefox.

more options

Well, I finally (accidentally) updated firefox to 29. So now I'm stuck with this steaming turd.

On the bride side, though, there's a theme that finally replicates the qute themes that you geniuses have repeatedly broken. (Because apparently a "theme" to you is overalying an image on the toolbars and saying "done!")

It's qute 5++!

On the not so bright side, it doesn't work at all, doesn't do what it claims, and it probably a deliberate fake.

It is a mystery, why Firefox has lost _HALF_ it's market share over the past 18 months.

more options

Please note what Gingerbread said.

If despite the above you still want to sabotage your system, see Install an older version of Firefox.

You can do so at your discretion instead of complaining about how Firefox 29 looks. Any feedback good or bad should be redirected to input.mozilla.org/feedback where comments are made available to the developers. Any comments made here will simply be ignored as this forum isn't the place for this and it's sole goal is to provide technical support, not discuss development decisions. Please note that NO Mozilla developers roam this forum. This is an entirely community-powered site. Were all Firefox users volunteering our time to help out other users. So please be nice in future threads.

I'll be closing this thread as there is no support request. If you wish to downgrade to 28 (strongly recommended not to) use the Install an older version of Firefox link. Gingerbread has given some great resources and is an awesome member of our community.


EDIT: Since you seem so motivated to stay on 28, you can use my below directions to do it. Please note again this is NOT recommended by Mozilla

There was a previous way by going through the Options menu to disable updates but after disabling it through there, when you would go to Help > About Firefox, it would update regardless of that setting.

You can set these prefs in about:config to disable automatic updating:
app.update.auto - false
app.update.enabled - false
app.update.silent - false

Another thing to do would be to go into about:config again and set these prefs to blank. Right click > Modify > delete existing > OK.

  • app.update.url
  • app.update.url.details
  • app.update.url.manual

Athraithe ag Moses ar