Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Poor Font Rendering

  • 7 bhfreagra
  • 37 leis an bhfadhb seo
  • 1255 views
  • Freagra is déanaí ó Gingerbread Man

more options

This happens on multiple computers using various operating systems and versions of Firefox. Many web pages have the fonts rendered poorly. It even happens on Mozilla's web pages, including this one I am entering this in, right now.

I have turned off "Use hardware acceleration when available" and restarted firefox, and that makes no difference.

Here are two different websites that render correctly in Chrome but have poor font rendering in Firefox: https://support.mozilla.org/en-US/kb/get-community-support www.phoronix.com

I would attach screenshots if there was a way to do that.

All Replies (7)

more options

gotaug wrote:

I would attach screenshots if there was a way to do that. 

You can attach images to replies. If you need to include images in the original question, you can upload them to a site like imgur.com and post the links.

See if the following article helps.

more options

Screenshots in next post

Athraithe ag gotaug ar

more options

Here are screenshots:

more options

Gingerbread Man, I appreciate your suggestions.

The problem isn't solved by anything in the "Websites look wrong or appear differently than they should" link.

I have looked long and hard for a solution and I'm experienced at troubleshooting software issues. This really frustrates me because I prefer Firefox to Chrome.

Firefox Font rendering is simply screwed up. On multiple machines w/multiple operating systems and multiple versions of the browser!

Athraithe ag gotaug ar

more options

Try to create a new Boolean pref on the about:config page via the right-click context menu with the name layout.paint_rects_separately and set the value to true and leave hardware acceleration enabled.

See comment 414 in bug 812695:

That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues.


You may have zoomed these page(s) by accident.
Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

Athraithe ag cor-el ar

more options

I've tried all the suggestions so far to no avail. This has been a problem for me for so long on so many websites and machines, I can't believe more people aren't affected by it.

I mean Firefox even renders it's own home pages for the Mozilla foundation wrong.

Could Win7 or not having admin rights be the problem? My Win8.1 machine at home renders everything perfectly.

more options
  1. Update your graphics drivers.
  2. Click the Windows logo orb on the taskbar to bring up the Start Menu.
  3. In the search box, type the following then press Enter: Adjust ClearType Text
  4. In the ClearType Text Tuner window, make sure "Turn on ClearType" is checked, then click the Next button and follow the steps until completion.
  5. In Firefox, under Options → Advanced → General, make sure "Use hardware acceleration when available" is checked, then restart Firefox.
  6. If the problems persist, check if you have the same issue in a brand new profile.
  7. If everything's okay in a brand new profile, return to your regular profile and reset Firefox.