Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Can't disable startup page after update

  • 22 freagra
  • 12 leis an bhfadhb seo
  • 659 views
  • Freagra is déanaí ó cor-el

more options

After recent update, when I start ff, there's always this page showing: https://www.mozilla.org/en-US/firefox/29.0.1/whatsnew/?oldversion=16.0.2

I went to option->general->home page and changed it to google.com, but everytime I started ff, above page still show. I googled around and couldn't find a solution.

Please help. Thanks.

All Replies (20)

more options

hello, this might happen when firefox is not able to properly save preferences in its profile folder. please try this: Click the menu button New Fx Menu and then click help Help-29 > troubleshooting information > profile folder - "show folder". then a new window will open up. in this window look out for a file named user.js (it might be used to overwrite your custom settings). in case it is present , delete or rename this file and restart firefox afterwards.

for more information and other steps please also see: How to fix preferences that won't save

more options

Thanks. I followed your step and I didn't find user.js in that folder. I tried to reset Firefox and that also doesn't help. Still, that page always pop up.

more options
more options

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

more options

I follow the steps and created a new profile. In the new profile, my old bookmarks are gone, but that page starts as usual...

more options

I uninstalled and reinstalled firefox, still the same problem...

more options

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

more options

Nothing is appended.

Here's the output: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

more options

I have the same problem -- down to the same exact URL with "oldversion=16.0.2" at the end of the URL.

Resetting FireFox to default does not fix the problem.

The problem persists with no extensions installed.

Why does FF think I was running 16.0.2? I've been letting FF do it's auto-update thing for years now.

more options

Does anything come up is you search the about:config page for 16.0.2 ?

more options

No "16.0.2" string appears in about:config

more options

Try to rename (or delete) the compatibility.ini file in the Firefox profile folder to see if that initializes the profile properly.

more options

Thanks for responding, but it didn't work.

  1. Stopped FF.
  2. deleted compatibility.ini
  3. restarted FF
  4. FF still shows the tab with above URL.
  5. profile folder has new compatibility.ini, timestamped few minutes ago

I'd already reset FF before hand, so I very much doubted this would work...

Athraithe ag user808 ar

more options

I can't find compatability.ini file in profile folder...

more options

could you go to the firefox menu New Fx Menu > help Help-29 > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

more options

Here it is:


Application Basics


Name: Firefox Version: 29.0.1 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 1048576 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.places.smartBookmarksVersion: 6 browser.sessionstore.upgradeBackup.latestBuildID: 20140506152807 browser.startup.homepage: www.google.com browser.startup.homepage_override.buildID: 20140506152807 browser.startup.homepage_override.mstone: 29.0.1 browser.tabs.warnOnClose: false dom.mozApps.used: true extensions.lastAppVersion: 29.0.1 gfx.direct3d.last_used_feature_level_idx: 0 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1400519145 places.history.enabled: false places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1399938176

Graphics


Adapter Description: Intel(R) HD Graphics 4000 Adapter Description (GPU #2): NVIDIA Quadro K1000M Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32 Adapter Drivers (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: Unknown Adapter RAM (GPU #2): 2048 Device ID: 0x0166 Device ID (GPU #2): 0x0ffc Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16571) Driver Date: 4-9-2012 Driver Date (GPU #2): 5-31-2012 Driver Version: 8.15.10.2725 Driver Version (GPU #2): 8.17.12.9688 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 10 Vendor ID: 0x8086 Vendor ID (GPU #2): 0x10de WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.3 Version in use: 4.10.3

NSS Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSMIME Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSSL Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSUTIL Expected minimum version: 3.16 Version in use: 3.16

more options

Here is mine (BTW, love the "copy to text" button" idea!):

Application Basics


Name: Firefox Version: 29.0.1 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Crash Reports for the Last 3 Days


All Crash Reports (including 1 pending crash in the given time range)

Extensions


Name: LastPass Version: 3.1.1 Enabled: true ID: support@lastpass.com

Name: Pocket Version: 3.0.4 Enabled: true ID: isreaditlater@ideashower.com

Name: Vimperator Version: 3.8.2 Enabled: true ID: vimperator@mozdev.org

Name: WOT Version: 20131118 Enabled: true ID: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}

Name: WebEx Productivity Tools Version: 2.0 Enabled: false ID: ocplugin@webex.com

Important Modified Preferences


accessibility.typeaheadfind.autostart: false browser.cache.disk.capacity: 1048576 browser.cache.disk.smart_size_cached_value: 665600 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.link.open_newwindow.restriction: 0 browser.places.smartBookmarksVersion: 6 browser.sessionstore.upgradeBackup.latestBuildID: 20140506152807 browser.startup.homepage_override.buildID: 20140506152807 browser.startup.homepage_override.mstone: 29.0.1 browser.urlbar.doubleClickSelectsAll: true dom.mozApps.used: true dom.popup_allowed_events: change click dblclick mouseup reset submit touchend keypress extensions.lastAppVersion: 29.0.1 gfx.direct3d.last_used_feature_level_idx: 0 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1400531618 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1400187739

Graphics


Adapter Description: NVIDIA Quadro K1000M Adapter Description (GPU #2): Intel(R) HD Graphics 4000 Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter Drivers (GPU #2): igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32 Adapter RAM: 2048 Adapter RAM (GPU #2): Unknown ClearType Parameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ] Device ID: 0x0ffc Device ID (GPU #2): 0x0166 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16440) Driver Date: 10-28-2013 Driver Date (GPU #2): 4-9-2012 Driver Version: 9.18.13.1269 Driver Version (GPU #2): 8.15.10.2725 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 10 Vendor ID: 0x10de Vendor ID (GPU #2): 0x8086 WebGL Renderer: Google Inc. -- ANGLE (NVIDIA Quadro K1000M Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.3 Version in use: 4.10.3

NSS Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSMIME Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSSL Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSUTIL Expected minimum version: 3.16 Version in use: 3.16

more options

does the same thing happen when you close all firefox windows, and then press windows-key+R and open firefox.exe?

more options

Yes, running firefoxe.exe from WindowsKey+R still displays the "commited to you..." tab.

more options

another thing to test: does it make a difference when you enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.startup.homepage_override.mstone, double-click it and change its value to ignore?

  1. 1
  2. 2