Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

How can I keep Tuvalo or other invasive sites from changing my homepage?

  • 2 antwurd
  • 1 hat dit probleem
  • 3 werjeftes
  • Lêste antwurd fan fb97e4ad

more options

Why can't Firefox add a simple opt-out question or password-protection for changing the homepage? "X is trying to change your homepage to X.com. Allow? Y/N"

After you add that, add: "Permanently block access by X.com. Y/N"

Why can't Firefox add a simple opt-out question or password-protection for changing the homepage? "X is trying to change your homepage to X.com. Allow? Y/N" After you add that, add: "Permanently block access by X.com. Y/N"

Keazen oplossing

Websites do not have permission to change your home page. If you find it is getting switched, consider the possibility that you've somehow installed a rogue extension.

Try this:

Disable ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable. (Or if it's clearly badware, remove.)

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that let you restore your home page?

A few related issues:

(1) If there is no remove button for an extension, visit the Windows Control Panel. In Windows Vista-7, the relevant dialog is "Uninstall a Program"; not sure what it is called in Windows 8.1. Clicking the "Installed on" column heading will sort by date and help uncover possible bundled items that you didn't know were being installed. Remove all the crap you can. (If you find anything named Search Protect or BrowserSafeguard, remove it.)

(2) Third party software can create a file named user.js that Firefox reads at startup and which will override your saved settings from your previous session. This article describes how to track down and remove that file if you have one: How to fix preferences that won't save.

(3) Some utilities such as Advanced SystemCare have a feature to roll back your settings changes, which can lock in unwanted settings. Theirs is called Surfing Protection. If you have that or a similar Homepage Protection (etc.) setting preventing you from making desired changes, turn it off temporarily (or permanently).

(4) To mop up unwanted software, try the scanners other Firefox users have found helpful in this article: Troubleshoot Firefox issues caused by malware.

Hopefully that will tame it.

Dit antwurd yn kontekst lêze 👍 1

Alle antwurden (2)

more options

Keazen oplossing

Websites do not have permission to change your home page. If you find it is getting switched, consider the possibility that you've somehow installed a rogue extension.

Try this:

Disable ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable. (Or if it's clearly badware, remove.)

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that let you restore your home page?

A few related issues:

(1) If there is no remove button for an extension, visit the Windows Control Panel. In Windows Vista-7, the relevant dialog is "Uninstall a Program"; not sure what it is called in Windows 8.1. Clicking the "Installed on" column heading will sort by date and help uncover possible bundled items that you didn't know were being installed. Remove all the crap you can. (If you find anything named Search Protect or BrowserSafeguard, remove it.)

(2) Third party software can create a file named user.js that Firefox reads at startup and which will override your saved settings from your previous session. This article describes how to track down and remove that file if you have one: How to fix preferences that won't save.

(3) Some utilities such as Advanced SystemCare have a feature to roll back your settings changes, which can lock in unwanted settings. Theirs is called Surfing Protection. If you have that or a similar Homepage Protection (etc.) setting preventing you from making desired changes, turn it off temporarily (or permanently).

(4) To mop up unwanted software, try the scanners other Firefox users have found helpful in this article: Troubleshoot Firefox issues caused by malware.

Hopefully that will tame it.

Bewurke troch jscher2000 - Support Volunteer op

more options

Yes, but. Having reset Firefox several times, I had NO add-ons or extensions, so nothing to do there. I checked "uninstall a program" in Windows 8 control panel, and nothing meeting your description was there. There was one other thing with 'search' in the name, 'search safeguard' or something (I forgot to write it down), so I deleted it, and it seems to have done the trick.

FYI, I followed the support page's instructions on creating new profiles, and I cleverly put the new profile in my Documents folder so I could find it. When I reopened Firefox, the profile folder had disappeared. Don't know how that happened.

Thanks for the info.