Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

The spellchecker in in the wrong flavor of English

  • 3 antwurd
  • 20 hawwe dit probleem
  • 20 werjeftes
  • Lêste antwurd fan rasputin

more options

I'm so certain I posted this a couple of weeks ago but I can't find it so here goes again.

I'm running Firefox 3.6.13 that came with Ubuntu (10.10).

When I use a word like flavor, the spell-checker underlines it with squiggles and suggests "flavour". Similarly for behavior and some other words. I recognize (that just got sqiggled; it wants "recognise) as being the British spelling convention. I have downloaded the United States English Spellchecker 5.01 but that was of no avail. I finally thought of looking into about:config and found: spellchecker.dictionary set to en_AU - that is, the Australian dictionary.

I can't just blindly set this to en-US without knowing that: - That is the correct name for the dictionary I need. (Seems probable.) - That the above extension is indeed the dictionary it would access.

I note that the Australian dictionary is spelled en_AU - with an underscore - while the US dictionary is spelled en-US - with a dash. This is the kind of stuff I need to watch out for, because if I mess it up, I may not be able to restart FireFox.

Thanks for help here.

-- Rasputin

I'm so certain I posted this a couple of weeks ago but I can't find it so here goes again. I'm running Firefox 3.6.13 that came with Ubuntu (10.10). When I use a word like flavor, the spell-checker underlines it with squiggles and suggests "flavour". Similarly for behavior and some other words. I recognize (that just got sqiggled; it wants "recognise) as being the British spelling convention. I have downloaded the United States English Spellchecker 5.01 but that was of no avail. I finally thought of looking into about:config and found: spellchecker.dictionary set to en_AU - that is, the Australian dictionary. I can't just blindly set this to en-US without knowing that: - That is the correct name for the dictionary I need. (Seems probable.) - That the above extension is indeed the dictionary it would access. I note that the Australian dictionary is spelled en_AU - with an underscore - while the US dictionary is spelled en-US - with a dash. This is the kind of stuff I need to watch out for, because if I mess it up, I may not be able to restart FireFox. Thanks for help here. -- Rasputin

Bewurke troch rasputin op

Keazen oplossing

Easiest is to let Firefox do this.

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.
You can open the "Add Dictionaries" link to install a dictionary if you do not have one.
Also make sure that [X] "Check Spelling" in the right-click context menu has a tick.

See also:

Dit antwurd yn kontekst lêze 👍 4

Alle antwurden (3)

more options

Keazen oplossing

Easiest is to let Firefox do this.

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.
You can open the "Add Dictionaries" link to install a dictionary if you do not have one.
Also make sure that [X] "Check Spelling" in the right-click context menu has a tick.

See also:

more options

I tend to use alternative profiles and can have different spell-checkers , &/or can change the personal dictionary I use. See Profile Manager - Create, remove or switch Firefox profiles

more options

Cor-el (A relative of the Kryptonian aristocrat? ;-)

That worked. In fact, the about:config entry for spellchecker.dictionary now shows en_US, that's with the underscore. I have uninstalled the dictionary add-on that I downloaded.

Problem solved so easily, if you know where to look.

Thanks mucho!

-- Rasputin Paskudniak