Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

When opening Firefox I get a message saying "Failed to read configuration file. Please contact system administrator" .

  • 11 antwurd
  • 0 hawwe dit probleem
  • 367 werjeftes
  • Lêste antwurd fan cor-el

more options

When I open Firefox I get a message telling me "Failed to read configuration file. Please contact system administrator". When I click OK Firefox opens normally and seems to be fine. Not sure what is going on here. Any ideas why this is happening and how to get rid of it?

Windows 10 64-bit Firefox 115.3.1 64-bit

Any assistance will be greatly appreciated. Thanks

When I open Firefox I get a message telling me "Failed to read configuration file. Please contact system administrator". When I click OK Firefox opens normally and seems to be fine. Not sure what is going on here. Any ideas why this is happening and how to get rid of it? Windows 10 64-bit Firefox 115.3.1 64-bit Any assistance will be greatly appreciated. Thanks

Keazen oplossing

jscher2000 - Support Volunteer said

Along the lines zeroknight suggested, and as noted in the article linked earlier by TyDraniu, the files involved in Autoconfig are in the program folder, typically C:\Program Files\Mozilla Firefox (sometimes C:\Program Files (x86)\Mozilla Firefox) You can remove the file that creates the general.config.filename preference and see whether that is enough to stop the messages. You probably also need to clear it on the about:config screen. If you have the usual install location, the file would be in this folder: C:\Program Files\Mozilla Firefox\defaults\pref Normally there is only one file here, named channel-prefs.js, which is a normal part of Firefox. Any other file here is potentially creating this problem because Firefox will read it at startup. You could delete the extra file(s), or move it/them to some other folder for further investigation. Note: If your Windows is not configured to show common file extensions, the .js might not appear. To see full file names including extensions, check the steps in this article: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Ah ha. There was an extra file in the defaults\pref folder. It was called antibeacon.js. I removed that and it's working as expected.

Thanks for the help.

Dit antwurd yn kontekst lêze 👍 0

Alle antwurden (11)

more options

Enter about:config in the address bar and check the value of general.config.filename pref.

See also Customizing Firefox Using AutoConfig.

Bewurke troch TyDraniu op

Behelpsum?

more options

The value of general.config.filename is mozilla.cfg

Is this the expected value?

Behelpsum?

more options

The preference "general.config.filename" only exists if an Autoconfig file was set up. This could be done by an IT department on a work computer, or by some other software you installed on your system -- sometimes security software will do it, sometimes malware will do it -- or by you.

Behelpsum?

more options

Try to remove it, or find the mozilla.cfg file.

Behelpsum?

more options

TyDraniu said

Try to remove it, or find the mozilla.cfg file.

I was unable to find the mozilla.cfg file. I removed the value from general.config.filename and the message still pops up when opening Firefox.

Behelpsum?

more options

jscher2000 - Support Volunteer said

The preference "general.config.filename" only exists if an Autoconfig file was set up. This could be done by an IT department on a work computer, or by some other software you installed on your system -- sometimes security software will do it, sometimes malware will do it -- or by you.

This is my personal computer so no IT department. I don't think I did it unless it can be done by accident. I use Windows built in security. When you say security software are you talking about third party software? Scanning with Windows Security does not find any threats. Is there a better option for scanning for malware?

Behelpsum?

more options

Try uninstalling Firefox, download a fresh copy and reinstall. The default uninstall process will not clear your settings.

Behelpsum?

more options

Along the lines zeroknight suggested, and as noted in the article linked earlier by TyDraniu, the files involved in Autoconfig are in the program folder, typically

C:\Program Files\Mozilla Firefox

(sometimes C:\Program Files (x86)\Mozilla Firefox)

You can remove the file that creates the general.config.filename preference and see whether that is enough to stop the messages. You probably also need to clear it on the about:config screen.

If you have the usual install location, the file would be in this folder:

C:\Program Files\Mozilla Firefox\defaults\pref

Normally there is only one file here, named channel-prefs.js, which is a normal part of Firefox. Any other file here is potentially creating this problem because Firefox will read it at startup. You could delete the extra file(s), or move it/them to some other folder for further investigation.

Note: If your Windows is not configured to show common file extensions, the .js might not appear. To see full file names including extensions, check the steps in this article: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Behelpsum?

more options

Keazen oplossing

jscher2000 - Support Volunteer said

Along the lines zeroknight suggested, and as noted in the article linked earlier by TyDraniu, the files involved in Autoconfig are in the program folder, typically C:\Program Files\Mozilla Firefox (sometimes C:\Program Files (x86)\Mozilla Firefox) You can remove the file that creates the general.config.filename preference and see whether that is enough to stop the messages. You probably also need to clear it on the about:config screen. If you have the usual install location, the file would be in this folder: C:\Program Files\Mozilla Firefox\defaults\pref Normally there is only one file here, named channel-prefs.js, which is a normal part of Firefox. Any other file here is potentially creating this problem because Firefox will read it at startup. You could delete the extra file(s), or move it/them to some other folder for further investigation. Note: If your Windows is not configured to show common file extensions, the .js might not appear. To see full file names including extensions, check the steps in this article: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Ah ha. There was an extra file in the defaults\pref folder. It was called antibeacon.js. I removed that and it's working as expected.

Thanks for the help.

Behelpsum?

more options

Since your install folder has been tampered with, you need to uninstall Firefox and reinstall a fresh copy, then do a full system scan for malware to ensure it is clean.

Behelpsum?

more options

Make sure you remove the Firefox installation folder after uninstalling to remove any leftover file/folder.

Behelpsum?

In fraach stelle

Jo moatte jo oanmelde by jo account om op berjochten te antwurdzjen. Stel in nije fraach as jo noch gjin account hawwe.