Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

Firefox shows only numbered squares instead of any fonts on local PC

  • 17 antwurd
  • 2 hawwe dit probleem
  • 2208 werjeftes
  • Lêste antwurd fan jscher2000

more options

Firefox is up to date but will not show any fonts that it should render using local fonts. It does though render special fonts that I have on my web server and fonts other sites have loading from their web sever but none that I have on my PC. This is on all web pages google for example does not render any fonts. What is does show are a box for each character with a number in it that I assume is the character number. Currently all other browsers on my PC are not having this trouble. I have cleared caches and tried many pages.

Keazen oplossing

If you check out what font is used then we can give more precise instructions about how to proceed. This is caused by a font that is installed on your computer and that Firefox tries to use, but somehow fails.


If locally installed fonts aren't working then this is possibly a sandbox security issue.

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Dit antwurd yn kontekst lêze 👍 0

Alle antwurden (17)

more options

Here is the image example showing special font rendering but normal font as numbered boxes.

more options

Please : https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer and https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles then https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Please let us know if this solved your issue or if need further assistance.

more options

This problem usually doesn't affect local fonts of Windows users.

The box indicates that Firefox couldn't find that character in the assigned font. So first question is, what font is Firefox trying to use for that text? To investigate further, try the Page Inspector. It has a Fonts panel that shows what the page asked for and what Firefox is using.

To open the inspector, right-click problem text and choose Inspect Element. Firefox will open a panel in the lower part of the tab. On the left side is HTML, and on the right side a set of panes for CSS rules and other things. If you don't see Fonts, click the triangle at the end of the row of headings that starts with Rules and choose Fonts there. What's going on?

Sample screenshot attached.

Possibly useful reference: https://developer.mozilla.org/docs/Tools/Page_Inspector

more options

New user profile created & firefox still will not render fonts. There really should be nothing a user could do that cause this.

Mozilla needs to own up to this and come out with a patch so this never happens again.

more options

You will have to check in the Inspector what font Firefox is using like posted above.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check the font used for selected text in the Fonts tab in the right pane of the Inspector. Note that you may have to click the arrow at the right end of the pane that shows Rules and Computed and others to access the Fonts tab.

Bewurke troch cor-el op

more options

The new version also has destroyed my ability to back up passwords which I absolutely need to back up. Even to proceed with trying to fix this. Thanks for your fabulous new version that make Firefox entirely unusable destroying data I need for my job. Thanks.

more options

I have now uninstalled then manually deleted all program folders and all profile folders for firefox then reinstalled - fixed it right???? WRONG What the hell is going on here?

more options

Keazen oplossing

If you check out what font is used then we can give more precise instructions about how to proceed. This is caused by a font that is installed on your computer and that Firefox tries to use, but somehow fails.


If locally installed fonts aren't working then this is possibly a sandbox security issue.

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

OK next fix delete everything program folders and profile folders and install version 54.0.1 first run it comes back and I can see fonts again then I have to run in and set it to never update. BUT WHEN I SHUT IT DOWN AND RESTART IT STARTS BY TELLING ME IT IS INSTALLING UPDATES PLEASE WAIT!!!!!!! ??????? EVEN THOUGH I TOLD IT NOT TO. It comes back as version 56 AND NOW THE FUCKKKKING FONT PROBLEM IS BACK.

There simply is no possible fix if this happens to you in Firefox 57. If you have any trouble all you personal data is lost with no way to get it back. I really wish I could sue you for ruining this once decent browser so completely. NOW WHAT THE HELL AM i GONNA DO. I'll have to reset a hundred passwords.

Mozzilla freaking fix this now.

more options

I was able to move back to version 49.0.2 and it remembered my do-not-update setting and it does properly display fonts again. I also use the ancient tool moz back up and had a backup of my passwords only and they seem to work.

After all that fear and frustration my suggestion to all is install version 49 and tell it to never update.

more options

I'm puzzled why you ignored three different responses asking you to see what Firefox was using on those pages. If you decide to update in the future and run into this problem again, you have those posts for reference.

Also, you know Firefox 49 is not secure and is not getting security updates.

more options

You can use the Firefox 52.5.0 ESR version if you really want to use an older Firefox version.

Firefox 52.5.0 ESR:

more options

Thank you any one who responded. New problem even when I have the browser set not to update anything some how it updated on my PC and came back with the same problem. If it is not Mozzila doing that it could be a software push on my network. If it is Mozzilla forcing the update somehow please stop it till you make a patch that corrects this problem.

The problem has nothing to do with certain pages and the CSS they use for fonts that is what I checked first and ruled out.

I am well aware of security concerns but I absolutely need all my web browsers working right now as I in the middle of Migrating a web server and all its pages from a basic Apache PHP to WordPress environment on a different server.

Possible things that I have not checked were the sandbox setting suggestion. And version 52 ESR? I don't know what ESR is I will check it out.

I will report back after trying first sandboxing setting and second version 52ESR?

more options

security.sandbox.content.level = 1 fixed the issue level 3 seemed to be the default and level 2 did not fix the issue.

This still does not let Mozilla off the hook this really can never happen to anyone. Many people need the browser for real vital work related purposes. Please make an update that will prevent this issue from happening to others.

more options

oliverg said

security.sandbox.content.level = 1 fixed the issue level 3 seemed to be the default and level 2 did not fix the issue.

You had this issue on Windows? Do you use any special font manager?

more options

Nope nothing unusual with the windows config relating to fonts.

more options

Hi oliverg, since you are the first Windows user I've seen report this issue, could you file a bug? The developers then could provide steps to investigate why the narrower list of font formats and file locations at sandbox level 3 was too restrictive for your system, and decide what kind of change to make in future versions of Firefox.

https://bugzilla.mozilla.org/