Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

When I open a tab and start typing a URL in the address bar, my focus is switched to the google search box while I'm typing.

  • 4 antwurd
  • 6 hawwe dit probleem
  • 326 werjeftes
  • Lêste antwurd fan cor-el

more options

When I open a new tab in Firefox, usually the first thing I do is start typing a URL in the address bar for the new tab (normally making use of the auto complete for sites I visit a lot). The new tab usually displays a google search page which is fine. It's there if I need it.

Lately though, the behaviour of firefox when I open a new tab has changed. After I open a new tab, my focus is taken from the address bar to the google search box. I'm not talking about the Firefox search box either. I mean the search box within the google page. This happens after I have already begun typing so I get the first letter or 2 of what I type in the search box while the rest starts appearing in the google search box. When I'm typing a URL I want it to go in the address bar. Not in the search box.

Keazen oplossing

On further thought, I think there were some extensions which would try to block or reverse this behavior of the Google search page. If you check your extensions, are any of them unexpectedly disabled or missing?

You can open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then check toward the bottom for disabled extensions.

Dit antwurd yn kontekst lêze 👍 1

Alle antwurden (4)

more options

Your new tab page is Google search? This is the normal behavior of the Google search page, to move the focus into its search box. If you want to type in the address bar more often than not, you might need to choose a different new tab page.

If you want to do that, here are the steps (but if you installed an add-on that sets your new tab page, you might need to change it there):

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

more options

Keazen oplossing

On further thought, I think there were some extensions which would try to block or reverse this behavior of the Google search page. If you check your extensions, are any of them unexpectedly disabled or missing?

You can open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then check toward the bottom for disabled extensions.

more options

Changing the browser.newtab.url but I wasn't sure at first. Opened a new tab, still the same. Closed and re-opened Firefox and still the same. I re-started my computer for an unrelated reason and now my new tabs are opening about:newtab like I wanted it to. So your suggestion worked but needed a computer restart apparently. Thanks for the help.

more options

A reboot of the computer shouldn't be necessary. It sounds that Firefox didn't get closed properly and was still running if a reboot was necessary.

It is usually best to use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.