Waarom moet ik klikken om plug-ins te activeren?

Dizze side bestiet net yn it Frysk. Yn stee dêrfan binne jo nei de Nederlandse ferzje trochferwizen. As jo de side nei it Frysk oersette wolle, klik dan hjir. Jo kinne ek de Ingelske ferzje fan dizze side besjen.

De ondersteuning voor alle NPAPI-plug-ins behalve Flash is stopgezet in Firefox-versie 52, dat in maart 2017 werd vrijgegeven. Zie dit compatibiliteitsdocument en dit artikel voor details.

Vanaf Firefox-versie 52 is de ondersteuning voor alle NPAPI-plug-ins behalve Adobe Flash stopgezet. Zie dit compatibiliteitsdocument en dit artikel voor details.

Om uw surfervaring snel, betrouwbaar en veilig te houden, activeert Firefox standaard geen plug-ins. In plaats daarvan laat Firefox u kiezen of u een plug-in wel of niet op een website wilt activeren.

Hoe klikken voor activeren werkt

  1. Wanneer Firefox een plug-in blokkeert, ziet u in plaats van inhoud een melding die u vraagt te klikken om de plug-in (zoals Adobe Flash) te activeren.
    activate flash 55
    • Op sommige websites ziet u alleen een zwarte rechthoek, en aan de linkerkant van de adresbalk verschijnt het pictogram van de plug-inmelding.
    Plugin Notification Icon
  2. Als u op het bericht of het meldingspictogram klikt om de plug-in te activeren, zal Firefox u twee opties bieden:
    • Nu toestaan: activeert Flash alleen voor een eenmalig bezoek.
    • Toestaan en onthouden: activeert Flash voor alle toekomstige bezoeken van die website.
  3. Als u klikt om de plug-in te activeren en uitvoeren ervan toe te staan, zal de ontbrekende inhoud normaal worden geladen. (Als dit niet zo is, klik dan op de knop Vernieuwen FxReloadButton in de adresbalk om de pagina opnieuw te laden en probeer het nogmaals.)

Wanneer is het in orde om een plug-in te activeren?

In situaties als deze kunt u een slimme keuze maken op basis van uw huidige taak:

  • Als u een vertrouwde website gebruikt, zoals een speciale website voor uw werk of school, vindt u het wellicht veilig genoeg om een kwetsbare plug-in in te schakelen om de inhoud van de website weer te geven.
  • Als u een website niet volledig vertrouwt, bijvoorbeeld omdat u erop bent beland door op een koppeling te klikken, wilt u de plug-in waarschijnlijk niet activeren.
Plug-in altijd activeren (niet aanbevolen): u kunt plug-ins ook instellen voor altijd activeren door naar about:addons te gaan en de plug-in op Altijd activeren in te stellen. De plug-in wordt dan automatisch uitgevoerd, en u ontvangt geen melding ‘Klik om te activeren’ meer.

In het verleden kon Firefox u alleen tegen plug-ins die stabiliteits- of veiligheidsproblemen hadden beschermen door de problematische plug-in uit te schakelen. Nu kan Firefox voorkomen dat de plug-in automatisch wordt uitgevoerd (wat veel problemen bespaart) en u daarna laten kiezen of u de plug-in wilt laten uitvoeren of deze bijwerken. Lees hier hoe dit werkt.

Noot: dit artikel beschrijft wat u kunt doen als het automatisch uitvoeren van een plug-in door Mozilla is geblokkeerd vanwege beveiligings- of stabiliteitsproblemen. De meeste plug-ins dienen nog steeds te worden geactiveerd, zelfs als deze up-to-date zijn, omdat Firefox plug-ins nu standaard instelt op ‘Vragen om te activeren’ in de add-onbeheerder (Adobe Flash is de uitzondering). Zie dit blogbericht voor meer informatie.

Hoe klikken voor activeren werkt

  1. Wanneer Firefox een plug-in blokkeert, ziet u een melding die er als volgt uitziet:
    Click to play 1 new
  2. U kunt dan kiezen om de plug-in te laten uitvoeren of deze bijwerken (als een update beschikbaar is).
    • Als u klikt om de plug-in te activeren en uitvoeren ervan toe te staan, zal de ontbrekende inhoud normaal worden geladen. (Als dit niet zo is, klik dan op de knop Vernieuwen FxReloadButton in de adresbalk om de pagina opnieuw te laden en probeer het nogmaals.) Als u echter de website of een andere website die deze plug-in gebruikt daarna weer bezoekt, zult u deze melding weer zien.
    Click to play 2 new

Wanneer is het in orde om een plug-in te activeren in plaats van bij te werken?

Het bijwerken van een plug-in is altijd het veiligst, maar soms is dit misschien niet mogelijk. Zo hebt u bijvoorbeeld geen toestemming om een computer op school of op het werk bij te werken. In situaties als deze kunt u een slimme keuze maken op basis van uw huidige taak:

  • Als u een vertrouwde website gebruikt, zoals een speciale website voor uw werk of school, vindt u het wellicht veilig genoeg om een kwetsbare plug-in in te schakelen om de inhoud van de website weer te geven.
  • Als u een website niet volledig vertrouwt, bijvoorbeeld omdat u erop bent beland door op een koppeling te klikken, wilt u de plug-in waarschijnlijk niet activeren.

Een plug-in voor een vertrouwde website altijd activeren

Als u een plug-in niet kunt bijwerken en u een vertrouwde website gebruikt, kunt u die plug-in zo instellen dat deze bij het gebruik van die website automatisch wordt uitgevoerd:

  1. Klik op het rode plug-inpictogram in de adresbalk. Er wordt een berichtvenster geopend.
  2. Klik in het berichtpaneel op Toestaan en onthouden.
Fx24AllowJavaDropdown

Vanaf nu zal de plug-in bij elk bezoek aan deze website automatisch worden uitgevoerd en zult u de melding ‘Klik om te activeren’ niet meer ontvangen.

Wie dit artikel behelpsum? Ien momint...

Dizze aardige minsken hawwe dit artikel holpen te skriuwen: Tonnes. Jo kinne ek helpe - lês hjir hoe.