Afficher les questions étiquetées : Afficher toutes les questions
  • Résolu
  • Archivé

utf-8 displayed incorrectly

My site uses a template engine to wrap standard page HTML around templates that contain only the body text. However utf-8 multibyte characters are displayed correctly if… (lire la suite)

My site uses a template engine to wrap standard page HTML around templates that contain only the body text. However utf-8 multibyte characters are displayed correctly if there is no HTML header but incorrectly if the standard page header, which explicitly specifies utf-8 encoding, is presented to Firefox.

https://www.jamescobban.net/templates/Articles/FrenchOccupations.html is the template of the body text https://www.jamescobban.net/displayPage.php?template=Articles/FrenchOccupations has the HTML header and footer wrapped around it. You can look at it yourself, but to save time the header added by displayPage is:

   
   
      
        <title>
	    ...text extracted by DisplayPage from the h1 tag...
        </title>
        <meta charset="utf-8">
        <meta http-equiv="default-style" content="text/css">
        <meta name="author" content="James A. Cobban">
        <meta name="copyright" content="© 2018 James A. Cobban">
        <meta name="keywords" content="genealogy, family, tree, ontario, canada ">
        <link rel="stylesheet" type="text/css" href="/styles.css">
      

Demandé par jamescobban il y a 2 ans

Réponse de jscher2000 il y a 2 ans

  • Résolu
  • Archivé

What does *raced* from the dev tools - Network - Transferred mean?

Hello, What does (raced) mean in transferred elements? Seems to me the browser is getting the item from the server even though I've set a cache for jpeg and png files. Ot… (lire la suite)

Hello,

What does (raced) mean in transferred elements? Seems to me the browser is getting the item from the server even though I've set a cache for jpeg and png files. Other similar items are locally cached as it should.

Thank you,

Demandé par srj.elmi il y a 2 ans

Réponse de TyDraniu il y a 2 ans

  • Résolu
  • Archivé

Websockets on localhost stopped working in 66.0

After updating to Firefox 66.0 on MacOS 10.13.6 today, websockets on my localhost stopped working. When using Create React App (version of "react-scripts": "2.1.8" => … (lire la suite)

After updating to Firefox 66.0 on MacOS 10.13.6 today, websockets on my localhost stopped working.

When using Create React App (version of "react-scripts": "2.1.8" => "webpack-dev-server": "3.1.14" => "sockjs": "0.3.19"), hot reload is broken and I get following error in the console:

`The connection to ws://localhost:3000/sockjs-node/743/khw0phgj/websocket was interrupted while the page was loading.`

When I tried https://www.websocket.org/echo.html, it works fine and no problems with hot reload in Chrome 72.0.

How can I debug and fix this problem please? (when I googled the error message, I got a lot of outdated advice from previous versions of Firefox)

Demandé par Peter Hozák il y a 2 ans

Réponse de Peter Hozák il y a 2 ans

  • Résolu
  • Archivé

Styles within pages are cached and don't reload. How not to cache styles in local pages?

When developing an html or svg file I repeat editing content and style information and reload the file in Firefox. When editing styles I can't save them notifying cache. … (lire la suite)

When developing an html or svg file I repeat editing content and style information and reload the file in Firefox. When editing styles I can't save them notifying cache. When editing content in external editor and reloading file all style changes are lost. However when editing styles in external editor, I can't force to reload them without deleting cache in general and when continuing to edit styles in Firefox all previously lost changes are lost on locally stored file as well. So how can I prevent Firefox from caching style information contained in local html or svg files?

Demandé par Vollbracht il y a 1 an

Réponse de FranciscoJS12 il y a 1 an

  • Résolu
  • Archivé

Our website doesn't display properly on Firefox

Our business website has recently been relaunched, it displays fine on other browsers but is beyond broken on Firefox. I've attached a screenshot of how it looks on Chrom… (lire la suite)

Our business website has recently been relaunched, it displays fine on other browsers but is beyond broken on Firefox. I've attached a screenshot of how it looks on Chrome, to see how it looks on Firefox here is our url: https://www.exegetic.biz/.

As you can see it's VASTLY different and VERY frustrating. I've done a fair amount of reading as to what the issue could be but all the suggestions I have found are end user based... For example emptying the cache, clearing cookies, checking the zoom etc. This doesn't really help since I've looked at the site on various devices with FireFox and they all appear the same...

Has anyone else experienced this? Any help would e greatly appreciated!

Demandé par EmmaExegetic il y a 2 ans

Réponse de Wesley Branton il y a 2 ans

  • Résolu
  • Archivé

where I can find Windows Media Player plugin for FF quantum 62.0?

Hi, I have win7pro 864) and I run "FF quantum 62.0 - 32 bit" I'm really struggling with Windows Media Player plugin for FF: I downloaded and installed the latest version… (lire la suite)

Hi, I have win7pro 864) and I run "FF quantum 62.0 - 32 bit"

I'm really struggling with Windows Media Player plugin for FF: I downloaded and installed the latest version (1.0.0.8 is it?) but it doesn't work...

Indeed I cannot see it within the installed plugins and if I try to "install by file (np-mswmp.dll)" it gets me an error of file corruption...

I really don't know what to do anymore...Where can I download it?

thanks a lot!

Demandé par mfran2002 il y a 3 ans

Réponse de cor-el il y a 3 ans

  • Résolu
  • Archivé

New CSS styles not picked in Firefox.

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren'… (lire la suite)

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren't displayed in the web page nor in the developer tools inspector.

They are visible in Chromium browser and dev tools.

I have cleared the cache and refreshed the page to no avail. It is only when I restart the browser that the new style rules take effect in the browser and show up in the dev tools.

Demandé par mt3ch il y a 1 an

Réponse de cor-el il y a 1 an

  • Résolu
  • Archivé

How to remove Event Listener at the inspector panel of firefox devtools?

Guys, Removing Event listener on chrome is simple, just view it on the bottom right section, expand the element on the event trees, then click the 'remove' button. Tada a… (lire la suite)

Guys, Removing Event listener on chrome is simple, just view it on the bottom right section, expand the element on the event trees, then click the 'remove' button. Tada and putta, the event is no longer functional. But, on firefox platform, how to achieve that???

Demandé par qlintonger il y a 1 an

Réponse de Buddhika il y a 1 an

  • Résolu
  • Archivé

My website is not working in Firefox but its working fine in Chrome

I just made my website and it's not working in Firefox however in chrome its working fine. It's in Wordpress. Is something wrong with my wordpress plugins. It gives me e… (lire la suite)

I just made my website and it's not working in Firefox however in chrome its working fine. It's in Wordpress. Is something wrong with my wordpress plugins.

It gives me error that says "Secure Connection Failed"

Website Link : http://esportsrush.com/

https://i.imgur.com/QnrvzMg.jpg

Can't use the add images button below so posting imgur link here.

Demandé par gomu il y a 2 ans

Réponse de cor-el il y a 2 ans

  • Résolu
  • Archivé

Firefox 76.0 javascript window.open() parameters ignored, tool bar, etc. missing

Until several weeks ago, new windows created through Javascript with window.open() worked. We could pass the new size, and other features, e.g. menubar, toolbar, etc. and… (lire la suite)

Until several weeks ago, new windows created through Javascript with window.open() worked. We could pass the new size, and other features, e.g. menubar, toolbar, etc. and they would show up. As of v.76.0 this is no longer true. The parameters are ignored. If we use no parameters, the menubar, etc. do show, but we can't control any new window features. We have not changed our programs at all, and window.open() parameters still work correctly in Chrome, Brave, Edge, etc. How do we get Firefox to recognize the window.open() parameters (again)?

Demandé par jjacobs3 il y a 1 an

Réponse de jscher2000 il y a 1 an

  • Résolu
  • Archivé

firefox.cfg no longer overwrite new tab content

I'm using firefox developer edition. The latest version: 76.0b2 I have firefox.cfg set up to overwrite new tab content with locally stored html. The code in firefox.cfg t… (lire la suite)

I'm using firefox developer edition. The latest version: 76.0b2 I have firefox.cfg set up to overwrite new tab content with locally stored html. The code in firefox.cfg that worked until recent update:

/* set new tab page */ try {

 var newTabURL = "file:///G:/Documents/Newtab.html";
 aboutNewTabService = Cc["@mozilla.org/browser/aboutnewtab-service;1"].getService(Ci.nsIAboutNewTabService);
 aboutNewTabService.newTabURL = newTabURL;

} catch(e){Cu.reportError(e);} // report errors in the Browser Console

In the browser console there is an error message displayed:

[Exception... "Cannot modify properties of a WrappedNative" nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)" location: "JS frame :: firefox.cfg :: <TOP_LEVEL> :: line 7" data: no]

Any idea what that error message means and how to resolve it? Does anything changed regarding new tab overwrite?

Demandé par shdowmyst il y a 1 an

Réponse de cor-el il y a 1 an

  • Résolu
  • Archivé

When testing layout on Firefox Responsive Design Mode, page appears drastically different from other Chrome/Safari

I spent hours struggling with my css and nothing would make my page look right. Whenever I tested on iPhone and iPad sizes through Firefox's RDM, the behaviour I was gett… (lire la suite)

I spent hours struggling with my css and nothing would make my page look right. Whenever I tested on iPhone and iPad sizes through Firefox's RDM, the behaviour I was getting was far from what I expected. Then it dawned on me to try it on other browsers. Shockingly, it worked as expected. On Chrome and Safari sticky bar was sticking to the bottom (on FF, it's pushed way down, so can't even be seen on the screenshot. Also, putting them side by side, it's noticeable the size difference from the FF render. I did check my zoom levels (this is actual size) and minimum font (none), so I don't think this is a local configuration issue. I love the dev tools in FF, and find them much better for handling design overall, but this issue really threw me for a loop.

For reference, this was on FF 75.0 (64-bit) with Mozilla/5.0 (iPad; CPU OS 11_0 like Mac OS X) AppleWebKit/604.1.34 (KHTML, like Gecko) Version/11.0 Mobile/15A5341f Safari/604.1.

Is this a known browser issue?

Demandé par Taly il y a 1 an

Réponse de Roland Tanglao il y a 1 an

  • Résolu
  • Archivé

Instead of redirecting to our main site like all the other major browsers do, we get: "Warning: Potential Security Risk Ahead" in Firefox

When you go to https://www.northshore.com, instead of redirecting to our main site (https://www.northshorecare.com) Firefox displays an incorrect warning that the site yo… (lire la suite)

When you go to https://www.northshore.com, instead of redirecting to our main site (https://www.northshorecare.com) Firefox displays an incorrect warning that the site you were about to be redirected to is somehow a potential security risk. This happened to me in regular Firefox, Nightly and the Developer edition, so it's not just an anomoly. The live site is fully SSL-compliant and poses no such threat to the user. Is it because the redirecting domain is not secure? Can you create an exception so that people don't see this erroneous message? Or is there a way we can alter the redirect so that it doesn't trigger this warning?

The old adage "you never get a second chance to make a first impression" is in full effect in this situation and I'm sure you can see that we certainly don't want to give people any reason to not continue to our site, so hopefully you can offer a solution to this problem.

Thanks in advance!

Demandé par paul-northshore il y a 2 ans

Réponse de paul-northshore il y a 2 ans

  • Résolu
  • Archivé

Developer Tools-Style Editor_change selected code text color

This is about Style Editor, which uses different code for styling. The colors used in browser toolbox (Ctrl + Shft + Alt + I) *Style Editor* uses Code Mirror selectors. … (lire la suite)

This is about Style Editor, which uses different code for styling. The colors used in browser toolbox (Ctrl + Shft + Alt + I) *Style Editor* uses Code Mirror selectors. Due to less than perfect sight & the poor visibility / contrast colors of found search terms & several other things in Style Editor, I needed to change things.

I didn't have too much problem finding most of CM's CSS selectors for what I needed. In all the CSS files associated with code mirror in the dark theme, I haven't found how to change the foreground (text) color when selecting lines or sections of code.

In Linux, Style Editor's default selected background is almost the same as the body BG color (looking at the hex colors used, and just visually. This from codemirror.css in omni.ja, changes selected, unfocused background: .CodeMirror-selected {

 background: #D4E7F9 !important;

This changes the selected, focused BG color: .CodeMirror-line::selection, .CodeMirror-line > span::selection, .CodeMirror-line > span > span::selection {

  background-color: #E9ECD8 !important; }

But I've found nothing for foreground "color," to make the selected text legible through the light selected BG color I chose. Just adding "color: #0000FF !important;" - under the background property doesn't work (like many CSS styled UIs - especially text editors).

Is it possible that Code Mirror doesn't have a way to change the text color on selected areas? Most text editors I've tested usually have preference menu settings for things like selected - foreground & BG color. Or they have themes that add extra UI styling ability. The themes on code mirror's site don't seem to use selected foreground color (or just "color"). Maybe it doesn't understand that concept.

If the highlight BG color chosen for CM is fairly light with some transparency, you can read some darker syntax colors, but not all.

Using another text editor with better search, I looked & searched all files I could find that control some of Style Editor's / code mirror's colors.

The only thing I found where I could change selected text color was one rule for searching in Style Editor. It's in codemirror.css ... and it doesn't work that consistently for visibility. /chrome/devtools/content/shared/sourceeditor/codemirror/lib/codemirror.css

The default colors (someone) used for search term matches have little contrast.

LINE 330: .cm-searching {

 background-color: rgba(255, 255, 170, 0.6) !important; /* The 1st BG value listed is for focused search result highlight.*/
 color: #0808E5 !important;
 background-color: rgba(2226, 253, 251, .6) !important; }

NOTE: I added the color property in ".cm-searching" - and it worked. Same trick doesn't work for any selection rules I tried. Codemirror's online manual is fairly spartan https://codemirror.net/doc/manual.html#styling

Demandé par Joebt il y a 1 an

Réponse de Joebt il y a 1 an

  • Résolu
  • Archivé

Do you support NgbHighlight component?

ngb-highlight selector doesn't get customer listeners (mouseenter, mouseleave) app.component.html <ngb-highlight (mouseenter)="hello()" class="autocomplete-item" [resu… (lire la suite)

ngb-highlight selector doesn't get customer listeners (mouseenter, mouseleave)

app.component.html <ngb-highlight (mouseenter)="hello()" class="autocomplete-item" [result]="replaceSpace(result)" [term]="replaceSpace(term)"></ngb-highlight>

app.component.ts hello() {console.log('What?')}

it doesn't run, why?

Demandé par dxlam il y a 3 ans

Réponse de Shadow110 il y a 3 ans

  • Résolu
  • Archivé

remove synced data from cloud while configured to use local sync server

We use a firefox sync server locally for around 50 users. One server updated automatically and lost the custom value for the "identity.sync.tokenserver.uri" setting in ab… (lire la suite)

We use a firefox sync server locally for around 50 users. One server updated automatically and lost the custom value for the "identity.sync.tokenserver.uri" setting in about:config. This meant that any user using firefox on that server had their sync account data sent and stored in the mozilla cloud sync server. What is the process to clear and remove all the synced data from the cloud sync server for several users without removing the local sync server's contents as well?

The issue here is technically how it is done. If I reset an account's password, and then change it from my laptop which is set to use the local sync server, from what I can tell that would remove the contents from the local sync server rather than the cloud one, or would it do both somehow? Then there is the question of if I change the password while on that server, choose a new one, it will then start syncing to the cloud sync server again right?

Demandé par joel.stockley il y a 3 ans

Réponse de Shadow110 il y a 3 ans

  • Résolu
  • Verrouillé
  • Archivé

javascript using class selectors opens new tab

I have a page using javascript to filter div's depending on a selection criteria. On Safari and Chrome, the filtering works just fine. Bit onFirefox (the latest version) … (lire la suite)

I have a page using javascript to filter div's depending on a selection criteria. On Safari and Chrome, the filtering works just fine. Bit onFirefox (the latest version) instead of seeing the filtered list I see a new tab, titled About:

The attached images show the sequence, screen1 and then screen2 then screen3. I should see screen1 with a subset of the divs in the scrolling section.

The javascript is:

  function TLSshowhide(tlsclassname) {
/* first, hide all responsive div's */
var y = window.frames['theinterviewsdataframe'];
var z = y.document.getElementById('theinterviewsdata');
var x = z.getElementsByClassName('responsive');
            var i;
            for (i = 0; i < x.length; i++) {
                    x[i].style.display = 'none';
             }
/* then, show the responsive div's with the selected classname */
           x = z.getElementsByClassName(tlsclassname);          
           for (i = 0; i < x.length; i++) {
                    x[i].style.display = 'initial';
            }
}
/* When the user clicks on the artist button,  show all responsive div's */
function showArtist() {
/* when showing the artists, show all responsive div's */
var y = window.frames['theinterviewsdataframe'];
var z = y.document.getElementById('theinterviewsdata');
var x = z.getElementsByClassName('responsive');
            var i;
            for (i = 0; i < x.length; i++) {
                    x[i].style.display = 'initial';
             }
}
You can see this in action for yourself by going to http://cultconv.com/CultConv20181030/theinterviews.html and clicking the By Artist button

The list of DIV's being displayed is found in http://cultconv.com/CultConv20181030/theinterviewsdata.html

All help appreciated.

bobj

Demandé par bobjtls il y a 2 ans

Réponse de jscher2000 il y a 2 ans

  • Résolu
  • Archivé

Content-Security-Policy: frame-ancestors doesn't work

As mentioned here https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy/frame-ancestors, CSP: frame-ancestors is supported from Firefox 33. Ho… (lire la suite)

As mentioned here https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy/frame-ancestors, CSP: frame-ancestors is supported from Firefox 33. However, it seems doesn't work.

I am trying to embed a 3-party site into our page using an iframe. The 3-party site did whitelist us using these headers - Content-Security-Policy: frame-ancestors 'self' https://*.ourdomain.com - X-Frame-Options: SAMEORIGIN

It works fine on Chrome, but not Firefox. I am using Firefox 79.

Is there anything wrong with our headers?

Thank you!

Demandé par vinh.vu il y a 1 an

Réponse de vinh.vu il y a 1 an