Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Firefox was a good, but now it's slow and when I search google I have to refresh the page when I click the back button. This is driving me to other browsers.

  • 2 réponses
  • 25 ont ce problème
  • 1621 vues
  • Dernière réponse par jscher2000

more options

When searching in goole, If I click on a link and want to go back a page firefox does not load the previous google search without refreshing the page. Because I use google frequently this is very annoying. Firefox has also been freezing and crashing most frequently of any of the other browsers that I have been driven to use. I'm not sure why I should keep it on my computer at this point.

Toutes les réponses (2)

more options

hello cjgirard, please try to reset firefox and see if this can address the issue...

more options

Regarding the Google results page blanking out when you go back, this occurs when using a combination of three settings, which may be fairly common:

  • Zoom level higher than two steps (120%; the newest versions of Windows apparently default to 125%, which Firefox detects and adopts)
  • Google search set to instant prediction results (default on Google search, but can be disabled in Search settings, see Google Instant Search Help)
  • Opening results in the same tab, then using the Back button to return to the results page (default on Google search, but can be changed in Search settings to open results in a new window/tab, see Google Search Help)

Firefox's cache feature attempts to maximize speed for forward and back actions by storing the last rendering of the page. Something about the instant prediction results with zoom is causing Firefox to briefly display the results and then they blank out and you have to reload the page to get them back. The mystery is why this only occurs (so far as I have heard) on Google? Is one of Google's scripts blanking out the page? Does Google care that it's messing up Firefox users?

For now, if you do not want to or cannot change any one of the three factors needed to experience this problem, you can disable the storage of the last rendering of the page. Then Firefox will skip the shortcut and lay it out fresh, which is known to work. As noted in earlier posts, you make this change using the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered.

(3) Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).

This thread has a lengthy discussion: When I go back to Google search results page, it takes me to a blank Google screen.