Search Support

Firefox does not leep <Google> as first and main page. Welcome page is always the first Tried everything!

  • 13 réponses
  • 2 ont ce problème
  • 942 vues
  • Dernière réponse par cor-el

more options

I need your advice. Several months ago Explorer did not make it possible for me to watch videos from Flixxy.com let alone their download. Everything else, worked ok. It kept me asking to download Flush 11. I did that at least 30 times, always successfully and re-started my PC. Did not change a thing! Then I downloaded Firefox and with it I could watch and download Flixxy.com. Five days ago something happened (I forgot what!) and I did uninstall Firefox and reinstalled a new copy. Since then I have a strange outcome: When I start it, Firefox starts with its <Firefox Start Page>. I want Google and I installed it on the usual way and correctly. It comes on, but next time I restart Firefox, their <Firefox Start Page> is the one coming on. Google just does not stay on! Everything else works fine! And if I didn't care with what page they start would be OK: but I want Google! What can you advise me? Why does it happen so? All my anti virus (Norton, Malwarebytes and SUPERAntiSpyware don't show any virus. I reinstalled three times Firefox with the same results.I tried to do everything is written in Firefox help. Cheers!

Solution choisie

Hmm.. I see.. Lets get to the bottom of your system configuration and try eradicating the problem.

  1. Disable MindSpark Plugin installed on your firefox Addons > Plugins
  2. Go To Control Panel > Uninstall Programs and look for anything that says "Toolbar" or something that sounds like that, uninstall them.
  3. Now reset firefox from about:support
  4. Reboot the system

Let me know if its fixed or not.

Cheers!

Lire cette réponse dans son contexte 👍 0

All Replies (13)

more options

Well your Flixxy.com stuff isn't related to it. What exactly you are looking for is here. "firefox" > options > options Under the General Tab, specify your home page in this case google.com. If you are facing trouble with the home page being reset every time, then try starting firefox in safe mode. firefox > Help > restart with add-on's disabled

Cheers!

Modifié le par Dron Rathore

more options

Thank you for your answer, but it did not fix the problem. I tried the Tools>Option>and typing <Google.com> what it seems a million times.: Mozilla Firefox Start page keep coming on the next time I reopen the program. I clicked also all the advises in the HELP with the same result. I even tried to uninstall firefox am Control Panel and also in <Computer> ->OS(C:)->Program Files (x86)->and deleted all files of Firefox, and then download the all shebang: No difference. (Curiosity: Also Explorer does the same thing except instead of firefox it opens <NewsNMS>! Both search programs do not keep the <Google> I want and always had! Now I tried the safe mode, but it freezes and in any case it deletes, if momentarily, all my "icons".. One more thing: Also <Most visited> button keeps coming on, even when deleted. Cheers!

more options

'''''Repeat my question with a better explanation... I need your advice. Several months ago I downloaded Firefox and all was well. Five days ago something happened (I forgot what!?!) but I did uninstall Firefox and reinstalled a new copy. Since then I have a strange outcome: When I start it, Firefox starts with its <Firefox Welcome-Start Page>. But I want Google so I installed it on the usual way and correctly (…Tools>Options>General>Type www.Google.com>OK). It comes on, but next time I restart Firefox, <Firefox Welcome-Start Page> is the one opening the search program. Google just does not stay on! Also, if I click the button <Most visited> ->Delete, it goes away, only to return the next session (I don’t want it!) Everything else works fine! If I didn't care with what page it starts would be OK: but, unfortunately, I want Google! What can you advise me? Why does it happen so? All my anti virus (Norton, Malwarebytes and SUPERAntiSpyware don't show any virus. I reinstalled three times Firefox with the same results. For 6 full days I tried to do everything written in Firefox help with no results. (Also my Explorer has similar behaviour now: the only difference is that re-opens always with <NewsSMS> and not with Google!) Can you help? Cheers!

more options

Okays, thanks for clear description. Well i see your browser's modified preference seems to be correct but as you stated its not working, lets try it different way. Open a new tab, type about:support now on the page that opened click on Reset Firefox, now try setting the home page.

If it didn't work, i suggest you to downgrade firefox to V 20.0.1 from here Setup 20.0.1.exe Firefox 20.1 because V 21 is still in beta so might be facing some problem.

Cheers!

more options

The link is incorrect try here Firefox 20.1

more options

The problem that you are facing is caused by malicious softwares like free downloaders or stuff like that. So please be advised to not to install any Free Toolbar or addon from outside of firefox browser. Always use the Addon's menu of firefox to do so.

Cheers!

more options

Tried too... no result. I start to think you are right: could be malicious software! Although: 1- I have Norton 360, Malwarebytes, Advanced SystemCare and SUPERAntiSpyware... and they do not accuse anything,,, By the way: I have Firefox 20.0.1 And I did delete and reinstalled (twice) Firefox. Maybe I reinstalled the virus? Do I have it? Now is late here... got to go to bed! See you tomorrow, hopefully. Cheers!

more options

Solution choisie

Hmm.. I see.. Lets get to the bottom of your system configuration and try eradicating the problem.

  1. Disable MindSpark Plugin installed on your firefox Addons > Plugins
  2. Go To Control Panel > Uninstall Programs and look for anything that says "Toolbar" or something that sounds like that, uninstall them.
  3. Now reset firefox from about:support
  4. Reboot the system

Let me know if its fixed or not.

Cheers!

more options

...Today I called Norton for a little problem with backup. It was solved in a minute. Then I explained my problem with Firefox and the telephonist could not help, but he called a technician who took power over my computer. He really worked! He worked for 2 hours and 30 minutes!!!! And he could not fix the problem!!!! Crazy eh? Than I did what you said and found 3 toolbar in my Control panel. I uninstalled and restarted. Unfortunately also this failed! I am still in trouble! The technician added a new.. What is it called? New name? Now I have two icon when it start up. In the second one it works, but in my PC no. Perhaps I really should start all over and put a brand new copy on my PC? My patience is eally at end! Cheers!

more options

I guess that would be much better idea. :) Because Firefox has nothing to deal with the system misconfiguration. :p.

Cheers!

more options

Do a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox.

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

Your bookmarks and other profile data are stored in the Firefox Profile Folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.


more options

Done that, but Google still is changed by Welcom to Firefox. (But I did not change username. I do not know how or why Cheers! Frank

more options

Try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

You can use this button to go to the Firefox profile folder: