Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

how to remove the small top margin, which appears only on the first page of printing

  • 2 réponses
  • 1 a ce problème
  • 1407 vues
  • Dernière réponse par jrewing

more options

first i removed header and footer, and set the all margins to be found in about:config(Linux) or in Dialog (Windows) to zero.

On all html documents i get a little gap on the top of the first page, but not on the second one. The gap appears on paper print, on file print(PDF) and on preview - under firefox (17.0) for Linux and Windows. IE 8 on windows has other abnormalities, but equal top margin on all printed pages.

How can i remove this difference top margins between first page and the following once in firefox ?

Modifié le par jrewing

Solution choisie

It seems the difference is the default 8px margin on the body element, which only appears the first page. To remove it on a case-by-case basis, you could use a bookmarklet (a snippet of script you run by clicking a bookmark entry).

To remove it automatically on every page, you could use a style rule in userContent.css or in a Stylish rule. I haven't tested this rule very extensively, but something like this:

@media print{
  body {margin-top:0 !important;}
}
Lire cette réponse dans son contexte 👍 2

Toutes les réponses (2)

more options

Solution choisie

It seems the difference is the default 8px margin on the body element, which only appears the first page. To remove it on a case-by-case basis, you could use a bookmarklet (a snippet of script you run by clicking a bookmark entry).

To remove it automatically on every page, you could use a style rule in userContent.css or in a Stylish rule. I haven't tested this rule very extensively, but something like this:

@media print{
  body {margin-top:0 !important;}
}
more options

Yes - the default margin-top in body is responsible for this behavior. Thanks for your solutions.