X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

Since installing the latest FF version 14.0.1 the search boxes on the home page don't work with google

Publié

The normal google page works fine, but the search boxes on the home page (below firefox logo and the one top RH corner) just go nowhere unless you change the search provider using the dropdown, to yahoo or bing etc, in whcih case it searches fine - just won't work with google, which I prefer to use. I have an older version 3.6.13 on another desktop and that still works fine.

Any ideas team?

The normal google page works fine, but the search boxes on the home page (below firefox logo and the one top RH corner) just go nowhere unless you change the search provider using the dropdown, to yahoo or bing etc, in whcih case it searches fine - just won't work with google, which I prefer to use. I have an older version 3.6.13 on another desktop and that still works fine. Any ideas team?

Détails additionnels sur le système

Plugins installés

adobe, Java, flash, google update, google earth, quicktime, windows presentation, trade manager

Application

  • Agent utilisateur :

Plus d’informations

jscher2000
  • Top 10 Contributor
8695 solutions 71066 réponses

Do you get an error message, blank page, etc.?

In Firefox 14, the settings were changed to use Google with the https (secure connection) protocol. Can you think of any reason this could be a problem on your system or in your environment?

It's possible to go back to the earlier search behavior, but several steps are involved so I'll refer you to this thread: remove google https 14.0.1.

Any luck?

Do you get an error message, blank page, etc.? In Firefox 14, the settings were changed to use Google with the https (secure connection) protocol. Can you think of any reason this could be a problem on your system or in your environment? It's possible to go back to the earlier search behavior, but several steps are involved so I'll refer you to this thread: [https://support.mozilla.org/en-US/questions/932674 remove google https 14.0.1]. Any luck?
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 réponses

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page. Reset the <b>browser.startup.homepage_override.mstone</b> pref via the right-click context menu to the default on the <b>about:config</b> page and close and restart Firefox to restore the about:home page to its default. *http://kb.mozillazine.org/about:config #Open the <b>about:config</b> page via the location bar #Type in the Filter bar: mstone #Right-click the browser.startup.homepage_override.mstone line and select: Reset #Close and restart Firefox If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.
AliceWyman
  • Moderator
240 solutions 2594 réponses

To add to what cor-el posted (in case it helps):

Bug 749477 - Searching from about:home broken if chromeappsstore.sqlite is deleted from profile folder (comment 1) suggests that you reselect your default search engine first, which you can do from the Search Bar. (If Google doesn't work from the Search Bar, try removing it and use the "Restore Defaults" button in the Search Bar "Manage Search Engine List" dialog to add it back to the list. Alternately, try the Search Reset add-on).

After doing that, you should open about:config and then reset the preference browser.startup.homepage_override.buildID and finally, restart Firefox. That worked for me, after restarting Firefox, when I intentionally broke my about:home search by deleting the chromeappsstore.sqlite file in a test profile. (Actually, when I tested it again, resetting the browser.startup.homepage_override.mstone preference also worked.)

To add to what cor-el posted (in case it helps): [https://bugzilla.mozilla.org/show_bug.cgi?id=749477 Bug 749477 - Searching from about:home broken if chromeappsstore.sqlite is deleted from profile folder] (comment 1) suggests that you reselect your default search engine first, which you can do from the [[Search Bar|Search Bar]]. (If Google doesn't work from the Search Bar, try removing it and use the "Restore Defaults" button in the Search Bar "Manage Search Engine List" dialog to add it back to the list. Alternately, try the [https://addons.mozilla.org/firefox/addon/searchreset/ Search Reset] add-on). After doing that, you should open about:config and then reset the preference '''browser.startup.homepage_override.buildID''' and finally, restart Firefox. That worked for me, after restarting Firefox, when I intentionally broke my about:home search by deleting the chromeappsstore.sqlite file in a test profile. (Actually, when I tested it again, resetting the '''browser.startup.homepage_override.mstone''' preference also worked.)

Modifié le par AliceWyman

Auteur de la question

Cor-el

Thanks for your advice. I found the browser.startup.homepage_override.mstone line no problem and reset it, closed FF by file>exit, but every time it somehow resets it. The next time I open FF I get the "welcome to firefox" first run page. Back to about:config and sure enough the reset has been cancelled and it says 14.0.1 again....... Any ideas on what is happening there?

Cor-el Thanks for your advice. I found the browser.startup.homepage_override.mstone line no problem and reset it, closed FF by file>exit, but every time it somehow resets it. The next time I open FF I get the "welcome to firefox" first run page. Back to about:config and sure enough the reset has been cancelled and it says 14.0.1 again....... Any ideas on what is happening there?

Auteur de la question

Thanks guys for the various bits of advice, I have made one reply, further comments as follows:

1) "delete the chromeappsstore.sqlite file in the Firefox Profile Folder" - what and where is the profile folder? I don't quite follow what this chromeappsstore.sqlite file is or is doing - I am not getting an alternative search provider such as Yahoo - what actually happens I describe below.

2) Alice I really did get completely lost on the Bug 749477 thing. I read the thread, but it was mostly way over my head. I didn't feel confident enough to follow it and I wasn't too sure it applied to my situation anyway.

To hopefully make things clearer:

My home page is about:home. What actually happens if I type a search term in either the search box in the top RH corner of the page or in the google search box below the firefox logo is this - the page tab changes to "connecting" and the little circle starts revolving, just as though it is looking for the page as normal and at the bottom of the home page the message appears "waiting for www.google.com". All normal, but it never gets any further. After about 50 seconds it stops trying to connect and the tab reverts to "Mozilla Firefox Start Page"

As I stated in the original post, if I go to www.google.co.uk page the main search works as normal, but the search box in the toolbar still does not.

Thanks guys for the various bits of advice, I have made one reply, further comments as follows: 1) "delete the chromeappsstore.sqlite file in the Firefox Profile Folder" - what and where is the profile folder? I don't quite follow what this chromeappsstore.sqlite file is or is doing - I am not getting an alternative search provider such as Yahoo - what actually happens I describe below. 2) Alice I really did get completely lost on the Bug 749477 thing. I read the thread, but it was mostly way over my head. I didn't feel confident enough to follow it and I wasn't too sure it applied to my situation anyway. To hopefully make things clearer: My home page is about:home. What actually happens if I type a search term in either the search box in the top RH corner of the page or in the google search box below the firefox logo is this - the page tab changes to "connecting" and the little circle starts revolving, just as though it is looking for the page as normal and at the bottom of the home page the message appears "waiting for www.google.com". All normal, but it never gets any further. After about 50 seconds it stops trying to connect and the tab reverts to "Mozilla Firefox Start Page" As I stated in the original post, if I go to www.google.co.uk page the main search works as normal, but the search box in the toolbar still does not.

Auteur de la question

Jefferson

Thanks for your advice - before I try it can you tell me: if I go to the mycroft/mozdev site and download a new search bar will that give an additional search bar in the tool bar or just an additional "google" in the choices in the existing search bar? I don't want to end up with something I don't want and find it hard to get rid of again.

Jefferson Thanks for your advice - before I try it can you tell me: if I go to the mycroft/mozdev site and download a new search bar will that give an additional search bar in the tool bar or just an additional "google" in the choices in the existing search bar? I don't want to end up with something I don't want and find it hard to get rid of again.

Auteur de la question

I don't really know how I ended up with 14.0.1 anyway. They are still updating 3.6 (I received update to 3.6.28 today on another PC). Everything works fine here - how could I get rid of 14 and re-install 3.6.28?

Am I just deferring the problem? Will 3.6 continue to be supported? What is the difference between the two?

I don't really know how I ended up with 14.0.1 anyway. They are still updating 3.6 (I received update to 3.6.28 today on another PC). Everything works fine here - how could I get rid of 14 and re-install 3.6.28? Am I just deferring the problem? Will 3.6 continue to be supported? What is the difference between the two?
AliceWyman
  • Moderator
240 solutions 2594 réponses

golden-grace, to answer some of your questions:

  • Firefox 3.6 is no longer supported and will no longer be updated for security vulnerabilities or any other updates.
  • On resetting browser.startup.homepage_override.mstone: It's normal for the "welcome to Firefox" tab to open and for that preference to revert back to user-set and show Firefox 14.0.1 afterwards.
  • On deleting the chromeappsstore.sqlite file in the Firefox Profile Folder and then resetting that preference again: You can open the Profile folder from the Firefox Help -> Troubleshooting Information page. See the Profiles - Where Firefox stores your bookmarks, passwords and other user data article for more information.
  • On installing new search engines from http://mycroft.mozdev.org that simply adds new search providers to the Search Bar. It does not install a new search bar. You will still have a single Search Bar and the "normal" Google will still be listed.

Getting back to Google not working from the about:home homepage or from the upper right corner search box, you said, the page tab changes to "connecting" and the little circle starts revolving, just as though it is looking for the page as normal and at the bottom of the home page the message appears "waiting for www.google.com". You also said in your original post that, The normal google page works fine. Which normal google page is that?

If you can go to www.google.com directly, and it works fine:

I would try removing Google from the list of search providers and then use the "Restore Defaults" button in the Search Bar "Manage Search Engine List" dialog to add it back to the list, then select it again as your default. The Search Bar article explains in detail how to do that. (Alternately, try the Search Reset add-on. This should also add back Google and set it as the default.)

If you try going to www.google.com but it never connects, that's a whole other issue. Putting that aside for now, if you would rather use google.co.uk from the Search Bar, you can install it as an additional choice from the Search Bar drop-down menu, by going here:

If you try going to www.google.com but it never connects, you could troubleshoot that by following the Troubleshoot and diagnose Firefox problems article (I would start with clearing cookies and cache) but all of these steps may be frustrating for you. Another option is to simply reset Firefox (which saves your bookmarks, passwords, and some other essential data) to see if that resolves the problem. You can do that from the Firefox Help -> Troubleshooting Information page. For details, read the Refresh Firefox - reset add-ons and settings article. You can then go to http://mycroft.mozdev.org/google-search-plugins.html and select your preferred Google search engine to use from the Search Bar.

golden-grace, to answer some of your questions: * Firefox 3.6 is no longer supported and will no longer be updated for security vulnerabilities or any other updates. *On resetting '''browser.startup.homepage_override.mstone''': It's normal for the "welcome to Firefox" tab to open and for that preference to revert back to user-set and show Firefox 14.0.1 afterwards. *On deleting the chromeappsstore.sqlite file in the Firefox Profile Folder and then resetting that preference again: You can open the Profile folder from the Firefox Help -> Troubleshooting Information page. See the [[Profiles]] article for more information. * On installing new search engines from http://mycroft.mozdev.org that simply adds new search providers to the [[Search Bar|Search Bar]]. It does not install a new search bar. You will still have a single Search Bar and the "normal" Google will still be listed. Getting back to Google not working from the about:home homepage or from the upper right corner search box, you said, ''the page tab changes to "connecting" and the little circle starts revolving, just as though it is looking for the page as normal and at the bottom of the home page the message appears "waiting for www.google.com"''. You also said in your original post that, ''The normal google page works fine.'' Which normal google page is that? If you can go to www.google.com directly, and it works fine: I would try removing Google from the list of search providers and then use the "Restore Defaults" button in the Search Bar "Manage Search Engine List" dialog to add it back to the list, then select it again as your default. The [[Search Bar|Search Bar]] article explains in detail how to do that. (Alternately, try the [https://addons.mozilla.org/firefox/addon/searchreset/ Search Reset] add-on. This should also add back Google and set it as the default.) If you try going to www.google.com but it never connects, that's a whole other issue. Putting that aside for now, if you would rather use google.co.uk from the Search Bar, you can install it <u>as an additional choice from the Search Bar drop-down menu</u>, by going here: * http://mycroft.mozdev.org/google-search-plugins.html ... where it's listed as '''''Google UK - the Web (google.co.uk) by Mycroft Project'''''. (You will still have a single Search Bar and the "normal" Google will still be listed.) If you try going to www.google.com but it never connects, you could troubleshoot that by following the [[Basic Troubleshooting]] article (I would start with clearing cookies and cache) but all of these steps may be frustrating for you. Another option is to simply reset Firefox (which saves your bookmarks, passwords, and some other essential data) to see if that resolves the problem. You can do that from the Firefox Help -> [https://support.mozilla.org/en-US/kb/provide-detailed-information-for-firfox-issues#w_accessing-the-troubleshooting-information-page Troubleshooting Information page]. For details, read the [[Reset Firefox – easily fix most problems]] article. You can then go to http://mycroft.mozdev.org/google-search-plugins.html and select your preferred Google search engine to use from the Search Bar.

Modifié le par AliceWyman

AliceWyman
  • Moderator
240 solutions 2594 réponses

P.S. Before trying the above, here's something you can try first: Download the installer for the English (British) version of Firefox from http://www.mozilla.com/firefox/all.html and save it to your computer. You can then uninstall Firefox 14.0.1 and install the British version.

Ref: https://support.mozilla.org/questions/862450


Download Firefox English (British) version:

   http://www.mozilla.com/en-US/firefox/all.html 

Uninstalling Firefox

   https://support.mozilla.com/en-US/kb/Uninstalling%20Firefox
   DO NOT SELECT TO REMOVE USER DATA AND SETTINGS 

Install Firefox English (British) version

   https://support.mozilla.com/en-US/kb/Installing%20Firefox%20on%20Windows
P.S. Before trying the above, here's something you can try first: Download the installer for the English (British) version of Firefox from http://www.mozilla.com/firefox/all.html and save it to your computer. You can then uninstall Firefox 14.0.1 and install the British version. Ref: https://support.mozilla.org/questions/862450 ----- Download Firefox English (British) version: http://www.mozilla.com/en-US/firefox/all.html Uninstalling Firefox https://support.mozilla.com/en-US/kb/Uninstalling%20Firefox DO NOT SELECT TO REMOVE USER DATA AND SETTINGS Install Firefox English (British) version https://support.mozilla.com/en-US/kb/Installing%20Firefox%20on%20Windows

Auteur de la question

Thanks Claire

Tried "Reset FF" - no good. Un-installed and re-installed GB version - no difference. Added Google.com from Mycroft, selected it - no difference Added google.co.uk from Mycroft and it works fine!!!!

A result of sorts and certainly better, doesn't fix the search box in the middle of the page under the FF logo though, doesn't really solve the mystery, unless it does for you?

I've found how to open the profile folder, what exactly are you suggesting to do with the chromeappsstore.sqlite file? Delete it? Then what?

Many thanks

Thanks Claire Tried "Reset FF" - no good. Un-installed and re-installed GB version - no difference. Added Google.com from Mycroft, selected it - no difference Added google.co.uk from Mycroft and it works fine!!!! A result of sorts and certainly better, doesn't fix the search box in the middle of the page under the FF logo though, doesn't really solve the mystery, unless it does for you? I've found how to open the profile folder, what exactly are you suggesting to do with the chromeappsstore.sqlite file? Delete it? Then what? Many thanks

Auteur de la question

I should also have said by the way that by the "normal" google page working OK, I meant google.co.uk, but if you try for google.com in the UK it automatically re-directs to google.co.uk and I don't know how to get round this. Maybe the re-direct is part of the problem?

I should also have said by the way that by the "normal" google page working OK, I meant google.co.uk, but if you try for google.com in the UK it automatically re-directs to google.co.uk and I don't know how to get round this. Maybe the re-direct is part of the problem?
AliceWyman
  • Moderator
240 solutions 2594 réponses

You can try cor-el's suggestion to delete the chromeappsstore.sqlite file from the profile folder and then reset the browser.startup.homepage_override.mstone preference, then restart Firefox ... but, if you already tried the Reset Firefox feature and it didn't help, I'm not sure that will either, since a Firefox reset will automatically create a new profile with default files and preferences.

Maybe cor-el or another contributor will be along shortly with other suggestions, that will let you use a Google search from the about:home page. At least the Search Bar is working with Google UK from Mycroft.

You can try cor-el's suggestion to delete the chromeappsstore.sqlite file from the profile folder and then reset the browser.startup.homepage_override.mstone preference, then restart Firefox ... but, if you already tried the [[Reset Firefox – easily fix most problems|Reset Firefox feature]] and it didn't help, I'm not sure that will either, since a Firefox reset will automatically create a new profile with default files and preferences. Maybe cor-el or another contributor will be along shortly with other suggestions, that will let you use a Google search from the about:home page. At least the Search Bar is working with Google UK from Mycroft.
AliceWyman
  • Moderator
240 solutions 2594 réponses

P.S. Did you ever try removing the "regular" Google entry from the Search bar "Manage Search Engine List" and then using the "Restore Defaults" button to add it back? The only other suggestion would be a clean reinstall, after removing the Firefox installation directory. See: http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

P.S. Did you ever try removing the "regular" Google entry from the [[Search Bar|Search bar]] "Manage Search Engine List" and then using the "Restore Defaults" button to add it back? The only other suggestion would be a clean reinstall, after removing the Firefox installation directory. See: http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall

Modifié le par AliceWyman

Auteur de la question

Update: I tried deleting the chromeappsstore.sqlite file and then resetting the browser.startup.homepage_override.mstone line in about:config as reccomended by cor-el's first post, but it made no difference.

Update: I tried deleting the chromeappsstore.sqlite file and then resetting the browser.startup.homepage_override.mstone line in about:config as reccomended by cor-el's first post, but it made no difference.
AliceWyman
  • Moderator
240 solutions 2594 réponses

You wrote: Update: I tried deleting the chromeappsstore.sqlite file and then resetting the browser.startup.homepage_override.mstone line in about:config as reccomended by cor-el's first post, but it made no difference.


Did you close Firefox after doing the above, and then reopen it?

You wrote: ''Update: I tried deleting the chromeappsstore.sqlite file and then resetting the browser.startup.homepage_override.mstone line in about:config as reccomended by cor-el's first post, but it made no difference.'' Did you close Firefox after doing the above, and then reopen it?

Modifié le par AliceWyman

Auteur de la question

Yes I did try removing the original google entry and restoring defaults, but to no avail.

Yes I did try removing the original google entry and restoring defaults, but to no avail.

Auteur de la question

Did I close ff and re-open? Certainly, yes.

I even went and did it again to check. I notice the chromeappsstore.sqlite file reappears after you re-start (which means it re-appears before you can re-set browser.startup.homepage_override.mstone as you cannot delete chromeappstore.sqlite when firefox is open)

Is this normal?

Did I close ff and re-open? Certainly, yes. I even went and did it again to check. I notice the chromeappsstore.sqlite file reappears after you re-start (which means it re-appears before you can re-set browser.startup.homepage_override.mstone as you cannot delete chromeappstore.sqlite when firefox is open) Is this normal?
AliceWyman
  • Moderator
240 solutions 2594 réponses

Yes, the chromeappsstore.sqlite file is supposed to re-generate after you delete it from the profile folder and restart Firefox. It's at that point that you would use about:config to reset the browser.startup.homepage_override.mstone and/or the browser.startup.homepage_override.buildID preference(s), then restart Firefox again.

Anyway, other than a clean reinstall I'm out of ideas.

Yes, the chromeappsstore.sqlite file is supposed to re-generate after you delete it from the profile folder and restart Firefox. It's at that point that you would use about:config to reset the '''browser.startup.homepage_override.mstone''' and/or the '''browser.startup.homepage_override.buildID''' preference(s), then restart Firefox again. Anyway, other than a [http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall clean reinstall] I'm out of ideas.
AliceWyman
  • Moderator
240 solutions 2594 réponses

One more idea.

Did you ever try my suggestion to follow the Troubleshoot and diagnose Firefox problems article starting with step 2 (clear your cookies and cache)?

Even if you used the Reset Firefox feature, that may not work if the problem has to do with cookies, since a reset transfers your cookies to a new profile (and bookmarks, passwords, browsing history and form-fill data).

You can try just clearing google cookies, then restart Firefox. I found this solution here:


clear all cookies from google.com & google.co.uk and the browser cache

One more idea. Did you ever try my suggestion to follow the [[Basic Troubleshooting]] article starting with step 2 (clear your cookies and cache)? Even if you used the [[Reset Firefox – easily fix most problems|Reset Firefox]] feature, that may not work if the problem has to do with cookies, since a reset transfers your cookies to a new profile (and bookmarks, passwords, browsing history and form-fill data). You can try just clearing google cookies, then restart Firefox. I found this solution here: *https://support.mozilla.org/en-US/questions/926533#answer-330230 Firefox will not search using google.co.uk after an upgrade from Firefox 10.0.3 to 10.0.4 ----- [[Deleting cookies|clear all cookies from google.com & google.co.uk]] and the [[How to clear the cache|browser cache]]
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 réponses

Note that some sites like Google also use local storage, so you may have to delete the webappsstore.sqlite file as well.
Local (DOM) Storage can also be cleared by clearing cookies via Clear Recent History and the time range set to everything, but that removes all cookies.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

Yo can also do a malware check with some malware scanning programs on the Windows computer.
You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Note that some sites like Google also use local storage, so you may have to delete the webappsstore.sqlite file as well.<br /> Local (DOM) Storage can also be cleared by clearing cookies via Clear Recent History and the time range set to everything, but that removes all cookies. You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Open Containing Folder ---- Yo can also do a malware check with some malware scanning programs on the Windows computer.<br /> You need to scan with all programs because each program detects different malware.<br /> Make sure that you update each program to get the latest version of their databases before doing a scan.<br /><br /> *http://www.malwarebytes.org/mbam.php - Malwarebytes' Anti-Malware *http://www.superantispyware.com/ - SuperAntispyware *http://www.microsoft.com/security/scanner/en-us/default.aspx - Microsoft Safety Scanner *http://www.microsoft.com/windows/products/winfamily/defender/default.mspx - Windows Defender: Home Page *http://www.safer-networking.org/en/index.html - Spybot Search & Destroy You can also do a check for a rootkit infection with TDSSKiller. *http://support.kaspersky.com/viruses/solutions?qid=208280684 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked