Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Why has the spellchecker become retarded?

  • 5 réponses
  • 2 ont ce problème
  • 39 vues
  • Dernière réponse par cor-el

more options

It used to be that the spellcheck features built into firefox did exactly what I needed, that is to tell me when I misspelled a word. However, it seems these days that it's source dictionary is crafted by complete morons.

Over 2 dozen times now I have been told a word somewhere in my internetting is wrong, only to google it and find out that guess what? IT WAS SPELLED PROPERLY. The spellcheck no longer recognizes so much as the word MILLENIUM. WTF ha[pened?

Modifié le par cor-el

Solution choisie

Unless you purposely misspelled the word MILLENIUM in your question, the correct spelling is millennium (2 n's, not 1).

You should install a dictionary instead of relying on the built-in dictionary (U. S. English Firefox only). It appears that you do not have a dictionary installed: https://addons.mozilla.org/en-US/firefox/language-tools/

That correct spelling is shown in the U. S. English dictionary when right-clicking on the misspelled word. I do not have the British English dictionary installed.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Lire cette réponse dans son contexte 👍 1

Toutes les réponses (5)

more options

Solution choisie

Unless you purposely misspelled the word MILLENIUM in your question, the correct spelling is millennium (2 n's, not 1).

You should install a dictionary instead of relying on the built-in dictionary (U. S. English Firefox only). It appears that you do not have a dictionary installed: https://addons.mozilla.org/en-US/firefox/language-tools/

That correct spelling is shown in the U. S. English dictionary when right-clicking on the misspelled word. I do not have the British English dictionary installed.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Modifié le par SafeBrowser

more options

I suppose I just misunderstood some of what google has told me.

nevertheless, I've had many proper spelled words be called wrong, so I'm rather thankful for the dictionary app, I suspect it will help me quite a bit.

more options

Makaub:

To help other users find solutions, please return and sign-in to the forum with your user name and password:

  • click on "Solved It" next to my first reply ABOVE if it BEST solved your question
  • DO NOT click "Solved It" next to this reply

Thanks




Be sure to thoroughly read the articles concerning spell checking. You can add words that are not in the Add-on dictionary (your personal dictionary). You can also edit words added to your personal dictionary.

There are some Google results using the spelling that you originally indicated being used for games, hotels, foundations, etc., but that spelling is actually not proper. When searching for those using an improper spelling, you must search by their spelling of the word. For correct spelling in acceptable spoken or written language, always consult a dictionary.

Modifié le par SafeBrowser

more options

I have a problem with spellchecker, too. I can't remember when it began, but it is saying words are misspelled when they are not. For example, "few." That's just the most recent example I can think of. It's become a daily issue. I actually came to the forum to search for a way to turn it off, it's become such an annoyance. I am tired of clicking "add to dictionary" just to get the red off my page.

more options

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.

  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries: