X
Appuyez ici pour vous rendre sur la version mobile du site.
Votre Firefox n'est pas à jour et peut présenter un risque de sécurité ! Mettre à jour Firefox

Forum d'assistance

can't get moonlight to install on firefox 5.0

Publié

I was trying to install the latest version of moonlight but it said that it was not compatible with firefox 5.0. is there something that i can do to fix this? it worked when i had an older version.

Solution choisie

You can try to download the Moonlight extension and bump the maxVersion from 4.0.* to 5.*
The extension is signed to protect the extension against changes, so you need to remove the META-INF folder that stores the data to verify the signing.

See:

Lire cette réponse dans son contexte 10

Détails additionnels sur le système

Ceci est arrivé

Je ne sais pas à quelle fréquence

Plugins installés

  • The next generation Java plug-in for Mozilla browsers.
  • Shockwave Flash 10.3 d180
  • Gecko Media Player 1.0.0Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

Application

  • Agent utilisateur : Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0

Plus d'informations

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 réponses

Solution choisie

You can try to download the Moonlight extension and bump the maxVersion from 4.0.* to 5.*
The extension is signed to protect the extension against changes, so you need to remove the META-INF folder that stores the data to verify the signing.

See:

Auteur de la question

i tried that but firefox is now saying that the extension may be corrupted.

Auteur de la question

never mind i figured out what i forgot. i appreciate it very much

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 réponses

You're welcome

passerpunt 0 solutions 1 réponses

Réponse utile

I found an other way: download the compatibility Reporter addon. this addon makes firefox to ignore the compatibility of the addon: https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/?src=api

Now moonlight works fine for me!
riteshbafna 0 solutions 2 réponses

I changed the maxVersion to 5.0* and removed META-INF folder but I am getting the same error "extension may be corrupt". What am I missing? I also tried installing compatibility Reporter addon, but it does not let me install moonlight. I checked extensions.checkCompatibility in about:config, and everything is set to false. Please help

Modifié le par riteshbafna

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 réponses

Did you make sure that you didn't corrupt the extensions .xpi file by editing the maxVersion?

Which program did you use to edit the file?

I usually do that by editing the file directly from inside the archive (cursor right to open and F4 to edit).
Krusader allows this and probably other file managers as well (haven't tested this).

riteshbafna 0 solutions 2 réponses

I extracted the .xpi file, opened install.rdf in gedit, changed maxVersion from 4.0.* to 5.0.*, saved it, deleted META-INF, zipped it, renamed it to xyz.xpi and tried opening in Firefox.

krtschil 0 solutions 1 réponses

The workaround with Add-on Compatibility Reporter is o.k. but I have problems in newer versions of Firefox (7.0a2, 8.0a1) with one silverlight application:

Here http://2seeitlive.com/twic/ you see the application work with FF 5 but does not work properly. Errors in the console:

Moonlight: browser bridge not found for your browser (likely not needed). User agent = 'Mozilla/5.0 (X11; Linux i686; rv:7.0a2) Gecko/20110706 Firefox/7.0a2' Moonlight: Plugin AppDomain Creation: OK Moonlight: URL = http://2seeitlive.com/twic/ Moonlight: URL = http://2seeitlive.com/twic/ClientBin/SilverBoard.xap Moonlight: OpenGL vendor string: Tungsten Graphics, Inc Moonlight: OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile GEM 20100330 DEVELOPMENT x86/MMX/SSE2 Moonlight: OpenGL version string: 2.1 Mesa 7.10.2 Using native xaml parser. trying to load: /System.Windows;component/themes/generic.xaml value_to_variant, can't create a variant of a 0 = (null) value_to_variant, can't create a variant of a 0 = (null) System.InvalidOperationException: Operation is not valid due to the current state of the object

 at System.Windows.Browser.ScriptObject.InvokeInternal (System.String name, System.Object[] args) [0x00000] in <filename unknown>:0 
 at System.Windows.Browser.ScriptObject.Invoke (System.String name, System.Object[] args) [0x00000] in <filename unknown>:0 
 at System.Windows.Browser.HtmlObject+DOMEventListener.AttachEvent () [0x00000] in <filename unknown>:0 
 at System.Windows.Browser.HtmlObject.AttachEvent (System.String eventName, System.EventHandler`1 handler) [0x00000] in <filename unknown>:0 
 at SilverBoard.Page..ctor (System.String fen, System.String fenfile, System.String san, System.String pgnfile, Int32 refreshInterval, Int32 currentGameIndex, Boolean selectGame, System.String notation, Int32 ply, Boolean arrows, Color lightSquareColor, Color darkSquareColor, Boolean turned, System.String header, System.String piece) [0x00000] in <filename unknown>:0 
 at SilverBoard.App.Application_Startup (System.Object sender, System.Windows.StartupEventArgs e) [0x00000] in <filename unknown>:0 
 at System.Windows.Application.OnStartup (System.Windows.StartupEventArgs e) [0x00000] in <filename unknown>:0 
 at System.Windows.Deployment.CreateApplication () [0x00000] in <filename unknown>:0 
 at System.Windows.Deployment.LoadAssemblies () [0x00000] in <filename unknown>:0 
 at System.Windows.Deployment.InitializeDeployment (IntPtr plugin, System.String xapPath, System.String culture, System.String uiCulture) [0x00000] in <filename unknown>:0 

Moonlight: ErrorEventArgs created with message: 'Operation is not valid due to the current state of the object' EMIT OF EVENT Error(1) ON OBJECT Surface CALLED WITH NO LISTENERS AND NON-NULL CALLDATA


Any ideas?

dumbo2 0 solutions 1 réponses

riteshbafna, I had the exact same problem. I'm assuming you had created a new folder where you extracted all the files from the original .xpi file. It seems it doesn't like it if you zip the entire folder (because when unzipped it produces a folder, not the individual files). So I just opened the folder (after modifying the .rdf file and deleting the META-INF folder), did "Select All", right-clicked and chose "Compress", and renamed the resulting .zip file to .xpi. Voila!

Modifié le par dumbo2

jonaternet 0 solutions 1 réponses

Same issue for me on firefox 6 AND seamonkey 2.0.14 installed on fedora 15 64 bits, none of the solutions work :( . Error message while trying to open http://info.francetelevisions.fr/?id-video=000299234_CAPP_LeQIhistoireduneimposture_190820111626_Au :

Error at Sys.UI.Silverlight.MediaPlayer._ensureLoaded () [0x00000] in <filename unknown>:0

 at Sys.UI.Silverlight.MediaPlayer.stop () [0x00000] in <filename unknown>:0 
 at FTVIPlayerLight.Silverlight.UserControls.Controllers.UCPlayerController.set_IdContent (System.String value) [0x00000] in <filename unknown>:0 
 at FTVIPlayerLight.Silverlight.UserControls.Controllers.UCPlayerController.PlayCommand_Executed (System.Object sender, SLExtensions.Input.ExecutedEventArgs e) [0x00000] in <filename unknown>:0 
 at (wrapper delegate-invoke) <Module>:invoke_void__this___object_ExecutedEventArgs (object,SLExtensions.Input.ExecutedEventArgs)
 at SLExtensions.Input.Command.Execute (System.Object parameter) [0x00000] in <filename unknown>:0 
 at FTVIPlayerLight.Silverlight.App+<>c__DisplayClass8.<Application_Startup>b__1 (System.Object , System.EventArgs ) [0x00000] in <filename unknown>:0 
 at FTVIPlayerLight.Silverlight.MainController.OnInitialized () [0x00000] in <filename unknown>:0 
 at FTVIPlayerLight.Silverlight.MainController.set_IsBusy (Boolean value) [0x00000] in <filename unknown>:0 
 at FTVIPlayerLight.Silverlight.MainController.SetBusyCounter (Boolean isBusy) [0x00000] in <filename unknown>:0 
 at FTVIPlayerLight.Silverlight.UserControls.Controllers.UCMainContentController.webclientMostViewed_DownloadStringCompleted (System.Object sender, System.Net.DownloadStringCompletedEventArgs e) [0x00000] in <filename unknown>:0 
 at System.Net.WebClient.OnDownloadStringCompleted (System.Net.DownloadStringCompletedEventArgs e) [0x00000] in <filename unknown>:0 
 at System.Net.WebClient+<DownloadStringAsyncCallback>c__AnonStorey3.<>m__5 (System.Object sender) [0x00000] in <filename unknown>:0 
 at System.Windows.Threading.Dispatcher.InvokeDelegate (System.Delegate d, System.Object[] args) [0x00000] in <filename unknown>:0 
 at System.Windows.Threading.Dispatcher+<Invoke>c__AnonStorey4B.<>m__B1 () [0x00000] in <filename unknown>:0

Modifié le par jonaternet

TheDaddy 0 solutions 2 réponses

Installation of Moonlight plugin fail on Firefox 7.0.1 because it is not compatible. Found this, worked for me

I found an other way: download the compatibility Reporter addon. this addon makes firefox to ignore the compatibility of the addon: https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/?src=api Solution By passerpunt