Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Why won't Firefox let me add an exception?

  • 23 réponses
  • 224 ont ce problème
  • 1025 vues
  • Dernière réponse par elangeland

more options

Firefox tells me that a site has an invalid security certificate, which I know. It asks if I want to Add an Exception and I click to add one. It pops up the Add Security Exception window and that window tells me that this site has a valid certificate and there is no need to add an exception; but I DO need to add an exception and it won't do it for me. Why? I am working in a secure test lab and use Firefox to login to our systems under test. Each time we change or add hardware we must add exceptions to login to a system. I have done this for years with Firefox but now Firefox 4 seems confused. We now need to use EI, which I would rather not.

Solution choisie

I was able to fix this on one machine by clearing my recent history through the Options dialog. On a second occasion, I was able to rule out "Browsing & Download History" and "Form & Search History", so I can say at this point that the problem can be fixed by clearing one or more of Cookies, Cache, "Active Logons", or "Site Preferences".

Oh, in all cases, I selected "Everything" for the time period to clear.

Lire cette réponse dans son contexte 👍 8

Toutes les réponses (3)

more options

I'm having a same problem where firefox complains about the self-signed cert but then when you click on view certificate, it says it's fine. I have an old self-signed cert that was expired which didn't seem to bother firefox until recently. I even tried issues a new valid cert and chrome and IE can see the new cert (new expiration dates) but firefox still gives me the "this connection is untrusted message". Then when I try to view the cert to add an exception it says it fine. One thing I noticed was that view cert in FF still shows the old cert expiration dates, whereas in chrome and IE the new cert shows up.

I have tried deleting the certs out of the certificate manager and adding the FF exception again but it didn't work. I even used IE to install the self-signed root cert again. IE and chrome will now open as a trusted page but FF still has the "this connection is untrusted" -> view -> cert is valid message.

I'm going to try a few of the suggestions above hopefully something will reset FF's cert exception/cache or something.

Thanks

more options

I overinstalled FF 7.0 and FF 6.0.2 but it didn't help. I said heck with it and created a new profile and copied my profile over from a working machine. It's working ok now. upgraded back to FF 7.0.1

more options

Solution choisie

I was able to fix this on one machine by clearing my recent history through the Options dialog. On a second occasion, I was able to rule out "Browsing & Download History" and "Form & Search History", so I can say at this point that the problem can be fixed by clearing one or more of Cookies, Cache, "Active Logons", or "Site Preferences".

Oh, in all cases, I selected "Everything" for the time period to clear.

  1. 1
  2. 2