Rechercher dans l’assistance

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Scrolling in Firefox 4 i slow and unresponsive and sometimes just stops working. Why?

  • 29 réponses
  • 1243 ont ce problème
  • 491 vues
  • Dernière réponse par hardon

more options

It's way more choppy and unresponsive (ie I scroll, and there is a delay before the scroll actually happens) than before and quite often the scroll function just stops working and I have to close and re-open the page to get it working again. Mouse actions actually feel more sluggish overall.

Toutes les réponses (20)

more options

It happens to me as well, Im using windows xp 32 bits, could be the OS the problem?

more options

Scrolling and overall performance, opening new tabs, menus etc was choppy and slow for me after the update to Firefox 4. First I tried disabling all my extensions. Problem persisted. Next I tried using the Firefox safe mode. This resolved the problem. After a little more poking around I unchecked "Use hardware acceleration when available" and restarted FF. Now everything was smooth.

This is on a Dell E6410 running Windows XP and the latest driver updates available from Dell.

more options

The answer that Dospac provided did the trick for me.

more options

There's an easy solution.

I applied the fix described in this article http://www.technipages.com/firefox-3-fix-for-slow-or-choppy-scrolling.html and it (almost) fixed the problem for me. I use windows xp sp3. When scrolling it was completely freezing (sometimes) for seconds and it was almost unusable (setting "use hardware acceleration" was on), now the problem gone.

Just add to userContent.css;

body {

  background-attachment: scroll !important;

}

It should be turned on by default or so, since the browser was simply almost unusable. This problem was in previous version, but to much lesser extent than in 4.

more options

I have the same painfully slow operation with Firefox 4.0. I find the only way to overcome the problem is to reboot. Not a great solution but seems to work. I use OS X 10.5.8

more options

I tried the Hardware Acceleration fix and Chrome File editing but neither worked. This problem has plagued me from the moment I installed FF4 on a Win XP Pro machine (actually 3 nearly identical machine but only one has the problem???). The easy fix was disabling all Plugins and Extensions (Tools\Add-ons\Plugins&Extensions) except Java and after a reboot the problem was gone. I still have to turn them on one by one to pin point the problem but at least I can get back to work.

more options

lol if i opened two youtube videos it would become unresposive. i have a toshiba qosmio x505 with a i5 intel processor.. windows 7 64bit 4gb gddr3 ram. there is no reason for that. IE 9 runs WAY smoother than it. haha

more options

I just reinstalled Firefox 3.6.15 on My Dell XPS Laptop running Windows 7 and THAT fixed the problem just fine. With Google Chrome out there, I'm not spending hours saving profiles and renaming them to do something that the folks at Mozilla will fix eventually. You want your speed back? Go back to your previous version.

Modifié le par alexmccat

more options

I am experiencing a similar issue after updating to FF 4 on my 32bit XP machine. Scrolling any page using the up/down keys will spike CPU usage to about 50%. I tried safe mode and disabling all extensions but the problem persists. Smooth scrolling and auto scrolling are unchecked in preferences as well. I reinstalled FF 3.6 and did not have this problem. Scrolling using the mouse wheel or PageUp/PageDown keys does not cause nearly as much CPU usage.

more options

The problem is the AOL toolbar. Please go to Tools - Add Ons- Extensions- Uninstall the AOL toolbar.

My Firefox is working great after I did this :)

more options

I have been a loyal FF user for several years. FF 4 has been a disappointment. Pages freeze and nothing but Control+Alt+Delete solves the problems.

Sometimes, the problem becomes too frequent and I have to switch to IE ...

I don't know if this is a related issue but my keyboard becomes unresponsive as well.

more options

I have actively promoted FireFox for over five years now but version 4 is driving me nuts... I feel like I am on dial-up again constantly waiting for FireFox to catchup with my 25wpm typing speed. Responsivness is horrible even when I have only one tab open. I never would have thought IE would beat out FF on speed and responsiveness but such is the current case with me.

My operating system is Windows XP Home edition SP3 running on a computer with a Celeron 2.66Ghz processor with 2GB of memory. I test websites so I can and do use other browsers but would like to continue using FF as my primary browser. Responsiveness measured in seconds is making this problomatic at best.

I have disabled many of the approved add-ons, stripped out the approved themes, and disabled hardware acceleration. I have restored the original default config for FF and totally cleaned and optimized my own system with no obvious improvement in FireFoxe 4s performance. Help!!!

more options

The scrolling in pages is choppy or causes freezing. The typing lags big-time; I can hardly type correctly because of it. And major video problems. Video is choppy and slow, not in sync and basically screwed up big-time. Right now my typing is totally messed up. I have Windows 7.

more options

Also: Sometimes the back arrow goes dark in tabls so I can's go to previous pages.

Thinking about switching (AGAIN) to IE (yuck) or Opera or Safari, because this typing lag thing is so beyond annoying and I have to go to IE to watch videos.

more options

I have Windows XP Pro SP2.

I have toiled with this for some time and the best I can get to aiding a resolution is:

Step 1: Add the following lines to userchrome.css

body {

background-attachment: scroll !important;

}

Step 2: disable plugincontainer.exe using about:config >> dom.ipc.plugins.enabled = false

Step 3: Disable "Hardware acceleration" (as mentioned above)

Note: This worked fine for a while but eventually ended up going SLOWWWWWW again ... so still no solution :-(

Dropped back to FF 4beta4 which has other problems but works for me better than FF 4.0.1

FF 5beta5 which I just tried also goes SLOWWWWWW

Good luck with any more possible solutions.

Modifié le par zogmeister

more options

I am using windows 7 64 bits ultimate on a phenom II 955 with 8gbyte memory. Should be sufficient for a web browser.

firefox often just freezes for a period of time. It takes 10 to 60 seconds for firefox to start responding again. It happens at different sites, looks to me as if firefox is waiting for some banner/advertisements to be downloaded but waits on some sort of time-out.

more options

My latest finding:

I disabled disk caching in about:config

browser.cache.disk.enable = false

and this looks promising.

Been running FF 4.0.1 for about 4 hours and no slow-downs so far.

Fingers crossed :-)

Note: The memory cache is enabled:

browser.cache.memory.enable = true

Caching still seems to work fine with the cached stuff coming from the memory cache and not the disk.

Good luck folks :-)

more options

Disabling disk cache in about:config seems to have solved the scrolling problem for me too. Now I have to see what problems that will create. ________________________________________

I am using Win7 64 Pro, 8 GB ram, AMD X3 450 cpu. ________________________________________

Update: Problem just resurface on this page. NOT A SOLUTION!

Everything seemed fine for a while on multiple websites until editing the top part of this post when scrolling again went beserk.

Modifié le par Straggler

more options

@Straggler: Yeah. It was only a matter of time before the SLOW issue resurfaced for me too. I have spent about 2 weeks trying every possible fix to this: CACHE / HARDWARE ACCELERATION OFF / Adobe Flash plugin disabled / NO ADDONS and eventually the issue resurfaces ... sometimes after a few hours and sometimes after a few minutes :-(

I have to admit defeat at this point and have been forced to abandom my Firefox until mozilla resolve this issue. Having used FF since its root beginnings this is painful.

Currently using google chrome 12.0.742.100 with adblockplus and flash-blocker extensions and am totaly blown away with the improvement to my browsing experience.

I'll keep downloading future versions of FF until they come out with one where the SLOW issue has been resolved.

I'll keep coming back here to this page to see if anyone else has more ideas.

One final note: I spent yesterday using the latest 5.0 Beta 7 RC (Release Candidate) version but the SLOWWWWWW issue is still present in this version ... which leads me to believe that FF 5.0 will have NOT resolved this major problem. Maybe FF 6.0 ??? :-)

I was starting to doubt my PC hardware but as others here have detailed, their more-than-adequate hardware should easily handle a web browser. My old 1.6GHz CPU / 512MB RAM runs google chrome blindingly fast.

Couldn't resist a little dig (JOKE) at mozilla for messing me around on this one: http://img59.imageshack.us/img59/5017/firefoxdownloadcount01a.png

Luck !!!

Modifié le par zogmeister

more options

FF 5.0 is out and the problem persists. Anyone at mozilla listening?

Seriously, I have had to resort to google chrome and installed chrome version 11.0.696.71 to retain the saving of youtube videos to the chrome profile cache folder. Subsequently upgraded to chrome version 12.0.742.122

This chrome thing rocks !!!!!!!!

I'm gonna keep trying firefox until someone at mozilla realizes they have an issue and get it resolved. I miss firefox :-(

Modifié le par zogmeister

  1. 1
  2. 2