Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Cannot open HTML files on Win7 using FF 3.6.10 as default browser.

  • 3 réponses
  • 43 ont ce problème
  • 249 vues
  • Dernière réponse par bear6579

more options

When I click on any HTML file in Windows 7 (64 bit, Ultimate) I get an error dialog that says "There was a problem sending the command to the program."

The only way I can open local HTML files is with IE as default browser - which I do not want.

I first noticed the error when clicking links in emails in Outlook 2010. But now it also happens on any local HTML file - like help files (help files that I really need to be able to easily read).

I have tried editing the registry (this solution found at which temporarily fixed the problem, but would not work a second time to fix the issue as the change I made was still present in the registry, so nothing to do.

I tried making IE the default browser then making FF the default browser again, but that didn't work.

I tried checking the default program for HTML files in Win7, but that is set to FF.

I don't get it. This just started happening in the last 2 weeks or so.

The "This happened" drop-down below is not entirely correct. This happens whenever I click on a local HTML link or a link in an Outlook email. But, the "This happened" drop down does not have an option for "When I click a local HTML link".

Toutes les réponses (3)

more options

I followed the directions at for setting the default program to FF - but it still fails.

more options

Windows 7 (64 bit, Pro) here - firefox 3.6.12 - "There was a problem sending the command to the program" when doubleclicking on htm/html - googled and tried the various solutions nothing seems to work - IE opens it fine - I cannot even drag and drop the file to FF Please help

more options

( links in emails )

this is what fixed my issue with links in my windows live mail

in Firefox go to tools >options >advanced > general tab > at the bottom click the check now button to make sure Firefox is your default browser . if its not click yes to make it default now your links in emails should open in Firefox properly

Modifié le par bear6579