Rechercher dans l’assistance

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Single word address bar searches resolve with bing search results, not google

  • 37 réponses
  • 57 ont ce problème
  • 285 vues
  • Dernière réponse par mhorvitz

more options

I've installed all updates recently (win7/x64) apart from Windows Live Essentials.

In firefox (umm... 3.6.3), a single word search in the location bar, eg; "facebook", results in a bing page, not going to facebook.com, or showing google results like it used to.

Multi-word searches resolve with google.

I don't have any tool bars installed. Google is my default search engine. About:config keywordURL is set to google. "search helper extension" doesn't appear in add-ons, nor does zugo or bing bar. I've disabled all add-ons, restarted. Same result. I started in safe mode Same result.

I've removed bing from IE8, set google as default. There are no toolbars installed.

I've searched my programs list. Nothing mentioned appears, everything seems fine. I looked at recent updates, nothing related to "search". I've looked in program files/program files (x86) for Program Files\Microsoft\Search Enhancement Pack\ but no such folder exists. I searched regedit for "bing", few results, but nothing that seemed linked with FF.

Why is bing showing up? I don't want it, I didn't ask for it, and I can't get rid of it.

This happened

Every time Firefox opened

== not sure. Recently.

Toutes les réponses (17)

more options

@ above

Thanks so much, it fixed :D :D :D

more options

Solved it finally for me (after trying to deinstall windows updates and toolbars i didn't have). Thanks a lot!

more options

@Vaibhav

you should have say how to open registry edit, but any way it fix for me thank you

more options

Vaibhav, thank you from the bottom of my cold, back heart. Either the regedit or uninstalling that "security" update did the trick--I can't tell which, as I did them at the same time.

more options

Ethan and Vaibhav,

Thank you soooo much, I sent bing some serious hate mail. It pissed me off SO much when I would type, apple, facebook, or netflix and it would take me to bing search results.

I had tried searching the contents of every file on my whole computer and searched my entire registry for the word "bing." And obviously it didn't work. Thanks for figuring out this intensely annoying problem.


Thanks!

more options

Damn man, thank alot , the registry one fixed it, i've been searching for a fix for 2 hours, thanx alot people

more options

@Vaibhav: this is brilliant, thank you very much! @mozilla: this should be featured more prominently (adding it to this kb article would be a good idea)

more options

This fixed the problem for me.

Please make this solution more visible. Spread the word!

Thank you very much for the original poster of this solution.

more options

Thanks!

I have the same problem, but don't have mshome on any adapter. Perhaps my DNS was poisoned from when I did have mshome. Anyway, opening an admin console and running:

ipconfig /home

solved it for me.

This was a tough one...

Thanks, Asaf

more options

Thanks for the solution. Also once mshome.net is removed from connection-specific suffix list, reverting the settings to append primary and connection-specific dns suffixes does not bring it again.

more options

Thanks Ethan! Lots of suggestions on the Internets, but this one actually worked. And learned a bit of DNS as well :-) Was wondering why 2 or more words still worked as expected.

more options

I was wrong, reverting the setting will bring the mshome.net back.

more options

Can someone explain this for those of us who are not as tech savvy?  :)

more options

Hi, I had the same problem and the fix with mshome worked!

Thank you very much.

I would also like to point out that when I switched from Wifi connection to LAN, the problem disappeared. It's obvious as previously I ran ipconfig and truly didn't see the string at any other adapter than my wifi. However it's interesting that it happened just for wifi (same as Xander in this thread). Maybe this would help finding the root cause for someone who's more skilled than me ;-)

more options

Translate:

Start Menu > run: "regedit" > HKEY_LOCAL_MACHINE > System > CurrentControlSet > Services > TCPIP > Parameters and "empty the "mshome.net" value from the ICSDomain key"

"then disable and re-enable your adapter":

Start Menu > settings > control panel > network connections > icon of your connection ("disable and re-enable your adapter")

more options

i found another solution here (i wasn't smart enough to follow that last post):

http://muslimmedianetwork.com/mmn/?p=4162

don't know why it's at this site, but it works!

more options

Every tome I try to open your response I get a "page not found"

  1. 1
  2. 2