Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Firefox seems to be very unstable with Windows 7 !!!

  • 20 réponses
  • 124 ont ce problème
  • 2304 vues
  • Dernière réponse par the-edmeister

more options

here are all my firefox crashes ID :

bp-68f7dcc2-61a2-46a7-959a-355cb2100524	24/05/2010	11:25
bp-faef2b19-79c0-4750-9e7a-3eacd2100524	24/05/2010	10:12
bp-a477cc33-0f81-4347-80e2-f38712100524	24/05/2010	10:08
bp-90b1cdf9-3160-4f99-bc7c-0e33e2100524	24/05/2010	09:16
bp-0c4b6fa8-bb59-48d4-a4e2-a6fb42100523	24/05/2010	08:07
bp-7ed61b64-bea4-4916-a60b-4fd842100523	23/05/2010	15:57
bp-b7622382-869f-4f8c-a26c-5c71b2100523	23/05/2010	15:31
bp-2aa08694-121d-4849-a267-0a6f32100523	23/05/2010	13:39
bp-590fd5f6-e8a4-42c6-9e4d-8633f2100523	23/05/2010	11:13
bp-e36eeb3e-b8a1-4747-abd3-be4e02100523	23/05/2010	10:44
bp-3caf6abf-5719-42ac-8617-32e802100521	22/05/2010	07:43
bp-cc558867-df89-42cb-b641-c7fd42100521	22/05/2010	07:33
bp-f3147c4e-5532-4761-9b01-3ec172100521	21/05/2010	22:49
bp-985b737c-b98b-469b-b5c0-136b92100520	20/05/2010	22:16
bp-c8008384-a96e-42c2-ac9a-7c7bb2100520	20/05/2010	22:13
bp-daf622ab-0921-4de0-acf0-157ed2100520	20/05/2010	21:04
bp-cedee64f-faba-4d03-8e77-984902100520	20/05/2010	18:18
bp-29433db0-3fb7-4643-b4b4-7725d2100519	20/05/2010	05:44

it becomes very difficult to work with Firefox. I never had such problems with XP and I'm looking at the same web sites

thanks for your support

Modifié le par cor-el

Toutes les réponses (20)

more options

Hello Pascal.

You may be having a problem with some extension or plugin that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

more options

thanks for the answer how do you deactivate the add-ons ? what is an add-on ?

sorry for these basic questions !

more options

It's no problem. An add-on is a small bit of software that is "latched" (added on) to Firefox for added or tweaked functionality. Themes, extensions and plugins are all add-ons. You can manage them by going into Tools > Add-ons. To easily temporarily disable all add-ons, run Firefox in safe mode.

more options

Firefox is a pile of Garbage. I can't wait until firefox 4 so that I can have 4 times the trouble. Firefox is quickly becoming an extinct species do to it's five legs and six arms that don't work. What a joke. And no, I don't need any help because I am well aware it is not coming. All these stupid non-working fixes are a joke.

more options

Well I deactivated most of them and reactivated the ones necessary to see a web page correctly (flash, etc...) but it still happens

No choice to wait for another version of Firefox....

It looks like it becomes a gaz factory ! instead of implementing all the time new functions..the best would be to work and fix the current problems

It would be more efficient and would give a better image of your product

more options

@ Wow

I could be you anything that if I had physical access to your computer, I could get Firefox working in less than half an hour. Unfortunately I don't, so you'll have to rely on your own skill and all the help we can give you through the internet.

Your problem is probably very VERY simple to fix. The problem is nobody knows (not even you) what your problem is, so you need to diagnose it. Do this:

  1. run Firefox in safe-mode to disable all extensions, themes and plugins. If this fixes your issues, be them with RAM or CPU usage, then you know it's a problem with plugins, themes or extensions. Proceed to number 2. If safe-mode doesn't fix the issues, then read bellow, after this list;
  2. update all extensions, themes and plugins in your Firefox. If this doesn't solve the issues, proceed to the following number;
  3. disable all extensions, themes and plugins in your Firefox (not running safe-mode). Being certain that, as in safe-mode, the problems you're having have gone away, enable one plugin at a time. You should be certain that you WANT that plugin to be enabled, so keep your overall number of plugins as low as possible. When you encounter the problems, you know you've found a problematic plugin, so disable it for good. Keep enabling all plugins (except problematic ones) until you've gone through them all.
  4. enable one extension at a time. Again, be certain that you WANT that extension to be enabled, so keep your overall number of extensions as low as possible. Also, try the theme you want to have installed so see if that is what's causing the problem. When you encounter the problems, you know you've found a problematic extension/theme, so disable it for good. Keep enabling all your extensions (except problematic ones) until you've gone through them all;
  5. you're done! You've fixed your problems with problematic add-ons. If you want to keep using those problematic add-ons, please contant their author for support.

Ok, if disabling all extensions and plugins through safe-mode didn't work to bring Firefox's CPU and RAM usage to good levels, then you have different issue. The most likely scenario is that you have a third party software running on your computer that is messing with Firefox. Do as follows:

  1. try reinstalling Firefox. No data will be lost. You can get the latest version for free at If that doesn't fix the problem, proceed;
  2. do a virus/malware check on your computer. If this doesn't fix it, proceed;
  3. disable all software running in the background that you don't want to have running in the background (in windows, this is done by pressing WINDOWS+R in your keyboard, typing "msconfig" (without the commas) and pressing enter. Now, under the "Startup" tab, you can uncheck the software you don't want, and reboot your system for changes to take effect. If you're unsure of what software you want running, ask someone with more experience). If this doesn't fix your issues with Firefox, proceed;
  4. check your firewall/antivirus/security suite for enabled functions/features that you don't want and/or may be conflicting with Firefox. You'll find that these features are most likely tied to Internet Security features, such as link scanners or URL checkers and the like. If you're not sure they are conflicting with Firefox, simply try to disable them to see whether or not that's true. As long as you don't browse the web with your antivirus completely off and your firewall completely turned off, there should be no problems. If this doesn't solve the issues, proceed to the following number;
  5. check your operating system security options, mainly advanced options that are not configured by default. While it's very unlikely that this may be the cause of the problem (after all, it's the last item on the list), it's remotely possible. If this doesn't work, proceed to the following point;
  6. update your modem/router software. There have been some reports that some modem/router software may cause Firefox and other browsers to loose performance and/or stability. If updating doesn't fix your issue, try other versions of the software, if possible. If you need support with this, contact your modem/router manufacturer. If this doesn't help, proceed;
  7. clean up your OS registry, using appropriate software. Make sure you've followed my instructions correctly, but if this all doesn't work, create a new Firefox profile (this can be temporary, of course) and see if the issues persist. Report here the results, so we can't help you further.
more options

@ Pascal

That's not really what I asked you to do (see Wow? people sometimes don't follow our instructions correctly...). Run Firefox in safe mode to easily and temporarily disable all add-ons and see if the problems persist.

In any case, you can just follow the instructions I posted above if you like, they apply to most problems of this sort.

And I remind you: this is not normal Firefox behavior. It's a glitch triggered by some external factor (add-on, firewall, or something else). Mozilla has no control over software they don't develop, so it's not their bug to fix. Please try to work with me to fix this problem, ok?

more options

I don't see how disabling (all) functionality is a step forward for anybody. The fact is, Firefox has been getting less and less stable as its Version 3 development drives forward, independent of OS as far as I can tell (between XP at work and Vista at home). I'm not sure whether this is due to Add-On authors or the addition of internal functionality, but it is clearly falling out of the control of Mozilla (or anybody else).

Some of the Add-Ons are fantastic, so I would love to see things slow down in terms of innovation and forward in terms of stability.

more options

ok I deactivated all plugins and reactivated them one by one

It looks like SHOCKWAVE FLASH is creating all these problems !

but I cannot deactivate it as most of the web pages nowadays use flash technology !

more options

@ Patrick

If you don't let me help, I can't really help you. If you follow my instructions though, I can help you. Disabling all add-ons is not a solution, but a means of diagnosing the problem. Since we don't know what the problem is, only its symptoms, we need to diagnose it first, so we can then proceed to fixing it. It's very much like healing a sick person.

@ Pascal

Hello again. I'm glad you found the source of the problem. And, although I do feel your pain on this, we can't, unfortunately, provide you any support on Flash, since Mozilla isn't the one who develop it. You'll need to contact Adobe. As I said before, if you have a problem with a particular add-on, you'll need to contact its author for support. Unless the add-on is developed by Mozilla (such as Firefox Sync, Account Manager and a few others), we can't help you troubleshooting problems with it, since we lack both the responsibility and the competence to do so.

more options

Firefox in safe mode still crashes, in fact it is highly unstable no matter what I do. IE 8 x64 is more stable but still manages to crash every few hours, it is still a better option for now. It is not a hardware issue.

Relevant specs: Win 7 Pro x64 and as of June 30 2010 I am running the latest version of FF.

more options

Brent, please be aware that safe mode should only possibly make any difference at all if you, when you start safe mode, tick the box that says Disable all add-ons.

I'm going to assume you did that and still encountered problems in safe mode. If you didn't tick the Disable all add-ons box, please do and see if you still have those problems in safe mode. If you do, please try creating a new (temporary) Firefox profile: managing profiles. See if the new profile has the same issues. Please report back the results.

more options

Thank you for the reply Morbus, I appreciate it. This now seems irrelevant since FF is running perfectly again (see below) but when FF crashed and it prompted me for safe mode I did instruct it to disable all add-ons. It still seemed to be crashing since when I instructed it to launch it would just go back and tell me to run it in safe-mode again. Don't know what that was about but a restart allowed me to run FF normally again.

The problem & symptoms: I've been running FF for several hours now crash-free. I spoke to a friend of mine who is also running Win 7 Pro x64 and he reported no problems with Firefox with the add-ons enabled. My solution to the problem is connected to a bad Creative audio driver. It seems some of their drivers are unstable with Windows 7 and as a result my flash plugin would begin to crash and I'd get an error message instead of any flash streaming videos, usually a couple of seconds later FF would crash. Even disabling the add-on didn't help too much. Other components such as windows explorer would stop responding.

The solution: I Uninstalled all Creative products in safe mode, booted back in and installed a Windows 7-friendly Creative sound driver that was released June 16 2010, fairly recently. Since this change I have had absolutely no problems for the several hours that my PC has been running, FYI FF crashes used to happen after about 2 to 15 minutes of browsing so I am confident the issue has been corrected.

Moral of the story: Check all of your drivers running under Windows 7 and make certain they are not messing up an add-on or Windows feature. My online research indicates that Creative has a lot of older incompatible drivers that will install inside of Windows 7 and make its applications highly unstable. It just happened to be Creative for me but it may be a different driver for you, if you are having software difficulties.

I thought I'd post my lengthy scenario since this was one of the first threads that popped up for me when I 'googled' FF crashes under Windows 7. Hope this helps someone else!

more options

Yes, hardware drivers (just some of them, of course) are known to cause problems with Firefox (and many other applications). I'm glad you fixed your problem.

more options

Hi Morbus, I can appreciate the patience you exhibited in assisting on the issue above...

I seem to have a similar issue -- I have a brand-new Dell E6510, and one of the first downloads was to install Firefox. After installing a few more apps (AVG antivirus, MS Office 2010 & Ad-Aware), Firefox became extremely unstable, freezing most of the time.

After reading the post above, I killed the Firefox process & restarted in Safe Mode -- and it seemed to work OK, so I exited & restarted it in normal mode to see what Add-Ons were running, and they were:

- AVG Safe Search
- Google Toolbar
- Trend Micro NSC Firefox Extension

I had installed the first two, and the 3rd was a factory install.

Since I wasn't using Trend Micro, I disabled it first, and bingo! the instability has disappeared (at least for now)...

Is there any documentation on any adverse interaction of these three addons?

Also, since this is a 64-bit Windows 7 PC, is there a 64-bit version of FF I shiould be running instead of teh standard version?

Thanks, JTG

more options

I have been a devout user of FF for some time (like years).. It has become completely unusable for me and my customers are complaining.. this crash to desktop thing is for the birds and I gotta agree... disabling everything is going backwards and I am not the beta/alpha tester for this software..

I can recreate the issue in short order but that is besides the point.. I find it highly unlikely that the guys doing the work are unaware of the issue..

At least the OP got a log file.. mine just flat dies and sends notice to Mozilla..  (so they already have the crash reports)..   

FF used to be a lightweight, fast and fairly robust package.. As of the last version or so, it has become slow and bloated (which is why I quit using E).. I find myself using C now and hope they do not go down the same road...

more options

sigh, seems reply isn't reply at all. its "also post something at the bottom" *My comments are at morbus only*

You realize that "I could be you anything that if I had physical access to your computer" is not a sentence. Its not even an incorrect sentence, its just words. though i keep reading...No one knows your problem, not even you! you have to diagnose it! well no shit sherlock. Thats why he is here!! to list the symptoms and enlist a literate and knowledgeable person for help!

I see you have said, in response to others, you didn't follow my instructions. maybe if you spoke in proper sentences and actually gave advice specific to the issue you'd get a better response from people.

Modifié le par Booga

more options

FireFox would probably be a much better product if it stop releasing new versions every hour. Its management lacks consideration for corporate developers who needs to test huge web apps on A VERSION; and wildly making new FireFox versions every moment makes that virtual unpractical.

more options

There is an ESR (Extended Support Release) for "corporate users".