Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Mozilla Firefoz crashes multiple times after waking laptop from sleep

  • 11 réponses
  • 0 a ce problème
  • 1 vue
  • Dernière réponse par Candlejack

more options

The behavior began with fifteen to twenty crash messages appearing. After which the browser would stop responding and be unable to reach out to the internet.

Network connectivity was confirmed as I was able to access my VPN and corporate teams.

I submitted as many crash reports as I could. Eventually the crash reporter ceased to function. The message is:

Firefox had a problem and crashed. Unfortunately, the crash reporter is unable to submit a report for this crash.

Details: expected value at line 1 column 1

Only a full reboot of the machine restored functionality but only temporarily. It returns after being put into sleep mode.

Running firefox in safe mode does not restore functionality. The behavior persists.

I am fully up to date according to firefox.

I am running a Lenovo Thinkpad Windows 11.

The behavior began with fifteen to twenty crash messages appearing. After which the browser would stop responding and be unable to reach out to the internet. Network connectivity was confirmed as I was able to access my VPN and corporate teams. I submitted as many crash reports as I could. Eventually the crash reporter ceased to function. The message is: Firefox had a problem and crashed. Unfortunately, the crash reporter is unable to submit a report for this crash. Details: expected value at line 1 column 1 Only a full reboot of the machine restored functionality but only temporarily. It returns after being put into sleep mode. Running firefox in safe mode does not restore functionality. The behavior persists. I am fully up to date according to firefox. I am running a Lenovo Thinkpad Windows 11.

Solution choisie

Update: The issue has been resolved.

The solution: The issue revolved around DNS resolution, which I suspected because the browser would break but all other network functionality would not. Other browsers would work. Which is a problem because I don't like using other browsers.

When I connected to the VPN everything works fine. When I disconnect from the VPN dns resolution in the browser breaks.

The VPN in question: Palo Alto global protect.

We do have our own internal DNS we use to navigate our intranet.

The feature that this breaks is dns over https. The solution is to disable this feature and force it to use the system DNS settings. For whatever reason it's not able to query DNS when this is turned on after disconnecting from the VPN.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (11)

more options

Addendum:

At first firefox was generating pr_connect_reset_error but now it just times out or stops responding altogether.

Cela vous a-t-il été utile ?

more options

Can you go to this link and verify that your drivers are current.

https://pcsupport.lenovo.com/us/en/selectproduct?linkto=downloads&linkTrack=footer:Support_Downloads

Then go to this Intel site and also check.

https://www.intel.com/content/www/us/en/support/detect.html

For the pr_connect_reset_error, what security software are you running?

Also, what version of Firefox?

Modifié le par jonzn4SUSE

Cela vous a-t-il été utile ?

more options

jonzn4SUSE said

Can you go to this link and verify that your drivers are current. https://pcsupport.lenovo.com/us/en/selectproduct?linkto=downloads&linkTrack=footer:Support_Downloads Then go to this Intel site and also check. https://www.intel.com/content/www/us/en/support/detect.html For the pr_connect_reset_error, what security software are you running? Also, what version of Firefox?

Firefox 126.0.1

I do have some drivers out of date, but they pertain to Bluetooth, wifi, and a graphics driver for Intel, and a BIOS update for USB-C power for Lenovo. Everything else is up to date.

My security software is a Trellix ePO agent. This is a requirement from my company, along with whatever extensions they are pushing out to the endpoints.

Modifié le par Candlejack

Cela vous a-t-il été utile ?

more options

jonzn4SUSE said

Can you go to this link and verify that your drivers are current. https://pcsupport.lenovo.com/us/en/selectproduct?linkto=downloads&linkTrack=footer:Support_Downloads Then go to this Intel site and also check. https://www.intel.com/content/www/us/en/support/detect.html For the pr_connect_reset_error, what security software are you running? Also, what version of Firefox?

Firefox version 126.0.1

For intel the only drivers out of date are a bluetooth driver, a wifi driver, and a graphics driver.

For Lenovo the only thing they recommended was a BIOS driver for power over USB-C, which I will probably update when Lenovo pushes their next firmware update. I am pretty good when it comes to updating for Lenovo.

The only security software I am running is a Trellix ePO agent, along with whatever extensions are installed on the corporate ePO.

Cela vous a-t-il été utile ?

more options

The security software is causing the pr_connect_reset_error.

Cela vous a-t-il été utile ?

more options

jonzn4SUSE said

The security software is causing the pr_connect_reset_error.

Why is it that the Trellix Agent is only causing the problem infrequently? Why has it occurred now (I have had this agent and this browser for two years now) and why does it go away on reboot but come back after putting the computer to sleep, but also only infrequently? (I put the computer to sleep last night and did not have to do a reboot this morning)

This cannot be at the network level as Chrome and Edge do not display this behavior.

Modifié le par Candlejack

Cela vous a-t-il été utile ?

more options

Could it be my VPN? I have two VPNs right now as I am in the middle of a data migration. The issue suddenly popped up after not presenting itself for most of the day.

I was bouncing between both VPNs when it suddenly occurred.

Cela vous a-t-il été utile ?

more options

When using just the browser without the VPN, does Firefox work?

Cela vous a-t-il été utile ?

more options

jonzn4SUSE said

When using just the browser without the VPN, does Firefox work?

I don't know for certain yet. The behavior is currently not present and the browser is working fine despite being on either VPN. I wasn't able to test this past week due to various events, but the last time it hopped up was when I was hopping between VPNs.

I am going to continue to test now that we have moved on to the new work week.

Modifié le par Candlejack

Cela vous a-t-il été utile ?

more options

I can confirm that it is switching VPNs that causes the behavior.

Firefox was fine for the past few days since my last post. But today I had reason to swap from the new VPN (Palo alto) to the old one (fortigate) and as soon as I hopped over firefox began to become unresponsive. It was like a switch got flipped.

If I am on the fortigate and then swap to Palo alto global protect, it's fine. If I go in the reverse direction it becomes very very slow verging on unresponsive.

Modifié le par Candlejack

Cela vous a-t-il été utile ?

more options

Solution choisie

Update: The issue has been resolved.

The solution: The issue revolved around DNS resolution, which I suspected because the browser would break but all other network functionality would not. Other browsers would work. Which is a problem because I don't like using other browsers.

When I connected to the VPN everything works fine. When I disconnect from the VPN dns resolution in the browser breaks.

The VPN in question: Palo Alto global protect.

We do have our own internal DNS we use to navigate our intranet.

The feature that this breaks is dns over https. The solution is to disable this feature and force it to use the system DNS settings. For whatever reason it's not able to query DNS when this is turned on after disconnecting from the VPN.

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.