Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Github is not rendering correctly

  • 11 réponses
  • 1 a ce problème
  • 22 vues
  • Dernière réponse par Guidodi

more options

When I open github it loads incorrectly as shown in the picture, after I press F5 to reload the site load fine. I have tried deleting cookies and I am using any ad-blocker. Any help? Thanks.

When I open github it loads incorrectly as shown in the picture, after I press F5 to reload the site load fine. I have tried deleting cookies and I am using any ad-blocker. Any help? Thanks.
Captures d’écran jointes

Toutes les réponses (11)

more options

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy".

Does it still happen in Troubleshoot Mode?

Cela vous a-t-il été utile ?

more options

I have done what you said, it seems to be working fine for the moment. Does changing those option make visiting other sites less secure?

Another thing is that this doesnt always happen. Sometimes I visit github and it loads just fine the first time, others I have to reload with F5, but doing this always fix it. I would say around 50-50 if it load fine or not.

Modifié le par Guidodi

Cela vous a-t-il été utile ?

more options

zeroknight said

Try changing DNS over HTTPS (DoH) to "Off" or "Max Protection" and in Connection Settings change "Use system proxy settings" to "No proxy". Does it still happen in Troubleshoot Mode?

After some tests the problem is still there, like I said before, sometimes it happens sometimes it doesnt. I also tried troubleshoot mode, and the same keep happening but less often, I opened like 20 github pages and it only happened once.

Any other ideas?

Cela vous a-t-il été utile ?

more options

You might be blocking CSS files.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin), always make sure such extensions do not block content.

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Cela vous a-t-il été utile ?

more options

I do have Adblock Plus and uBlock Origin but they are both disabled in github. I used the web console and like you said there seems to be a bunch of error with css files. I will upload a screen. How can I find out what is causing those errors? I have been using firefox for years and this only started happening around 2 months ago. I havent installed any new extensions or changed any settings in that time.

Modifié le par Guidodi

Cela vous a-t-il été utile ?

more options

Guidodi said

but they are both disabled in github.

This does not properly disable extensions, they are still active and can interfere. You need to disable them from the addons manager (about:addons) to completely rule them out.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Cela vous a-t-il été utile ?

more options

@zeroknight, thanks for "DNS over HTTPS" tip, it helped!

Although, I've had slightly different rendering issue: https://github.com/orgs/community/discussions/118680

I would never think, that DNS setting could break the rendering =)

Cela vous a-t-il été utile ?

more options

UPD: I was wrong, what helped in my case - "Expand file tree". When it is collapsed - there are rendering issues with text selection.

Cela vous a-t-il été utile ?

more options

zeroknight said

Guidodi said

but they are both disabled in github.

This does not properly disable extensions, they are still active and can interfere. You need to disable them from the addons manager (about:addons) to completely rule them out.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

But I tried troubleshoot mode which should disable extensions and it was still happening. I uninstalled both ad blockes and I have no others extension and the problem is still there.

I installed developer edition fresh install, new profile and it also happens there. I will upload picture. Also tried shutting down my anti virus (Kaspersky) but didnt help.

Well I am an idiot, it is not a firefox bug. I never use it so I didnt even bother to try but I tested using edge as a browser and the same thing happens there. Funny thing is that it only happens on github, I dont have problems with any other site.

Modifié le par Guidodi

Cela vous a-t-il été utile ?

more options

Cela vous a-t-il été utile ?

more options

cor-el said

Boot the computer into Windows Safe Mode with network support to see if that has effect.

Problem is still there in safe mode using both firefox and edge.

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.