Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Firefox on Linux- Forward mouse button works, but back button does not

  • 5 réponses
  • 0 a ce problème
  • 40 vues
  • Dernière réponse par jonzn4SUSE

more options

I'm running firefox 124.0.2 on Linux Mint and am having the most bizarre issue. I've got a logitech M560 mouse, and when I press the mouse button for Forward it functions normally. However when I press the mouse button for Back, Firefox ignores it.

I've already confirmed that the OS is registering the button click as 'Back' using Input-Remapper, and the extra mouse buttons are enabled in the Firefox configuration. I've also used the mouse on another PC with no issues so this one is kind of boggling the mind.

I'm running firefox 124.0.2 on Linux Mint and am having the most bizarre issue. I've got a logitech M560 mouse, and when I press the mouse button for Forward it functions normally. However when I press the mouse button for Back, Firefox ignores it. I've already confirmed that the OS is registering the button click as 'Back' using Input-Remapper, and the extra mouse buttons are enabled in the Firefox configuration. I've also used the mouse on another PC with no issues so this one is kind of boggling the mind.

Toutes les réponses (5)

more options

I have a Gameball and never had any issues. What Desktop? X11 or Wayland?

I would suggest you try a live usb stick of Mint or another Distro and see if you have the same issues.

Try downloading Firefox from Mozilla. Download, unzip, and run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release



Operating System: openSUSE Leap 15.6 KDE Plasma Version: 5.27.11 KDE Frameworks Version: 5.115.0 Qt Version: 5.15.12 Kernel Version: 6.4.0-150600.10-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 PRO 6850HS with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Manufacturer: HP Product Name: HP EliteBook 865 16 inch G9 Notebook PC

Modifié le par jonzn4SUSE

Cela vous a-t-il été utile ?

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Cela vous a-t-il été utile ?

more options

See also these prefs in about:config.

  • mousebutton.4th.enabled true
  • mousebutton.5th.enabled true

Cela vous a-t-il été utile ?

more options

I tried starting in troubleshooting mode, and that didn't change anything. And I was able to confirm that both buttons were enabled in the configuration.

I tried running a freshly downloaded firefox-bin and ran into the same issue.

Curiously, I tried a different wireless mouse I had sitting around, and it's back button worked perfectly fine, but that mouse has an atrocious scroll wheel so I can't stand using it. So it's an extremely specific issue to this mouse and just its back button, as the forward button works normally.

I've used input remapper to change the back button to use the Alt + Left Arrow hotkey to get the functionality for now, but that will cause issues if I want to use that anywhere else where it would normally be detected as back.

Cela vous a-t-il été utile ?

more options

Doesn't sound like a browser issue. Get a live usb stick of the same OS or my go to openSUSE and test.

What Desktop? X11 or Wayland?

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.