Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Firefox suggest ignoring settings

  • 5 réponses
  • 1 a ce problème
  • 22 vues
  • Dernière réponse par zeroknight

more options

I have search separated from the url bar, and I have Firefox Suggest configured to only use history for tab completion. I've noticed a couple problems.

  • Search is being prioritized over options in my history. I have the separate search box, if I wanted to search I would use it. If I type a single character I want the most common result from my history to be the result of hitting tab.
  • I've noticed recently that I'm getting sponsored results even though I have them disabled. It's somewhat inconsistent, and I've only noticed it in one of my profiles. Specifically I am used to "w <tab>" taking me to weather.gov but I'm getting sponsored results for AccuWeather. I clicked the "feedback -> not interested" button but this is concerning that Firefox is ignoring preferences and there's a pattern of sending data to Google and AccuWeather despite me configuring the browser not to.
I have search separated from the url bar, and I have Firefox Suggest configured to only use history for tab completion. I've noticed a couple problems. * Search is being prioritized over options in my history. I have the separate search box, if I wanted to search I would use it. If I type a single character I want the most common result from my history to be the result of hitting tab. * I've noticed recently that I'm getting sponsored results even though I have them disabled. It's somewhat inconsistent, and I've only noticed it in one of my profiles. Specifically I am used to "w <tab>" taking me to weather.gov but I'm getting sponsored results for AccuWeather. I clicked the "feedback -> not interested" button but this is concerning that Firefox is ignoring preferences and there's a pattern of sending data to Google and AccuWeather despite me configuring the browser not to.

Toutes les réponses (5)

more options

Hi Luke, adding back the classic short search bar doesn't change how the address bar works, it just gives you more options. With that in mind, could you check these settings:

(1) Dynamic search engine suggestions (magnifying glass icon)

These should be easy to manage:

Settings page, Search panel

Under "Search Suggestions", uncheck the box for "Show search suggestions in address bar results" to turn off dynamic search suggestions from your default search site.

Note: if you have already turned off ALL search suggestions for both bars, then this box is grayed out.

(2) External non-search results

Are these the ones with the little information icon on the right side? As you probably noticed, there are multiple categories:

Settings page, Privacy & Security panel

Under "Address Bar – Firefox Suggest", you can individually manage:

  • Suggestions from the web
  • Suggestions from sponsors
  • Improve the Firefox Suggest experience [More privacy implications]

Did you experiment with turning those on and off individually?

more options

I've screenshotted how I configured it. I am sure there is a bug where sponsored results are being showed when they are disabled, but I can't reproduce it consistently because I've only experienced it for a single search string "wea" and only in one browser, it seems likely there is an A/B test or something bypasssing my configuration.

The second screenshot is more a complaint, that the characters I've entered match something in my history but Firefox is suggesting I search google instead. This is a change in behavior from how it used to be, which I just have ignored until recently when I noticed sponsored results being shown despite them being configured to be off.

more options

If you never want to search from the address bar without expressly starting your text with a question mark, there is a setting for that. Maybe it will bring you closer to what you had before, but typically the default action when search is disabled is to navigate to the top level of the site matching what you entered in the address bar. Maybe check both of these:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste keyword.enabled and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

(4) In the search box in the page, type or paste browser.urlbar.autoFill and pause while the list is filtered

(5) If the preference is bolded and has a value of false, double-click it (or click the Toggle button or Reset button at the right end of the row) to restore the default value of true

Does that restore the expected functioning?

more options

That helps, thanks. I'm still not sure how to debug the issue with sponsored results showing up. Previously I double-checked my settings, restarted the browser and then the ad disappeared. But then it showed up again later.

more options

See if you are enrolled in any related studies by going to about:studies in the address bar, they can override your settings so you may need to remove ones that are interfering.

Go to about:config, search for browser.urlbar.suggest and try changing unwanted suggestions to false.