Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Latest version 117.0.1 (64-bit) https://webmail1.earthlink.net/login won't populate email address

  • 10 réponses
  • 1 a ce problème
  • 22 vues
  • Dernière réponse par zeroknight

more options

Since the latest version of firefox installed when I go to this site for my mail Firefox won't auto fill the email address. It won't display any of the users When you tab to the password field, the list appears but only populates the password field.

Since the latest version of firefox installed when I go to this site for my mail Firefox won't auto fill the email address. It won't display any of the users When you tab to the password field, the list appears but only populates the password field.

Toutes les réponses (10)

more options

That email field in an unusual input field that isn't supported by the Firefox Password Manager. Firefox seems to have a problem autocomplete="new-password".

<input autocomplete="new-password" type="email" name="email" class="ant-input" value="">

See a thread like this one for a possible JavaScript bookmarklet to remove this autocomplete attribute :

more options

Thank you for this information, but I do see that it's from 11/9/21.

I have use Firefox since it was released, and when the save password feature was introduced.

However until the "latest update" I have NEVER had this problem in the past. All previous versions s always been able to display and list all saved passwords on this webpage.

more options

See:

(edited to fix the bug ID)

Modifié le par cor-el

more options

This still doesn't solve the problem. Until installing the 117.0.1 update I have been able to login to this webpage https://webmail1.earthlink.net/login And have both the email and the password fields populate without a problem for Years!!!

So something has changed. I need a reply that will give me the steps needed to resolve this problem.

more options

The website may have changed its code recently and now has added autocomplete="new-password" to its username input field. Some websites do not want browsers to save their username and password. I checked the form in 115.2.1esr and there also it doesn't recognize the email field as a username field (no "Use Saved Login" in the context menu).

more options

I have been in touch with earthlink support and spent several hours with them. They had me delete and reenter the email and password and it still doesn't work. It works with Google Chrome and Edge. They say it should work and to contact FIrefox support. So here I am!

more options

You can send Earthlink to this bug report, so they can read why it doesn't work with Firefox.

more options

Well Earthlink has no interest in solving this problem. I pass the information that you provided. I did however find something that I think may be in the mix. I am now at 119.0 and have the same issue. FYI

I have used Chrome CSS for changing the spacing in the pull down menus. And have changed toolkit.legacyUserProfileCustomizations.stylesheets=true

Anyway my wife's laptop is also at the same version of Firefox as mine but actually works on the Earthlink home page without any problems.

Having discovered that I ran Firefox refresh on my laptop, and the email populated! The only difference between the two installs is that I have a Chrome subdir and a userchrome.css

userchrome.css is listed below

@namespace menupopup > menuitem, menupopup > menu {padding-top: 2px !important; padding-bottom: 2px !important;}

  • |*:root {--arrowpanel-menuitem-padding: 2px 8px !important;}

/* Show active colors on main menu bar */

  1. TabsToolbar,
  2. navigator-toolbox,
  3. tabs-newtab-button,
  4. titlebar toolbarbutton:not(:hover):not(:active),
  5. scrollbutton-up:not(:hover):not(:active),
  6. scrollbutton-down:not(:hover):not(:active),

.titlebar-color {

   background: AccentColor !important;
   color: AccentColorText;
   fill: AccentColorText !important;

}

  1. TabsToolbar:-moz-window-inactive,
  2. navigator-toolbox:-moz-window-inactive,
  3. tabs-newtab-button:-moz-window-inactive,
  4. titlebar toolbarbutton:not(:hover):not(:active):-moz-window-inactive,
  5. scrollbutton-up:not(:hover):not(:active):-moz-window-inactive,
  6. scrollbutton-down:not(:hover):not(:active):-moz-window-inactive,

.titlebar-color {

   background: unset !important;
   color: unset;
   fill: unset !important;
   transition: none !important;

}

Once I add the chrome dir and the userchrome.css file the login page doesn't work any more.

Any thoughts?

more options

I'm not seeing any rule that would affect auto-fill. Since Firefox doesn't recognize the username field as part of a login form, only saved form data can fill this username. Filling the password from a saved login shouldn't be a problem.

more options

Make sure you have not disabled "Remember search and form history".