Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

firefox wont start / run command firefox.exe -p wont run

  • 19 réponses
  • 1 a ce problème
  • 1 vue
  • Dernière réponse par jonzn4SUSE

more options

firefox is my goto browser-tons of bookmarks etc-always kept UpToDate along with my dell MS10 laptop - today laptop boots up fine, outlook and MS edge work fine, but firefox will not start up, even in Administrator mode - searched for help - tried the run command firefox.exe -p, and also tried to create new profile ( as suggested ) that didnt work either- i would hate to uninstall and reinstall ! any help besides that ?

firefox is my goto browser-tons of bookmarks etc-always kept UpToDate along with my dell MS10 laptop - today laptop boots up fine, outlook and MS edge work fine, but firefox will not start up, even in Administrator mode - searched for help - tried the run command firefox.exe -p, and also tried to create new profile ( as suggested ) that didnt work either- i would hate to uninstall and reinstall ! any help besides that ?

Toutes les réponses (19)

more options

If you click the Firefox icon but no Firefox window opens and no error message is shown, a simple first step is to restart your computer and then try again. If Firefox still does not start, maybe something here will help: Firefox won't start - find solutions (under No error message) Troubleshoot and diagnose Firefox problems (try numbered steps and also Other solutions)

Modifié le par AliceWyman

more options

You mentioned Firefox will not start up in Administrator mode. That can actually cause the problem, according to https://support.mozilla.org/en-US/questions/1280478#answer-1292602 How to get Firefox to start.

more options

rebooted- didnt use Admin mode created new profile tried to "run" with new profile nothing seems to work still cant get even run command firefox.exe-p to run anything else ? thanks! Mike

more options

Did you recently uninstall an application that was using Visual C+ runtime components?

You can check for issues caused by a corrupted or incomplete Visual C++ installation that is missing runtime components (Redistributable Packages) required by Firefox, especially VCRUNTIME140_1.dll.

See "Visual Studio 2015, 2017, 2019, and 2022":

You may also have to install the Visual Studio 2013 Redistributable Package. You need to reboot the computer.

more options

cor-el said

<snip> You can check for issues caused by a corrupted or incomplete Visual C++ installation that is missing runtime components (Redistributable Packages) required by Firefox, especially VCRUNTIME140_1.dll. <snip>

I was wondering if that might be the problem. The Troubleshoot and diagnose Firefox problems article Other solutions section has a Check for issues caused by corrupt or incomplete Visual C++ installation paragraph I added a little while ago.

Modifié le par AliceWyman

more options

i did this: https://aka.ms/vs/17/release/vc_redist.x64.exe

restarted laptop, but still no firefox load

still appreciate any help - i want to use firefox as default browser thanksmike

more options

What security software are you running? Are you running Win 10 Pro? If so, do you have Windows Sandbox setup? You should have it setup for testing issue like this. https://www.howtogeek.com/399290/how-to-use-windows-10s-new-sandbox-to-safely-test-apps/ Can you watch task manager and see if the process even loads? Also, try downloading a different version (Beta, Dev, or Nightly) and install in a different directory to see what happens. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Modifié le par jonzn4SUSE

more options

i use IPVanish for VPN i use PCMatic for alltime virus check i use CCleaner Pro to remove trackers, clean junk space, update registry when needed, etc

my build: Edition Windows 10 Pro Version 22H2 Installed on ‎7/‎18/‎2020 OS build 19045.2364 Experience Windows Feature Experience Pack 120.2212.4190.0

looked at Task Manager "Processes" as i tried to load firefox, nothing seen

so, i did your request Also, try downloading a different version (Beta, Dev, or Nightly) and install in a different directory to see what happens. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

and installed into mozilla/firefox2 directory, An AND IT WORKED

how do i now "sync" to get all my extensions/apps/bookmarks from previous install?

or, does that tell you something about my current firefox that i can fix ? Thanks Mike

more options

Did you ever disable all those tools, reboot, and see if your Firefox works?

more options

and now i went into task manager and "ended" all those tools, and still no original firefox

do you all have a "firefox diagnositc" program that will show what my problem is ? Thanks Mike

more options

No, you need to disable those tools, reboot, and try again.

more options

ok-went into each program and disabled startup rebooted laptop still no firefox

i mean when i execute, it doesnt do anything mike

more options

Did you ever use sync?

more options

Since the new browser works, maybe cor-el can chime in on what files to move to the new browser.

more options

yes i do that with my iphone ( or at least i see that on my iphone...

i actually have a "json" backup, but a year old, and i imported that into my "firefox2" - which works what i really wanted was all those "extensions"/"addons" that i had is there a way to restore those ?

if not, is there a way to "save/backup" all bookmarks/extensions/options/etc so if this happens again

thanks mike

more options

wow, i just digned into "sync" and all my extensions/addons came back into my firefox2 i guess "problem solved" and i will use my firefox 2 from now on thansk mike

more options

This is why it's a good idea to run more than 1 version of Firefox, so that your data is not just in 1 place. see screenshot Since your data is now in Firefox 2, you can try to reinstall Firefox 1 and see if it helps. You can also just mark this issue resolved if your done.  ;-)

more options

Just checking in to see how's it going since this issue is still open?