Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Color PDFs viewing as black and white – This is a brand new problem!

  • 28 réponses
  • 5 ont ce problème
  • 119 vues
  • Dernière réponse par cor-el

more options

I noticed today that all my color PDFs are viewing as black and white. For years they were fine, presenting as color. This is a serious problem, as I am a graphic designer and have many PDFs on my portfolio. I am also seeing the same problem with PDFs linked to my clients' sites.

Images on PDFs are still in color. It's the flat color graphics created in InDesign exported to PDF. Oddly enough, gradients (originally created in InDesign as well) are still presenting as color, but only the gradients.

I do not have this problem in Safari, nor in other browsers, but Firefox has been my go-to browser for years. I never had a problem until I noticed today. Firefox updated two days ago. I'm on a Mac and I now have Firefox version 102.01, as it updates automatically.

Thank you for attending to this issue.

I noticed today that all my color PDFs are viewing as black and white. For years they were fine, presenting as color. This is a serious problem, as I am a graphic designer and have many PDFs on my portfolio. I am also seeing the same problem with PDFs linked to my clients' sites. Images on PDFs are still in color. It's the flat color graphics created in InDesign exported to PDF. Oddly enough, gradients (originally created in InDesign as well) are still presenting as color, but only the gradients. I do not have this problem in Safari, nor in other browsers, but Firefox has been my go-to browser for years. I never had a problem until I noticed today. Firefox updated two days ago. I'm on a Mac and I now have Firefox version 102.01, as it updates automatically. Thank you for attending to this issue.

Toutes les réponses (8)

more options

@cor-el did you mean to rename prefs.js under the profile root directory (/Users/...../Library/Application Support/Firefox/Profiles/.....default-release-3/prefs.js)? I tried that, but it has no effect other than automatically generating a new prefs.js after I restart Firefox.

Cela vous a-t-il été utile ?

more options

The problem is still there in 103.

The problem is not the PDFs. They render perfectly fine in other browsers. It is with the latest two versions of Firefox (at least).

Cela vous a-t-il été utile ?

more options

I just found a solution that works for me. The issue is from this line in my prefs.js:

user_pref("browser.display.background_color", "#feffff");

Once I remove that line and restart Firefox, I can see colors in pdf files again!

Cela vous a-t-il été utile ?

more options

he.jia.phy said

I just found a solution that works for me. The issue is from this line in my prefs.js: user_pref("browser.display.background_color", "#feffff"); Once I remove that line and restart Firefox, I can see colors in pdf files again!

Okay, yes, if you turn off "System Colors" then having that very slightly off-white background color causes this problem. It's hard to image where that came from, and of course if you checked the Colors dialog, you wouldn't be able to tell at a glance that it was customized:

Very odd.

Cela vous a-t-il été utile ?

more options

There is a fix for this problem in Firefox 104. Until then, enabling "Use system colors" or using a plain white background is the workaround.

Cela vous a-t-il été utile ?

more options

For reference:

  • 1778068 - PDF Viewer should not set the background of PDF documents to browser.display.background_color

(please do not comment in bug reports
https://https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Cela vous a-t-il été utile ?

more options

jscher2000 – Thanks. I will wait for Firefox 104. It's not a problem for me, since I know my PDFs are perfectly fine... It's a problem when people I don't know are viewing my portfolio. This is a Firefox bug, and I am glad to see they will be fixing it.

Thanks again.

Cela vous a-t-il été utile ?

more options

You can try to set these two prefs:

  • pdfjs.pageColorsBackground => #FFF
  • pdfjs.pageColorsForeground => #000

Cela vous a-t-il été utile ?

  1. 1
  2. 2
Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.