Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

unable to turn off Safe Search in Bing

more options

unable to turn off safe search when using Bing search. After clicking the more bars on the Bing search page and setting safe search to off, when checking if it is off, it has reverted to moderate. Firefox is vs 96.0.1. Setting is set to normal, not strict. Windows 10 preferences are set to safe search off. All caches have been cleared. I took off all extensions, ran malware bytes & cccleaner & anti-virus scan. I tried a refresh of Firefox. Nothing has helped.

Using Edge or Chrome browsers on the Bing search page, Safe search turns off as it should.

--There was a power failure, last night, which knocked off my computer.  That may or may not be related.  However, with both Edge and Chrome accessing Bing okay, it seems to definitely be a Firefox problem?
unable to turn off safe search when using Bing search. After clicking the more bars on the Bing search page and setting safe search to off, when checking if it is off, it has reverted to moderate. Firefox is vs 96.0.1. Setting is set to normal, not strict. Windows 10 preferences are set to safe search off. All caches have been cleared. I took off all extensions, ran malware bytes & cccleaner & anti-virus scan. I tried a refresh of Firefox. Nothing has helped. Using Edge or Chrome browsers on the Bing search page, Safe search turns off as it should. --There was a power failure, last night, which knocked off my computer. That may or may not be related. However, with both Edge and Chrome accessing Bing okay, it seems to definitely be a Firefox problem?

Solution choisie

Note that this can also be a macOS thing (parental setting).

Does this happen on sites like YouTube as well ?

Also make sure you do not block cookies.

There is a change in Firefox 96 related to cookies and insecure sites.

See also:

As a workaround for now you can modify this pref on the about:config page to revert this change to see if that has effect. .

  • about:config => network.cookie.sameSite.laxByDefault = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Lire cette réponse dans son contexte 👍 1

Toutes les réponses (7)

more options

Note: Sudden power loss can damage or destroy a hard drive's data.

Go to your local department/electronics store and look around for a UPS (Uninterruptible Power Supply) that is useful for you. The lowest price is $50 +. There are also units on the market that plug into the computer. So, if the battery gets low, it will shut down the computer to protect it.


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Cela vous a-t-il été utile ?

more options

Thanks, Fred.

As I posted, I did the clear cache and cookies as well as tried the Firefox refresh. I also disable the Hardware Acceleration. Nothing has made a difference.

Is the only thing left a complete uninstall and reinstall? I read that someone else was having the same problem with version 96. It is only my Firefox browser that is not playing nicely with Bing Safe Search.

Ideas? Thank you.

Cela vous a-t-il été utile ?

more options

Solution choisie

Note that this can also be a macOS thing (parental setting).

Does this happen on sites like YouTube as well ?

Also make sure you do not block cookies.

There is a change in Firefox 96 related to cookies and insecure sites.

See also:

As a workaround for now you can modify this pref on the about:config page to revert this change to see if that has effect. .

  • about:config => network.cookie.sameSite.laxByDefault = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Cela vous a-t-il été utile ?

more options

Bingo! cor-el!

the about:config => network.cookie.sameSite.laxByDefault = false fixed it.

Don't know its purpose but changing it from "true" to "false" solved the problem. can now toggle the Bing Safe Search "on" or "off" as required.

Thank You!

Cela vous a-t-il été utile ?

more options

My problem is when changing from Moderate to Strict or Off it will change OK but then if I click on the search again or change from any of the modes or suggestions it will revert to Moderate.

In other words if I click on any button within the red square on the image I uploaded it will revert to Moderate.

I've tried the suggested fixes but no luck.

Cela vous a-t-il été utile ?

more options

Hi player120948, I think the earlier discussion is about setting the default value in Bing's Settings > More (https://www.bing.com/account/general).

If your Image search page doesn't match your default setting, please start a new Firefox question at https://support.mozilla.org/questions/new/desktop/form or maybe ask Bing what is going on there.

Cela vous a-t-il été utile ?

more options

Alternately, you can keep the general setting on true and add Bing to the exceptions list until they update how they send their cookies to Firefox.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(B) In the search box in the page, type or paste laxByDefault and pause while the list is filtered

Firefox should list two matching preferences:

  • network.cookie.sameSite.laxByDefault
  • network.cookie.sameSite.laxByDefault.disabledHosts

(C) Double-click network.cookie.sameSite.laxByDefault to toggle it back to true (or click the toggle button at the right end of the row)

(D) Double-click the network.cookie.sameSite.laxByDefault.disabledHosts preference to display an editing field, and enter www.bing.com and then press Enter or click the blue check mark button to save the change.

Can you save changes on Bing after that?

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.