Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Some website pages displaying many ??????? instead of what should be there

  • 10 réponses
  • 1 a ce problème
  • 40 vues
  • Dernière réponse par cor-el

more options

I have the latest version and when using Firefox I get often many ???????????????????? appearing instead of the words

How can I sot this ?

Toutes les réponses (10)

more options

Is this with all websites/pages, some, a few?

Does it look like there should be printing where the ? are located? That could be an issue with fonts.


[v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Cela vous a-t-il été utile ?

more options

Hello

I have added a screen shot of the ???? I have checked the options you suggested and all seems to be ok

I think this may be occurring when clicking a link within an email that takes me to firefox

Thanks

Cela vous a-t-il été utile ?

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Cela vous a-t-il été utile ?

more options

Hello - after selecting Start In Troubleshoot(Safe) Mode the issue was not there, but when I reverted the issue came back

I cleared cache, cookies as suggested and issue was still remaining

Thanks Andrew

Cela vous a-t-il été utile ?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Cela vous a-t-il été utile ?

more options

Hello

I disabled the Hardware Acceleration and there was no change

I disabled all add-ons and restarted FF and there was no change

Thanks Andrew

Cela vous a-t-il été utile ?

more options

Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

Cela vous a-t-il été utile ?

more options

Hello

Deleted all history, search and download, restarted FF and the issue is still occurring

Is there anything else i can try ?

Thanks Andrew

Cela vous a-t-il été utile ?

more options

Cela vous a-t-il été utile ?

more options

This can happen if the font that is requested is corrupted or otherwise can't be accessed, possibly because the font is under control of a third-party font manager and is located in a non standard location. If Firefox isn't able to access the requested font then it falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'.

You can check in Font Book for font issues like corrupted and duplicate fonts.


You can right-click and select "Inspect Element" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.