Ce site disposera de fonctionnalités limitées pendant que nous effectuons des opérations de maintenance en vue de vous proposer un meilleur service. Si un article ne règle pas votre problème et que vous souhaitez poser une question, notre communauté d’assistance est prête à vous répondre via @FirefoxSupport sur Twitter, et /r/firefox sur Reddit.

Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Remove Search function in Address Bar

more options

Hello. After reading numerous posts addressing similar issues & having no success, I've decided to post a question of my own. I am running the current version of firefox, 94.0.2. I use the Search Bar religiously for searches to sites like google, wikipedia, youtube, amazon, and ebay. I NEVER use the address bar for searches. I have attempted to disable all functionality associated with searching via the address bar. When I go to the address bar, it is because I have a specifc url I know I want to type with a specific destination in mind. Occasionally, I have a need to just go to the home page of one of my search sites, most often it's amazon.com. Recently (not sure which version of firefox) I've found when I go to the Address Bar & type amazon.com, I cannot just go to amazon.com, instead the address bar turns into a search bar. How do I disable this? Its driving me mad! I swear I've disabled every option I can within about:config related to urlb. Please Help. I don't want to switch to Chrome, but I'm tired of my settings getting messed up every time mozilla pushes a new version.

Hello. After reading numerous posts addressing similar issues & having no success, I've decided to post a question of my own. I am running the current version of firefox, 94.0.2. I use the '''Search Bar''' religiously for searches to sites like google, wikipedia, youtube, amazon, and ebay. I NEVER use the address bar for searches. I have attempted to disable all functionality associated with searching via the address bar. When I go to the address bar, it is because I have a specifc url I know I want to type with a specific destination in mind. Occasionally, I have a need to just go to the home page of one of my search sites, most often it's amazon.com. Recently (not sure which version of firefox) I've found when I go to the '''Address Bar''' & type amazon.com, I cannot just go to amazon.com, instead the address bar turns into a search bar. How do I disable this? Its driving me mad! I swear I've disabled every option I can within about:config related to '''urlb'''. Please Help. I don't want to switch to Chrome, but I'm tired of my settings getting messed up every time mozilla pushes a new version.

Solution choisie

I think I figured it out. Within the Privacy & Security settings, there's a heading called Address Bar - Firefox Suggest. When I disable everything under that heading, my issue appears to go away. I never thought to look under Privacy & Security, thinking my solution should either be within the Search settings or somewhere in about:config. This question can be closed. Thanks.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (4)

more options

You need to set keyword.enabled = false on the about:config page to disable searching via the location bar.

more options

I did that. I set keyword.enabled to 'false' long ago and it didn't work. I've been all through about:config setting random things to 'false'. Some include the following: browser.search.suggest.enabled browser.urlbar.oneOffsearches browser.urlbar.searchSuggestionsChoice browser.urlbar.shortcuts.bookmarks, ...history, ...tabs, browser.urlbar.suggest.bookmarks, ...history, ...openpage, ...searches, ...topsites browser.urlbar.update1, ...interventions, ...searchtips services.sync.prefs.sync.browser.urlbar.suggest.searches

more options

I never go there but I tried amazon. com (without the space) in the address bar and it went there so I don't know why you have that issue. You could try troubleshoot mode or a new profile. https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles

more options

Solution choisie

I think I figured it out. Within the Privacy & Security settings, there's a heading called Address Bar - Firefox Suggest. When I disable everything under that heading, my issue appears to go away. I never thought to look under Privacy & Security, thinking my solution should either be within the Search settings or somewhere in about:config. This question can be closed. Thanks.