Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

The latest firefox: close, Minimize, restore order doesn't appear the same order as the system, Mojave-light theme is used.

  • 4 réponses
  • 1 a ce problème
  • 25 vues
  • Dernière réponse par 1539908400

more options

Hi experts,

I installed the latest firefox 91.2.0esr (64-bit) yesterday on OS centos 7.9, and use the Mojave-light theme. I change the close, maximize, minimize to the left top corner of each window and change such order under dconf-editor. Remember, my order is: close, maximize, minimize, (red, green, yellow), NOT close, minimize, maximize,(red, yellow, green).

Actual results:

The actual result is that: only firefox doesn't take effect. Only firefox window has the WRONG order: close, minimize, maximize. (red, yellow, green)

Expected results:

It should be: close, maximize, minimize (red, green, and yellow)

or:

how to change the order of close, maximize, minimize in the userChrome.css?

PS1: changing to the default theme, or using safe-mode doesn't work.

Hi experts, I installed the latest firefox 91.2.0esr (64-bit) yesterday on OS centos 7.9, and use the Mojave-light theme. I change the close, maximize, minimize to the left top corner of each window and change such order under dconf-editor. Remember, my order is: close, maximize, minimize, (red, green, yellow), NOT close, minimize, maximize,(red, yellow, green). Actual results: The actual result is that: only firefox doesn't take effect. Only firefox window has the WRONG order: close, minimize, maximize. (red, yellow, green) Expected results: It should be: close, maximize, minimize (red, green, and yellow) or: how to change the order of close, maximize, minimize in the userChrome.css? PS1: changing to the default theme, or using safe-mode doesn't work.
Captures d’écran jointes

Modifié le par 1539908400

Solution choisie

Hello,

I do not know if there is a direct fix for you. I do not use MacOS, so I can only assume that your Firefox is similar.

In the customize menu (article about it is below) on GNU/Linux distributions and on Windows, there is an option for title bar, which tells Firefox to forfeit it's custom window decorations for the desktop environment to deal with, which in your case (assuming that title bar is an option), should force Firefox to use your preferences.

Visit this article to learn how to customize your toolbar (plus other customization tips!)

Did this fix the problem? Please report back to us!

Thank you.

Edit: I did not completely grasp that you were running centos, so I assumed you were running macos. I apologize for any confusion that I may have caused there

Lire cette réponse dans son contexte 👍 1

Toutes les réponses (4)

more options

Solution choisie

Hello,

I do not know if there is a direct fix for you. I do not use MacOS, so I can only assume that your Firefox is similar.

In the customize menu (article about it is below) on GNU/Linux distributions and on Windows, there is an option for title bar, which tells Firefox to forfeit it's custom window decorations for the desktop environment to deal with, which in your case (assuming that title bar is an option), should force Firefox to use your preferences.

Visit this article to learn how to customize your toolbar (plus other customization tips!)

Did this fix the problem? Please report back to us!

Thank you.

Edit: I did not completely grasp that you were running centos, so I assumed you were running macos. I apologize for any confusion that I may have caused there

Modifié le par Amelia

more options

Hi andmagdo:

This is fantastic solution! After click on the title-bar, it returns to the system setup.

Really appreciated!

Cheers, Yingjie

more options

Note that this question is about using a special them on Linux.

I'm not sure if you can use code in userChrome.css to reorder the window control in the title bar (i.e. the title bar is visible; browser.tabs.drawInTitlebar = true). If the title bar is hidden then the buttons either appear on the menu bar or on the tab bar.


.titlebar-close {-moz-box-ordinal-group:1}
.titlebar-max, .titlebar-restore {-moz-box-ordinal-group:2}
.titlebar-min {-moz-box-ordinal-group:3}
more options

Hi cor-el:

Thanks a lot! This also could help!

Cheers, Yingjie