Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Screen objects misplaced on some sites

  • 9 réponses
  • 1 a ce problème
  • 27 vues
  • Dernière réponse par cor-el

more options

Using Firefox (92.0) on Win 10. I have noticed that some screen objects are displayed in different ways on Firefox than they are on Edge (and I presume other browsers). For a long time I thought the problem was errors in the Rite Aid web design. Yesterday I saw a similar problem on another site and decided to try another browser. The displays looked proper on Edge. See attached image which shows the same screen on the Edge browser (top) and Firefox (bottom). Part of the logon window is missing on Firefox. Other objects are affected also such as text size. I don't see any options in the Firefox config that would apply to this.

Toutes les réponses (9)

more options


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Please label what browser for each picture.

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there? also see

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

The image I tried to append to the report failed to upload -- just hung while indicating uploading. Uploading succeeded this time. The top screen shot is from the Edge browser. The bottom image is from Firefox.

more options

I think this is related to a zoom change or font face/size override.

For example, the drop-down are the wrong width if I check the box for "Zoom text only" in the Zoom section of the Settings page. (Screenshot attached) However, if I uncheck that, it's fine. Do you use that setting?

more options

I tried playing with the zoom and it did have some effect, but didn't solve the problem. I've attached another collage of screen shots from another site which has a more pronounced effect because of the way it's designed. I blocked out personal info. My guess is that these sites are using a feature for locating objects that Firefox doesn't recognize.

more options

Don't ask me why, but that problem on the Aon site appears to be caused by disabling pages from choosing their own fonts. Try restoring the default setting:

more options

That does seem to correct the Aon site. It also changes the behavior of the Rite Aid site, but not for the better. I'll play with it some more tomorrow. Thanks for your help.

more options

So I have played with it some more. I restored all settings to default and there is still a problem with the Rite Aid site. Photo attached. Aon is working as expected. I'm not aware of problems on any other sites. I'm willing to drop the issue although I'm curious if you have tried the Rite Aid site and what results you got. Thanks again for the assistance.

more options

Note that modifying the default font size from 'none' can cause issues.

If you have made changes to Advanced font-size settings like increasing the minimum/default font-size then try the Default font-size setting "16" and the Minimum font-size setting "none" in case the current setting is causing the problem.

  • Settings -> General: Fonts & Colors -> Advanced -> Minimum Font Size (none)

Make sure you allow pages to choose their own fonts.

  • Settings -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of your selections above"

It is better not to increase the minimum font-size, but to use the built-in Firefox Zoom feature.

  • Settings -> General -> Language and Appearance -> Zoom