On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Need help with my userChrome.css and window controls

  • 4 réponses
  • 1 a ce problème
  • 33 vues
  • Dernière réponse par cor-el

more options

I'm trying to get Firefox to obey my window control order. For me, the window controls are on the left with the order of Close, Maximize, Minimize. But Firefox does not like that and puts it like macOS with Close, Minimize, Maximize.

So I got this going

#TabsToolbar {
  direction: ltr;
}

#tabbrowser-tabs {
  direction: ltr;
}

.titlebar-buttonbox {
  display: flex;
}

.titlebar-min {
  order: 2;
}

.titlebar-max {
  order: 1;
}

And it works well. But here is the problem, when the window becomes Maximized, the order changes to Maximize, Close, Minimize, as seen here in the photo. Anyone got some advice?

I'm trying to get Firefox to obey my window control order. For me, the window controls are on the left with the order of Close, Maximize, Minimize. But Firefox does not like that and puts it like macOS with Close, Minimize, Maximize. So I got this going <pre><nowiki>#TabsToolbar { direction: ltr; } #tabbrowser-tabs { direction: ltr; } .titlebar-buttonbox { display: flex; } .titlebar-min { order: 2; } .titlebar-max { order: 1; } </nowiki></pre><br> And it works well. But here is the problem, when the window becomes Maximized, the order changes to Maximize, Close, Minimize, as seen here in the photo. Anyone got some advice?
Captures d’écran jointes

Modifié le par cor-el

Toutes les réponses (4)

more options

I am unable to edit my comment, but I didn't paste the proper userChrome.css file

This is the code I am actually playing with:

  1. tabbrowser-tabs {
 direction: ltr;

}

.titlebar-buttonbox {

 display: flex;

}

.titlebar-min {

 order: 3;

}

.titlebar-max {

 order: 2;

} .titlebar-close {

 order: 1;

}

more options

In full screen mode you do not use .titlebar-buttonbox (.titlebar-buttonbox-container), but you use #window-controls.

#TabsToolbar[inFullscreen] #window-controls


Modifié le par cor-el

more options

cor-el said

In full screen mode you do not use .titlebar-buttonbox (.titlebar-buttonbox-container), but you use #window-controls.
#TabsToolbar[inFullscreen] #window-controls


Thank you. I tried this code but the same result happened:

  1. tabbrowser-tabs {
 direction: ltr;

}

.titlebar-buttonbox {

 display: flex;

}

.titlebar-min {

 order: 3;

}

.titlebar-max {

 order: 2;

} .titlebar-close {

 order: 1;

}

  1. TabsToolbar[inFullscreen] #window-controls {
 direction: ltr;

}

.titlebar-buttonbox {

 display: flex;

}

.titlebar-min {

 order: 3;

}

.titlebar-max {

 order: 2;

} .titlebar-close {

 order: 1;

}

more options

You need different selectors for the individual window-controls as you can see if you use the Browser Toolbox to inspect the controls.