Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Fedora 34, Ffx 'new window' brings up all my initial tabs. How to fix this

more options

In Windows 10, when I hit 'new window' it brings up a browser with only 1 tab. In Fedora 34 Ffx when I hit 'new window' it brings up all my 5 initial startup tabs. I don't want this. I want it to behave the way it does in Windows 10. Any way to fix this? https://imgur.com/ovKf0Sx Why is this behavior different in Fedora 34 Linux?

Is the a Ffx add-on extension plug-in that fixes this? If yes, let me know. Thx.

In Windows 10, when I hit 'new window' it brings up a browser with only 1 tab. In Fedora 34 Ffx when I hit 'new window' it brings up all my 5 initial startup tabs. I don't want this. I want it to behave the way it does in Windows 10. Any way to fix this? https://imgur.com/ovKf0Sx Why is this behavior different in Fedora 34 Linux? Is the a Ffx add-on extension plug-in that fixes this? If yes, let me know. Thx.

Solution choisie

By chance I found the solution. Create a new default tab, right click on that tab, click on 'Move Tab' then click on 'Move to New Window'. Then that tab appears in a new browser instance with no other tabs. A little clunky but at least it works.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (8)

more options

I'm using the latest version of Ffx.

more options

I'm in openSUSE and cannot replicate the issue. see screenshot Are you in KDE or Gnome? Can you try downloading a separate copy and run it from the folder to see if you have the same issue? Also, try it from another user account.

Pick a version https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

I think that you should always get all pages set as multiple home pages when you open a new window, so you may have an extension on the Windows Firefox to open only the first page.

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Solution choisie

By chance I found the solution. Create a new default tab, right click on that tab, click on 'Move Tab' then click on 'Move to New Window'. Then that tab appears in a new browser instance with no other tabs. A little clunky but at least it works.

Modifié le par jaiamma@gmail.com

more options

Note that you simply can drag the tab down in the browser area to tear this tab off to a new window (unless you have disabled this tear off feature).

more options

Note that you can also create an about:blank bookmark and Shift left-click this bookmark to open a blank window.

more options

cor-el said

Note that you simply can drag the tab down in the browser area to tear this tab off to a new window (unless you have disabled this tear off feature).

I have tear off tabs enabled, but it didn't work. I tried dozens of times to tear off a tab and drag it to a new window, but it only worked about 1 time out of 20. And I couldn't see why it worked. I repeat the same action but didn't work. The context menu on the tab works reliably.

more options

cor-el said

Note that you can also create an about:blank bookmark and Shift left-click this bookmark to open a blank window.

I tried your suggestion and it works great, but I like the bookmarks row to be hidden. And going thru the main menu is more steps. And I like seeing the new tab with my default content (recent sites and Pocket suggestions).