Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

cannot connect to any https sites: secure connection failed, PR_END_OF_FILE_ERROR

  • 9 réponses
  • 1 a ce problème
  • 41 vues
  • Dernière réponse par cor-el

more options

Since today, whenever I want to open an https site in Firefox, it fails with PR_END_OF_FILE_ERROR, even for the mozilla support files, so I am writing this on Chromium. I am having this problem on two Debian laptops with FF 78.11.0esr. I followed the advice given in https://support.mozilla.org/en-US/questions/1317824#question-reply, but I do not understand why I have to set security.tls.version.max to 3 instead of the default 4. Why is the default 4 in the first place, what does it mean and what are the consequences of changing it to 3? Doesn't the need for such a hack suggest that there is a problem somewhere else?

Toutes les réponses (9)

more options

Update: On one of my laptops, I actually had to set security.tls.version.min to 2 (standard is 3), otherwise I was getting timeout errors on https sites.

more options

The numbers for security.tls.version.min and security.tls.version.max mean:

  • 4 => TLS 1.3
  • 3 => TLS 1.2
  • 2 => TLS 1.1 (deprecated as no longer secure)
  • 1 => TLS 1.0 (deprecated as no longer secure)

Usually a problem with negotiating between TLS 1.3 and 1.2 would only affect a very few sites, and perhaps now and then you might encounter a site that can't run TLS 1.2. If you have this problem for multiple sites operated by different companies/hosts, it could be that a proxy server or other "man in the middle" is not handling that correctly.

more options

Thanks a lot! Is there a way to find out what might be the problem then? And why it only happens on Firefox? I can access all sites just fine using Chromium. I am on Linux, don't use a proxy server and don't have any third party antivirus running on my home laptop.

more options

If you haven't already, try clearing the web cache and doing a regular quit/restart: How to clear the Firefox cache (don't clear cookies and site data, just cached web content).

To rule out a proxy issue --

  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

At the top of the panel, select "No proxy".


Otherwise, could an add-on be a factor? You could test in Firefox's Safe/Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

more options

Thanks for the detailed instructions! So, it seems that despite my security.tls.version.max = 3 setting, I still have trouble on and off accessing https-sites, sometimes it takes awfully long, times out, and sometimes I still get the PR_END_OF_FILE_ERROR.

I had tried clearing the cache before, and I just followed your instructions again, but no difference. I confirm that "no proxy" was already chosen. I had also tried the safe mode before, which also did not fix it. Even creating a new profile did not help. As long as security.tls.version.max = 4, I cannot open any https-sites. Now, with security.tls.version.max = 3, it only seems to fail periodically, mostly with https://duckduckgo.com/. But the browser still takes an awful long time. I have also been noticing trouble with vpn connections since yesterday, and on one of my computers, I haven't been able to send emails from Thunderbird using imap until a reboot, so I wonder if there was some SSH/TLS-related update in linux that causes all the trouble.

more options
more options

Thanks, no malware found, but then I found out that I had none of these problems when on a different network. These problems only seemed to occur on my home network. I unplugged my server and restarted the router and now the problems are gone, even with security.tls.version.max = 4. I really don't understand what was going on, but it seems to work again.

more options

UPDATE: no, it does not work again. Still receiving the PR_END_OF_FILE_ERROR on some https-sites and just time-outs on others. Why only on my home network, why only Firefox? Is there a way to gather more information on what might be the reason?

more options