Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Cannot cancel dark mode in Firefox windows

  • 5 réponses
  • 2 ont ce problème
  • 777 vues
  • Dernière réponse par cor-el

more options

I cannot get Firefox to stop using dark mode. I've tried uninstalling and reinstalling, checking my Mac's settings (dark mode is not enabled), and Firefox still shows dark mode in webpages (like Google News). It makes it really hard to read the page without reading glasses.

Is there a way to turn this off? It is really irritating.

I cannot get Firefox to stop using dark mode. I've tried uninstalling and reinstalling, checking my Mac's settings (dark mode is not enabled), and Firefox still shows dark mode in webpages (like Google News). It makes it really hard to read the page without reading glasses. Is there a way to turn this off? It is really irritating.
Captures d’écran jointes

Solution choisie

Hey, you cant try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste ui.systemUsesDarkTheme and pause while the list is filtered.

(3) If there is no variable like this, add a new one and set its number value to 0.

I suspect you would need to quit/restart Firefox to update the internal reading. Does it work now?

Lire cette réponse dans son contexte 👍 2

Toutes les réponses (5)

more options

Solution choisie

Hey, you cant try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste ui.systemUsesDarkTheme and pause while the list is filtered.

(3) If there is no variable like this, add a new one and set its number value to 0.

I suspect you would need to quit/restart Firefox to update the internal reading. Does it work now?

more options

No, I'm sorry it didn't. The background remains black despite setting the value to "true" or "false" (there isn't a value of 0.

more options

ben-marko said

No, I'm sorry it didn't. The background remains black despite setting the value to "true" or "false" (there isn't a value of 0.

Oops, the preference got created as a Boolean (true/false) type, but it needs to be a Number type. You can use the trash can at the right end of the row to delete the preference, then select Number before clicking the + button and assign the value of 0 using the form that opens.

more options

Yes! Deleting the value and then inserting a new numerical one worked. It changed the color from dark to light. Thank you!

more options