On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

How to re-disable TLSv1.0?

more options

I tried to visit a website on a private network.

Firefox threw up a security warning about how the web page uses TLSv1.0.

I clicked on the "Enable TLS v1.0" button because I wanted to temporarily view the web page, so that I can look at the TLS certificate to debug an unrelated issue about the cert chain on this site.

Now I want to go back to the default settings, where Firefox blocks TLSv1.0.

How do I do that?

In about:config I looked at security.tls.version.min but it's still on the original value of 3. Yet Firefox is still letting me view that particular page over TLSv1.0 without the security warning.

I tried to visit a website on a private network. Firefox threw up a security warning about how the web page uses TLSv1.0. I clicked on the "Enable TLS v1.0" button because I wanted to temporarily view the web page, so that I can look at the TLS certificate to debug an unrelated issue about the cert chain on this site. Now I want to go back to the default settings, where Firefox blocks TLSv1.0. How do I do that? In about:config I looked at security.tls.version.min but it's still on the original value of 3. Yet Firefox is still letting me view that particular page over TLSv1.0 without the security warning.

Solution choisie

Hi Matthew, I'm not sure what preferences are changed when you enable TLS 1.0, but could you take a look here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste TLS and pause while the list is filtered

(3) At the right end of each row that is bolded, indicating that it has been modified, click the arching left-pointing arrow reset button to restore the default value for the preference -- in particular, look for security.tls.version.enable-deprecated

More info on about:config: Configuration Editor for Firefox.

Does that fix it -- meaning, you get the old error message again?

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (3)

more options

Here is a printscreen of the original error screen, which is no longer appearing.

more options

Solution choisie

Hi Matthew, I'm not sure what preferences are changed when you enable TLS 1.0, but could you take a look here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste TLS and pause while the list is filtered

(3) At the right end of each row that is bolded, indicating that it has been modified, click the arching left-pointing arrow reset button to restore the default value for the preference -- in particular, look for security.tls.version.enable-deprecated

More info on about:config: Configuration Editor for Firefox.

Does that fix it -- meaning, you get the old error message again?

more options

Yep, `security.tls.version.enable-deprecated` was the setting that was changed. Now I've set that back to the default value of false, and the TLS warnings return.

Thanks!